aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-19 00:33:34 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-19 00:33:34 +0000
commitb2831e9c3db3fb705779bb9b50c0e3dcc09fb897 (patch)
treed74213eeafecea53c60653c95ca6da86f7e04a60
parent242f353a9a32922b810d666420d81880f8bf2bbc (diff)
Notes
-rw-r--r--emulators/pipelight/Makefile7
-rw-r--r--emulators/pipelight/files/patch-src_linux_libpipelight_configloader.c17
2 files changed, 22 insertions, 2 deletions
diff --git a/emulators/pipelight/Makefile b/emulators/pipelight/Makefile
index 2cafc220e1e2..a7bcc11d6c29 100644
--- a/emulators/pipelight/Makefile
+++ b/emulators/pipelight/Makefile
@@ -57,8 +57,11 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/wine:${PORTSDIR}/emulators/i386-wine-staging
.endif
pre-configure:
- ${LN} -s ${DISTDIR}/${DIST_SUBDIR}/pluginloader.tar.gz ${WRKSRC}/pluginloader-v${DISTVERSION}.tar.gz
- ${LN} -s ${DISTDIR}/${DIST_SUBDIR}/pluginloader.tar.gz.sig ${WRKSRC}/pluginloader-v${DISTVERSION}.tar.gz.sig
+ ${LN} -s ${DISTDIR}/${DIST_SUBDIR}/pluginloader.tar.gz \
+ ${WRKSRC}/pluginloader-v${DISTVERSION}.tar.gz
+ ${LN} -s ${DISTDIR}/${DIST_SUBDIR}/pluginloader.tar.gz.sig \
+ ${WRKSRC}/pluginloader-v${DISTVERSION}.tar.gz.sig
+ ${MKDIR} ${WRKDIR}/.gnupg
post-stage:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/pipelight/libpipelight.so
diff --git a/emulators/pipelight/files/patch-src_linux_libpipelight_configloader.c b/emulators/pipelight/files/patch-src_linux_libpipelight_configloader.c
new file mode 100644
index 000000000000..822452113622
--- /dev/null
+++ b/emulators/pipelight/files/patch-src_linux_libpipelight_configloader.c
@@ -0,0 +1,17 @@
+--- src/linux/libpipelight/configloader.c.orig 2015-01-11 04:48:05 UTC
++++ src/linux/libpipelight/configloader.c
+@@ -46,6 +46,7 @@
+ #include <string> // for std::string
+ #include <map> // for std::map
+ #include <dlfcn.h>
++#include <errno.h>
+
+ #include "common/common.h"
+ #include "configloader.h"
+@@ -663,4 +664,4 @@ bool loadPluginInformation(){
+ err:
+ fclose(file);
+ return false;
+-}
+\ No newline at end of file
++}