aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-09-05 02:30:19 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-09-05 02:30:19 +0000
commitb291c01064bdd0ecff047e794a1173d89641fe6f (patch)
treed7766daeb09a1011fe1997089187d9945616d5ac
parent110eef605f02469d5fd0a4ea7c3e12f01e0ce603 (diff)
downloadports-b291c01064bdd0ecff047e794a1173d89641fe6f.tar.gz
ports-b291c01064bdd0ecff047e794a1173d89641fe6f.zip
- rename nc to netcat to prevent /usr/bin/nc from shadowing
/usr/local/bin/nc PR: ports/11970 Submitted by: Jonathan Liu <Net147@hotmail.com> Approved by: maintainer timeout (sumikawa ; 960 days)
Notes
Notes: svn path=/head/; revision=260572
-rw-r--r--UPDATING6
-rw-r--r--net/netcat/Makefile12
-rw-r--r--net/netcat/files/nc.112
3 files changed, 18 insertions, 12 deletions
diff --git a/UPDATING b/UPDATING
index c6ed1d4d5435..02920a0fb4ae 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,12 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20100904
+ AFFECTS: net/netcat
+ AUTHOR: pgollucci@FreeBSD.org
+
+ Rename nc to netcat to prevent /usr/bin/nc shadowing /usr/local/bin/nc
+
20100902:
AFFECTS: users of KDE4
AUTHOR: kde@FreeBSD.org
diff --git a/net/netcat/Makefile b/net/netcat/Makefile
index cfb868dba32b..39a59bdf41f4 100644
--- a/net/netcat/Makefile
+++ b/net/netcat/Makefile
@@ -8,7 +8,7 @@
PORTNAME= netcat
PORTVERSION= 1.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net ipv6
MASTER_SITES= ftp://coast.cs.purdue.edu/pub/tools/unix/netutils/netcat/ \
ftp://ftp.cuhk.edu.hk/pub/packages/security/purdue/netutils/netcat/ \
@@ -30,9 +30,9 @@ OPTIONS= IPV6 "enable IPv6 support" on \
TELNET "enable TELNET support" on \
GAPING "enable GAPING_SECURITY_HOLE support" on
-PLIST_FILES= bin/nc
+PLIST_FILES= bin/netcat
PORTDOCS= README
-MAN1= nc.1
+MAN1= netcat.1
.include <bsd.port.pre.mk>
@@ -48,11 +48,11 @@ XFLAGS+= -DTELNET
XFLAGS+= -DGAPING_SECURITY_HOLE
.endif
-MAKE_ENV= XFLAGS="$(XFLAGS)"
+MAKE_ENV= XFLAGS="${XFLAGS}"
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/nc ${PREFIX}/bin
- ${INSTALL_MAN} ${FILESDIR}/nc.1 ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/nc ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${FILESDIR}/nc.1 ${PREFIX}/man/man1/${MAN1}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
diff --git a/net/netcat/files/nc.1 b/net/netcat/files/nc.1
index 8b4379f1652a..43da468e3754 100644
--- a/net/netcat/files/nc.1
+++ b/net/netcat/files/nc.1
@@ -1,11 +1,11 @@
-.TH NC 1
+.TH NETCAT 1
.SH NAME
-nc \- TCP/IP swiss army knife
+netcat \- TCP/IP swiss army knife
.SH SYNOPSIS
-.B nc
+.B netcat
.I "[-options] hostname port[s] [ports] ..."
.br
-.B nc
+.B netcat
.I "-l -p port [-options] [hostname] [port]"
.SH "DESCRIPTION"
.B netcat
@@ -15,11 +15,11 @@ reliable "back-end" tool that can be used directly or easily driven by
other programs and scripts. At the same time, it is a feature-rich
network debugging and exploration tool, since it can create almost any
kind of connection you would need and has several interesting built-in
-capabilities. Netcat, or "nc" as the actual program is named, should
+capabilities. Netcat, or "netcat" as the actual program is named, should
have been supplied long ago as another one of those cryptic but
standard Unix tools.
.P
-In the simplest usage, "nc host port" creates a TCP connection to the
+In the simplest usage, "netcat host port" creates a TCP connection to the
given port on the given target host. Your standard input is then sent
to the host, and anything that comes back across the connection is
sent to your standard output. This continues indefinitely, until the