aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-23 19:10:37 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-23 19:10:37 +0000
commitb382f19a831a050b2dcd49330fa7da840211ce73 (patch)
tree2a4d4a9d222eb1312007d52b34dc7065919f7783
parent3480e7a9a73f873b5d0b6084029da32b8949984d (diff)
- Add spdylay 1.1.0
Spdylay - SPDY C Library This is an experimental implementation of Google's SPDY protocol in C. This library provides SPDY version 2 and 3 framing layer implementation. It does not perform any I/O operations. When the library needs them, it calls the callback functions provided by the application. It also does not include any event polling mechanism, so the application can freely choose the way of handling events. This library code does not depend on any particular SSL library (except for example programs which depend on OpenSSL 1.0.1 or later). This project also develops SPDY client, server and proxy on top of Spdylay library. WWW: http://spdylay.sourceforge.net/
Notes
Notes: svn path=/head/; revision=331414
-rw-r--r--www/Makefile1
-rw-r--r--www/spdylay/Makefile60
-rw-r--r--www/spdylay/distinfo2
-rw-r--r--www/spdylay/pkg-descr14
-rw-r--r--www/spdylay/pkg-plist13
5 files changed, 90 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b482af25bad8..e9876c7ba61e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1868,6 +1868,7 @@
SUBDIR += snarf
SUBDIR += snownews
SUBDIR += spawn-fcgi
+ SUBDIR += spdylay
SUBDIR += speedtest-mini
SUBDIR += spreadlogd
SUBDIR += sqstat
diff --git a/www/spdylay/Makefile b/www/spdylay/Makefile
new file mode 100644
index 000000000000..2487e5758764
--- /dev/null
+++ b/www/spdylay/Makefile
@@ -0,0 +1,60 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= spdylay
+PORTVERSION= 1.1.0
+CATEGORIES= www net
+MASTER_SITES= SF/${PORTNAME}/stable/${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= SPDY protocol version 2 and 3 implementation in C
+
+LICENSE= MIT
+
+OPTIONS_DEFINE= SHRPX
+OPTIONS_SUB= yes
+SHRPX_DESC= Build shrpx (HTTP reverse proxy), requires OpenSSL 1.0.1+
+
+CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
+ OPENSSL_LIBS="-L${OPENSSLLIB} -lssl" \
+ ZLIB_CFLAGS="-I${INCLUDEDIR}" \
+ ZLIB_LIBS="-L${LIBDIR} -lz"
+GNU_CONFIGURE= yes
+USE_CXXSTD= c++11
+USE_GNOME= libxml2
+USE_LDCONFIG= yes
+USE_OPENSSL= yes
+USE_XZ= yes
+USES= compiler:c++11-lang pathfix pkgconfig
+
+PORTDOCS= README.rst
+
+.include <bsd.port.pre.mk>
+
+# Only build shrpx on FreeBSD 10 and above
+.if ${PORT_OPTIONS:MSHRPX} && ${OSVERSION} < 1000000 && !defined(WITH_OPENSSL_PORT)
+IGNORE= shrpx requires libevent_openssl.so (devel/libevent2) built with OpenSSL 1.0.1+
+.endif
+
+# spdylay requires OpenSSL 1.0.1+
+.if ${OSVERSION} < 1000000
+WITH_OPENSSL_PORT= yes
+.endif
+
+.if ${PORT_OPTIONS:MSHRPX}
+LIB_DEPENDS+= libevent_openssl.so:${PORTSDIR}/devel/libevent2
+CONFIGURE_ARGS+=--enable-examples
+CONFIGURE_ENV+= LIBEVENT_OPENSSL_CFLAGS="-I${LOCALBASE}" \
+ LIBEVENT_OPENSSL_LIBS="-L${LOCALBASE}/lib/event2 -levent_openssl"
+.endif
+
+post-build:
+ @${STRIP_CMD} ${WRKSRC}/lib/.libs/libspdylay.so.6
+
+post-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/examples/spdycli ${STAGEDIR}${PREFIX}/bin/
+.if ${PORT_OPTIONS:MSHRPX}
+ @${INSTALL_DATA} ${WRKSRC}/shrpx.conf.sample ${STAGEDIR}${PREFIX}/etc/
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/spdylay/distinfo b/www/spdylay/distinfo
new file mode 100644
index 000000000000..fe1a814734e9
--- /dev/null
+++ b/www/spdylay/distinfo
@@ -0,0 +1,2 @@
+SHA256 (spdylay-1.1.0.tar.xz) = f6382926fc42031bc01b9402be606356430ec122db0ff9bbeac895cc84085ec7
+SIZE (spdylay-1.1.0.tar.xz) = 411900
diff --git a/www/spdylay/pkg-descr b/www/spdylay/pkg-descr
new file mode 100644
index 000000000000..80f10d6eff85
--- /dev/null
+++ b/www/spdylay/pkg-descr
@@ -0,0 +1,14 @@
+Spdylay - SPDY C Library
+
+This is an experimental implementation of Google's SPDY protocol in C. This
+library provides SPDY version 2 and 3 framing layer implementation. It does not
+perform any I/O operations. When the library needs them, it calls the callback
+functions provided by the application. It also does not include any event
+polling mechanism, so the application can freely choose the way of handling
+events. This library code does not depend on any particular SSL library (except
+for example programs which depend on OpenSSL 1.0.1 or later).
+
+This project also develops SPDY client, server and proxy on top of Spdylay
+library.
+
+WWW: http://spdylay.sourceforge.net/
diff --git a/www/spdylay/pkg-plist b/www/spdylay/pkg-plist
new file mode 100644
index 000000000000..b8142f8abf02
--- /dev/null
+++ b/www/spdylay/pkg-plist
@@ -0,0 +1,13 @@
+%%SHRPX%%bin/shrpx
+bin/spdycat
+bin/spdycli
+bin/spdyd
+%%SHRPX%%etc/shrpx.conf.sample
+include/spdylay/spdylay.h
+include/spdylay/spdylayver.h
+lib/libspdylay.a
+lib/libspdylay.la
+lib/libspdylay.so
+lib/libspdylay.so.6
+libdata/pkgconfig/libspdylay.pc
+@dirrm include/spdylay