aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2017-11-05 12:36:16 +0000
committerBernard Spil <brnrd@FreeBSD.org>2017-11-05 12:36:16 +0000
commitb38d05d84ed1b0730ca9c52f9e60f1bd894b5f7b (patch)
treecb7d8e879afe7e4f6daec9206c848caf2dfdba00
parent6dd362d9088637cc71bf8ccc325eb682e0d435e8 (diff)
downloadports-b38d05d84ed1b0730ca9c52f9e60f1bd894b5f7b.tar.gz
ports-b38d05d84ed1b0730ca9c52f9e60f1bd894b5f7b.zip
www/mod_auth_cas: Update to 1.1
- Update to 1.1 - Add modules.d configuration file - Builds OK with clang - Fix configure detection of libpcre PR: 214707 Submitted by: Geoffroy Desvernay <dgeo@centrale-marseille.fr> With hat: apache
Notes
Notes: svn path=/head/; revision=453543
-rw-r--r--UPDATING9
-rw-r--r--www/mod_auth_cas/Makefile38
-rw-r--r--www/mod_auth_cas/distinfo5
-rw-r--r--www/mod_auth_cas/files/250_mod_auth_cas.conf.sample.in28
-rw-r--r--www/mod_auth_cas/files/patch-mod_auth_cas.c14
-rw-r--r--www/mod_auth_cas/files/patch-src_mod__auth__cas.c12
-rw-r--r--www/mod_auth_cas/pkg-message2
7 files changed, 83 insertions, 25 deletions
diff --git a/UPDATING b/UPDATING
index 06432e0b4925..9203d252a1d8 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,8 +5,17 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20171105
+ AFFECTS: users of www/mod_auth_cas
+ AUTHOR: brnrd@FreeBSD.org
+
+ The configuration of mod_auth_cas has changed since the previous
+ version. Visit the https://github.com/apereo/mod_auth_cas page for
+ an overview of all configuration parameters
+
20171105:
AFFECTS: users of www/mod_rpaf2
+ AUTHOR: brnrd@FreeBSD.org
The configuration of mod_rpaf2 has been heavily modified since version
0.6. Have a look at https://github.com/gnif/mod_rpaf/tree/v0.8.4 to
diff --git a/www/mod_auth_cas/Makefile b/www/mod_auth_cas/Makefile
index 5f467585c2ee..23f0684c2ab4 100644
--- a/www/mod_auth_cas/Makefile
+++ b/www/mod_auth_cas/Makefile
@@ -2,27 +2,49 @@
# $FreeBSD$
PORTNAME= mod_auth_cas
-PORTVERSION= 1.0.9.1
+PORTVERSION= 1.1
DISTVERSIONPREFIX= v
-PORTREVISION= 3
CATEGORIES= www
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache 2.x module that supports the CASv1 and CASv2 protocols
LICENSE= APACHE20
-LIB_DEPENDS= libcurl.so:ftp/curl
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libpcre.so:devel/pcre
USE_GITHUB= yes
GH_ACCOUNT= Jasig
+USES= ssl
-WRKSRC_SUBDIR= src
+HAS_CONFIGURE= yes
+# configure requires LDFLAGS to find libpcre
+LDFLAGS+= -L${AP_LIB}
USE_APACHE= 22+
-AP_FAST_BUILD= yes
-AP_GENPLIST= yes
AP_LIB= ${LOCALBASE}/lib
-AP_EXTRAS= -l ssl -l curl
+AP_EXTRAS= -lpcre -lssl -lcrypto
-.include <bsd.port.mk>
+PLIST_FILES= @sample\ %%APACHEETCDIR%%/modules.d/%%APMOD_FILE%% \
+ %%APACHEMODDIR%%/mod_auth_cas.so
+
+PORTDOCS= README
+
+SUB_FILES= ${APMOD_FILE}
+APMOD_FILE= 250_${PORTNAME}.conf.sample
+PLIST_SUB+= APMOD_FILE=${APMOD_FILE}
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEMODDIR} ${STAGEDIR}${DOCSDIR}
+ ${APXS} -S LIBEXECDIR=${STAGEDIR}${PREFIX}/${APACHEMODDIR} \
+ -i -n ${MODULENAME} ${WRKSRC}/src/${MODULENAME}.la
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/${MODULENAME}.so
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEETCDIR}/modules.d
+ ${INSTALL_DATA} ${WRKDIR}/${APMOD_FILE} ${STAGEDIR}${PREFIX}/${APACHEETCDIR}/modules.d
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.post.mk>
diff --git a/www/mod_auth_cas/distinfo b/www/mod_auth_cas/distinfo
index 19393e70ceac..b456ae82de6c 100644
--- a/www/mod_auth_cas/distinfo
+++ b/www/mod_auth_cas/distinfo
@@ -1,2 +1,3 @@
-SHA256 (Jasig-mod_auth_cas-v1.0.9.1_GH0.tar.gz) = dbafc0bc51366d34fe7f02d8150a9ae70949da0bae3f19b581bbc0f5b0302d64
-SIZE (Jasig-mod_auth_cas-v1.0.9.1_GH0.tar.gz) = 73147
+TIMESTAMP = 1464815458
+SHA256 (Jasig-mod_auth_cas-v1.1_GH0.tar.gz) = e70decc7a887c63df46a848497acdbd8fa4776d0c8a8c1de2c0d71b1b07e3dd0
+SIZE (Jasig-mod_auth_cas-v1.1_GH0.tar.gz) = 409316
diff --git a/www/mod_auth_cas/files/250_mod_auth_cas.conf.sample.in b/www/mod_auth_cas/files/250_mod_auth_cas.conf.sample.in
new file mode 100644
index 000000000000..f8d17696bdc8
--- /dev/null
+++ b/www/mod_auth_cas/files/250_mod_auth_cas.conf.sample.in
@@ -0,0 +1,28 @@
+LoadModule auth_cas_module %%APACHEMODDIR%%/mod_auth_cas.so
+<IfModule auth_cas_module>
+ #CASVersion 2
+ #CASDebug Off
+ #CASValidateServer On
+ #CASValidateDepth 9
+ #CASAllowWildcardCert Off
+ #CASAllowWildcardCert On
+ #CASCertificatePath /usr/local/etc/ssl/cert.pem
+ CASLoginURL https://CAS_SERVER/cas/login
+ CASValidateURL https://CAS_SERVER/cas/serviceValidate
+ # CASCookiePath /dev/null
+ #CASCookiePath /var/tmp/
+ #CASTimeout 7200
+ #CASIdleTimeout 3600
+ #CASCacheCleanInterval 1800 # 30 min
+ #CASCookieDomain NULL
+ #CASCookieHttpOnly Off
+
+ ## per directory (or htaccess):
+ #AuthType CAS
+ #CASCookie MOD_AUTH_CAS # over http
+ #CASSecureCookie MOD_AUTH_CAS_S # over https
+
+ # add HTTP header (for use of REMOTE_USER by backend)
+ #CASAuthNHeader None
+</IfModule>
+
diff --git a/www/mod_auth_cas/files/patch-mod_auth_cas.c b/www/mod_auth_cas/files/patch-mod_auth_cas.c
deleted file mode 100644
index ed95bdba3f6a..000000000000
--- a/www/mod_auth_cas/files/patch-mod_auth_cas.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./mod_auth_cas.c.orig 2014-07-13 23:56:46.000000000 +0200
-+++ ./mod_auth_cas.c 2014-07-13 23:58:26.000000000 +0200
-@@ -2024,9 +2024,9 @@
- CRYPTO_set_id_callback(cas_ssl_id_callback);
- }
- #else
-- if(CRYPTO_get_locking_callback() == NULL && CRYPTO_THREADID_get_id_callback() == NULL) {
-+ if(CRYPTO_get_locking_callback() == NULL && CRYPTO_THREADID_get_callback() == NULL) {
- CRYPTO_set_locking_callback(cas_ssl_locking_callback);
-- CRYPTO_THREADID_set_id_callback(cas_ssl_id_callback);
-+ CRYPTO_THREADID_set_callback(cas_ssl_id_callback);
- }
- #endif /* OPENSSL_NO_THREADID */
- #endif /* defined(OPENSSL_THREADS) && APR_HAS_THREADS */
diff --git a/www/mod_auth_cas/files/patch-src_mod__auth__cas.c b/www/mod_auth_cas/files/patch-src_mod__auth__cas.c
new file mode 100644
index 000000000000..f2bb407fd83f
--- /dev/null
+++ b/www/mod_auth_cas/files/patch-src_mod__auth__cas.c
@@ -0,0 +1,12 @@
+--- src/mod_auth_cas.c.orig 2016-12-10 12:15:10 UTC
++++ src/mod_auth_cas.c
+@@ -22,7 +22,9 @@
+ *
+ */
+
++#ifdef HAVE_ERROR_H
+ #include <error.h>
++#endif
+ #include <string.h>
+ #include <sys/file.h>
+ #include <sys/types.h>
diff --git a/www/mod_auth_cas/pkg-message b/www/mod_auth_cas/pkg-message
index 78385befabf4..7b7fceb700f8 100644
--- a/www/mod_auth_cas/pkg-message
+++ b/www/mod_auth_cas/pkg-message
@@ -28,5 +28,5 @@
</Location>
For more informations see:
- https://wiki.jasig.org/display/CASC/mod_auth_cas
+ https://github.com/Jasig/mod_auth_cas
======================================================================