aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-04-02 08:05:36 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-04-02 08:05:36 +0000
commitb3aa9d4ba731674be4a6123c1d5109c923ed8309 (patch)
treebab883666b819439e7847bfc96db929f115b61f1
parentb318dd2a1c5b37c92707ed5857ea52ae7db8fcbd (diff)
downloadports-b3aa9d4ba731674be4a6123c1d5109c923ed8309.tar.gz
ports-b3aa9d4ba731674be4a6123c1d5109c923ed8309.zip
Notes
-rw-r--r--audio/Makefile1
-rw-r--r--audio/kmp/Makefile30
-rw-r--r--audio/kmp/distinfo2
-rw-r--r--audio/kmp/pkg-descr7
-rw-r--r--audio/kmp/pkg-plist1
5 files changed, 41 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 1cc3737eb4b1..c05218e13a73 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -148,6 +148,7 @@
SUBDIR += juk
SUBDIR += juke
SUBDIR += jxm
+ SUBDIR += kmp
SUBDIR += ksmp3play
SUBDIR += ladspa
SUBDIR += lame
diff --git a/audio/kmp/Makefile b/audio/kmp/Makefile
new file mode 100644
index 000000000000..c551f22060df
--- /dev/null
+++ b/audio/kmp/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: kmp
+# Date created: Apr 2, 2004
+# Whom: Mark Reidel <ports@mark.reidel.info>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kmp
+PORTVERSION= 0.01
+CATEGORIES= audio
+MASTER_SITES= http://mercury.chem.pitt.edu/~shank/ \
+ http://www.threadbox.net/files/
+
+MAINTAINER= ports@mark.reidel.info
+COMMENT= A graphical interface to musicpd written with Qt
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+
+USE_BZIP2= true
+USE_QT_VER= 3
+MAKE_ENV= QTDIR="${QT_PREFIX}"
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} qmake \
+ -spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ kmp.pro
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/kmp ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/audio/kmp/distinfo b/audio/kmp/distinfo
new file mode 100644
index 000000000000..2c60d28bfbdf
--- /dev/null
+++ b/audio/kmp/distinfo
@@ -0,0 +1,2 @@
+MD5 (kmp-0.01.tar.bz2) = 2b2607beea11b1feb53c5a5fd39cb721
+SIZE (kmp-0.01.tar.bz2) = 486474
diff --git a/audio/kmp/pkg-descr b/audio/kmp/pkg-descr
new file mode 100644
index 000000000000..6d32923efb1b
--- /dev/null
+++ b/audio/kmp/pkg-descr
@@ -0,0 +1,7 @@
+KMP is an MPD (audio/musicpd) client that uses the QT GUI toolkit
+so it will comfortably fit in with your KDE desktop, although only
+QT is required.
+KMP will allow you to browse the server's collection, add songs
+to the playlist, change the volume, etc.
+
+WWW: http://www.threadbox.net/kmp.php
diff --git a/audio/kmp/pkg-plist b/audio/kmp/pkg-plist
new file mode 100644
index 000000000000..9ded71b78bd8
--- /dev/null
+++ b/audio/kmp/pkg-plist
@@ -0,0 +1 @@
+bin/kmp