aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2014-06-13 11:47:41 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2014-06-13 11:47:41 +0000
commitb46f80ca64c73dacb4f391edae5f7c85030e3a8a (patch)
tree9cda6353efbcfbb8fb933a807e260706902d7fc1
parent2c2e201261462fcb7d94803a9e23cf1d6e56ed8d (diff)
* USES=uidfix -- staging without needing root access
* Don't install relayd.conf to staging; switch to @sample in pkg-plist * Drop warnings for FreeBSD 7.x compat as that's long out of support * Modernize LIB_DEPENDS * Fix LICENSE: this is OpenBSD code, but it uses the ISC Licence wording rather than either of the {2,3}-clause BSD licenses. Approved by: portmgr (blanket "just fix it")
Notes
Notes: svn path=/head/; revision=357672
-rw-r--r--net/relayd/Makefile13
-rw-r--r--net/relayd/pkg-plist4
2 files changed, 5 insertions, 12 deletions
diff --git a/net/relayd/Makefile b/net/relayd/Makefile
index f03273db8435..f0e2907809f0 100644
--- a/net/relayd/Makefile
+++ b/net/relayd/Makefile
@@ -2,19 +2,20 @@
PORTNAME= relayd
PORTVERSION= 5.4.20131122
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= GH
MAINTAINER= mm@FreeBSD.org
COMMENT= OpenBSD relay daemon
-LICENSE= BSD
+LICENSE= ISCL
GH_ACCOUNT= mmatuska
GH_COMMIT= a4f6140
WRKSRC= ${WRKDIR}/${GH_ACCOUNT}-${GH_PROJECT}-${GH_COMMIT}/src/usr.sbin
+USES= uidfix
USE_GITHUB= yes
USE_RC_SUBR= relayd
@@ -34,14 +35,10 @@ LIBEVENT_STATIC_DESC= Build with static libevent
BUILD_DEPENDS= ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
MAKE_ARGS+= LIBEVENT=${LOCALBASE}/lib/libevent.a
.else
-LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= libevent-1.4.so:${PORTSDIR}/devel/libevent
MAKE_ARGS+= LIBEVENT=-levent
.endif
-.if ${OSVERSION} < 800041
-BROKEN= does not build on FreeBSD 7.X
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/relayd/relay.c \
@@ -52,7 +49,5 @@ post-patch:
post-install:
@${INSTALL_DATA} ${WRKSRC}/../etc/relayd.conf \
${STAGEDIR}${PREFIX}/etc/relayd.conf.sample
- @${CP} -n ${WRKSRC}/../etc/relayd.conf \
- ${STAGEDIR}${PREFIX}/etc/relayd.conf || ${TRUE}
.include <bsd.port.post.mk>
diff --git a/net/relayd/pkg-plist b/net/relayd/pkg-plist
index 56b7fdf14abd..90b87352a455 100644
--- a/net/relayd/pkg-plist
+++ b/net/relayd/pkg-plist
@@ -1,6 +1,4 @@
-@unexec if cmp -s %D/etc/relayd.conf %D/etc/relayd.conf.sample; then rm -f %D/etc/relayd.conf; fi
-etc/relayd.conf.sample
-@exec cp -n %B/%f %B/relayd.conf
+@sample etc/relayd.conf.sample
man/man5/relayd.conf.5.gz
man/man8/relayctl.8.gz
man/man8/relayd.8.gz