aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-02-27 22:51:27 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-02-27 22:51:27 +0000
commitb4a3db7038b0245a917b60bdc1f7aece69054c02 (patch)
treebb9e6259594eac7ac28566870be2d695106c1b2d
parent9b3224c1143c25004f1cfa77579c8f4d83224702 (diff)
downloadports-b4a3db7038b0245a917b60bdc1f7aece69054c02.tar.gz
ports-b4a3db7038b0245a917b60bdc1f7aece69054c02.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/pear-Crypt_HMAC/Makefile24
-rw-r--r--security/pear-Crypt_HMAC/distinfo2
-rw-r--r--security/pear-Crypt_HMAC/pkg-descr3
4 files changed, 30 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index a77b0d99f87d..120ce719c126 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -332,6 +332,7 @@
SUBDIR += pear-Auth_HTTP
SUBDIR += pear-Auth_SASL
SUBDIR += pear-Crypt_CBC
+ SUBDIR += pear-Crypt_HMAC
SUBDIR += pear-Crypt_RC4
SUBDIR += pear-File_Passwd
SUBDIR += pear-LiveUser
diff --git a/security/pear-Crypt_HMAC/Makefile b/security/pear-Crypt_HMAC/Makefile
new file mode 100644
index 000000000000..c4f1735cc063
--- /dev/null
+++ b/security/pear-Crypt_HMAC/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: pear-Crypt_HMAC
+# Date created: 21 February 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt_HMAC
+PORTVERSION= 1.0.1
+CATEGORIES= security www pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR class to calculate RFC 2104 compliant hashes
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Crypt
+FILES= HMAC.php
+TESTS= test.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/security/pear-Crypt_HMAC/distinfo b/security/pear-Crypt_HMAC/distinfo
new file mode 100644
index 000000000000..6e9f7f505390
--- /dev/null
+++ b/security/pear-Crypt_HMAC/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Crypt_HMAC-1.0.1.tgz) = 7c9781e32d23ff35754fd7261a3aad39
+SIZE (PEAR/Crypt_HMAC-1.0.1.tgz) = 2149
diff --git a/security/pear-Crypt_HMAC/pkg-descr b/security/pear-Crypt_HMAC/pkg-descr
new file mode 100644
index 000000000000..48bf056923ef
--- /dev/null
+++ b/security/pear-Crypt_HMAC/pkg-descr
@@ -0,0 +1,3 @@
+PEAR class to calculate RFC 2104 compliant hashes.
+
+WWW: http://pear.php.net/package/Crypt_HMAC/