aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-29 08:32:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-29 08:32:36 +0000
commitb57e7139d49daba229c5f6445af6c48e3140db40 (patch)
tree3a607cf340250db64e0ca475b970a4177f5c0639
parent46ac9432cbfdd5afc30beb0b765ea2f47328595c (diff)
downloadports-b57e7139d49daba229c5f6445af6c48e3140db40.tar.gz
ports-b57e7139d49daba229c5f6445af6c48e3140db40.zip
Notes
-rw-r--r--print/panda/Makefile11
-rw-r--r--print/panda/files/patch-objects.c11
-rw-r--r--x11-wm/epiwm/Makefile27
-rw-r--r--x11-wm/epiwm/files/patch-modules__logoepiwm__logoEPIwm.c10
-rw-r--r--x11-wm/epiwm/files/patch-src__key.c13
-rw-r--r--x11-wm/epiwm/files/patch-src__style_init.c13
6 files changed, 58 insertions, 27 deletions
diff --git a/print/panda/Makefile b/print/panda/Makefile
index 69a48f3abc7a..12f9ab1e2368 100644
--- a/print/panda/Makefile
+++ b/print/panda/Makefile
@@ -17,22 +17,21 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A PDF generation library
-LIB_DEPENDS= db41.1:${PORTSDIR}/databases/db41 \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
USE_BZIP2= yes
-USE_GNOME= gnomehack gnometarget lthack pkgconfig
+USE_GNOME= gnomehack gnometarget pkgconfig
+USE_BDB= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-berkeley-db
USE_LDCONFIG= yes
-CPPFLAGS= -I${LOCALBASE}/include/db41 -I${LOCALBASE}/include \
- ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${BDB_LIB_DIR} -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
diff --git a/print/panda/files/patch-objects.c b/print/panda/files/patch-objects.c
new file mode 100644
index 000000000000..6100ef2bea84
--- /dev/null
+++ b/print/panda/files/patch-objects.c
@@ -0,0 +1,11 @@
+--- objects.c.orig Tue Apr 13 09:46:24 2004
++++ objects.c Wed Jun 27 23:25:53 2007
+@@ -99,7 +99,7 @@
+ created->children = (panda_child *) panda_xmalloc (sizeof (panda_child));
+
+ ((panda_child *) created->children)->next = NULL;
+- (panda_child *) created->cachedLastChild = NULL;
++ created->cachedLastChild = NULL;
+
+ // By default this object is not a pages object
+ created->isPages = panda_false;
diff --git a/x11-wm/epiwm/Makefile b/x11-wm/epiwm/Makefile
index 687f3447290b..593c5bd88a4f 100644
--- a/x11-wm/epiwm/Makefile
+++ b/x11-wm/epiwm/Makefile
@@ -14,34 +14,19 @@ MASTER_SITES= http://www.nongnu.org/epiwm/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= Another fast, small, configurable window manager
-LIB_DEPENDS= Imlib.5:${PORTSDIR}/graphics/imlib \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- ungif.5:${PORTSDIR}/graphics/libungif
-
-CONFIG= icons key menu start style window workspace
-DOCS= AUTHORS BUGS COPYING ChangeLog EPIwm-0.5.6.lsm INSTALL NEWS \
- README TODO
+USE_GNOME= imlib
GNU_CONFIGURE= yes
-USE_X_PREFIX= yes
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
post-patch:
- ${REINPLACE_CMD} 's|/etc/X11/epiwm|${PREFIX}/etc/epiwm|' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|/etc/X11/epiwm|${PREFIX}/etc/epiwm|' \
+ ${WRKSRC}/configure
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for ii in ${DOCS}
+ @${MKDIR} ${DOCSDIR}
+.for ii in AUTHORS BUGS ChangeLog EPIwm-0.5.6.lsm COPYING INSTALL NEWS README TODO
${INSTALL_DATA} ${WRKSRC}/${ii} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-wm/epiwm/files/patch-modules__logoepiwm__logoEPIwm.c b/x11-wm/epiwm/files/patch-modules__logoepiwm__logoEPIwm.c
new file mode 100644
index 000000000000..af1573396707
--- /dev/null
+++ b/x11-wm/epiwm/files/patch-modules__logoepiwm__logoEPIwm.c
@@ -0,0 +1,10 @@
+--- modules/logoepiwm/logoEPIwm.c.orig Sat Feb 3 08:53:20 2001
++++ modules/logoepiwm/logoEPIwm.c Sun Jun 24 01:06:40 2007
+@@ -1,6 +1,7 @@
+ /* This is logoEPIwm */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <X11/Xlib.h>
+ #include <X11/Xutil.h>
diff --git a/x11-wm/epiwm/files/patch-src__key.c b/x11-wm/epiwm/files/patch-src__key.c
new file mode 100644
index 000000000000..86c1d619e6d1
--- /dev/null
+++ b/x11-wm/epiwm/files/patch-src__key.c
@@ -0,0 +1,13 @@
+--- src/key.c.orig Sat Feb 3 08:53:20 2001
++++ src/key.c Sun Jun 24 01:04:43 2007
+@@ -50,8 +50,8 @@
+ tokens[i] = NULL;
+ i = 0;
+ strncpy(tmpstring, line, 100);
+- (char *) tokens[i] = (char *) strtok(tmpstring, "+");
+- while (((char *) tokens[++i] = (char *) strtok(NULL, "+")));
++ tokens[i] = (char *) strtok(tmpstring, "+");
++ while ((tokens[++i] = (char *) strtok(NULL, "+")));
+ tokens[i] = NULL;
+ return (tokens[index]);
+ }
diff --git a/x11-wm/epiwm/files/patch-src__style_init.c b/x11-wm/epiwm/files/patch-src__style_init.c
new file mode 100644
index 000000000000..a40c399acac2
--- /dev/null
+++ b/x11-wm/epiwm/files/patch-src__style_init.c
@@ -0,0 +1,13 @@
+--- src/style_init.c.orig Sat Feb 3 08:53:20 2001
++++ src/style_init.c Sun Jun 24 01:05:45 2007
+@@ -77,8 +77,8 @@
+ tokens[i] = NULL;
+ i = 0;
+ strncpy(tmpstring, line, 100);
+- (char *) tokens[i] = (char *) strtok(tmpstring, "\"");
+- while (((char *) tokens[++i] = (char *) strtok(NULL, "\"")));
++ tokens[i] = (char *) strtok(tmpstring, "\"");
++ while ((tokens[++i] = (char *) strtok(NULL, "\"")));
+ tokens[i] = NULL;
+ return (tokens[index]);
+ }