aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-09-27 18:25:34 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-09-27 18:25:34 +0000
commitb59e043cdeb3a34957916d38fe3ef3532e0f137e (patch)
tree088f7f0fcd4546e2de39f14cb9fab94ede0a6be9
parent55be9c95f5e7fa63263e3b38cc78ea638d510d8e (diff)
downloadports-b59e043cdeb3a34957916d38fe3ef3532e0f137e.tar.gz
ports-b59e043cdeb3a34957916d38fe3ef3532e0f137e.zip
emulators/ppsspp: enslave GUI options
Catering package-only users that want Qt4 flavor or just SDL UI. COMMENT and pkg-descr (both plural) can be improved in future.
Notes
Notes: svn path=/head/; revision=422825
-rw-r--r--UPDATING9
-rw-r--r--emulators/Makefile2
-rw-r--r--emulators/ppsspp-qt4/Makefile14
-rw-r--r--emulators/ppsspp-qt5/Makefile14
-rw-r--r--emulators/ppsspp/Makefile5
5 files changed, 42 insertions, 2 deletions
diff --git a/UPDATING b/UPDATING
index 9c5cd4d2e83e..d691e4c107f5 100644
--- a/UPDATING
+++ b/UPDATING
@@ -6,6 +6,15 @@ You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
20160927:
+ AFFECTS: emulators/ppsspp
+ AUTHOR: jbeich@FreeBSD.org
+
+ Qt* GUI was split into separate ports:
+
+ emulators/ppsspp-qt4
+ emulators/ppsspp-qt5
+
+20160927:
AFFECTS: sysutils/android-file-transfer
AUTHOR: jbeich@FreeBSD.org
diff --git a/emulators/Makefile b/emulators/Makefile
index 185c93291ad5..47d7919962f2 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -109,6 +109,8 @@
SUBDIR += pipelight
SUBDIR += playonbsd
SUBDIR += ppsspp
+ SUBDIR += ppsspp-qt4
+ SUBDIR += ppsspp-qt5
SUBDIR += py-gns3-converter
SUBDIR += q4wine
SUBDIR += qemu
diff --git a/emulators/ppsspp-qt4/Makefile b/emulators/ppsspp-qt4/Makefile
new file mode 100644
index 000000000000..c0f6f30344d9
--- /dev/null
+++ b/emulators/ppsspp-qt4/Makefile
@@ -0,0 +1,14 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -qt4
+
+MASTERDIR= ${.CURDIR}/../ppsspp
+
+OPTIONS_SLAVE= QT4
+OPTIONS_EXCLUDE=${OPTIONS_SINGLE_GUI}
+
+# XXX Why OPTIONS_EXCLUDE doesn't trigger _OFF helpers?
+do-install-QT4-on: do-install-SDL-off
+
+.include "${MASTERDIR}/Makefile"
diff --git a/emulators/ppsspp-qt5/Makefile b/emulators/ppsspp-qt5/Makefile
new file mode 100644
index 000000000000..72ef6d9e15ac
--- /dev/null
+++ b/emulators/ppsspp-qt5/Makefile
@@ -0,0 +1,14 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -qt5
+
+MASTERDIR= ${.CURDIR}/../ppsspp
+
+OPTIONS_SLAVE= QT5
+OPTIONS_EXCLUDE=${OPTIONS_SINGLE_GUI}
+
+# XXX Why OPTIONS_EXCLUDE doesn't trigger _OFF helpers?
+do-install-QT5-on: do-install-SDL-off
+
+.include "${MASTERDIR}/Makefile"
diff --git a/emulators/ppsspp/Makefile b/emulators/ppsspp/Makefile
index f7e8c7220fdb..3c85a17d50fd 100644
--- a/emulators/ppsspp/Makefile
+++ b/emulators/ppsspp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ppsspp
DISTVERSIONPREFIX= v
DISTVERSION?= 1.3
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= emulators
# XXX Get from Debian once #697821 lands
MASTER_SITES= https://bazaar.launchpad.net/~sergio-br2/${PORTNAME}/debian-sdl/download/5/${PORTNAME}.1-20140802045408-dd26dik367ztj5xg-8/:manpage
@@ -25,7 +25,7 @@ GH_ACCOUNT= hrydgard:DEFAULT,lang Kingcom:ext_armips
GH_PROJECT= ${PORTNAME}-lang:lang armips:ext_armips
GH_TAGNAME?= cdf4a8d:lang 1ffab37:ext_armips
-CONFLICTS_INSTALL?= ${PORTNAME}-devel-[0-9]*
+CONFLICTS_INSTALL= ${PORTNAME}-*
USES= compiler:c++11-lib localbase pkgconfig
EXCLUDE= glew snappy libzip zlib
@@ -47,6 +47,7 @@ DESKTOP_ENTRIES="PPSSPP" \
OPTIONS_DEFAULT=QT5
OPTIONS_SINGLE= GUI
OPTIONS_SINGLE_GUI= QT4 QT5 SDL
+OPTIONS_SLAVE?= SDL
QT4_USES= qmake:outsource
QT4_USE= QT4=qmake_build,moc_build,rcc_build,uic_build,linguisttools_build,gui,opengl