aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:04:02 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:04:02 +0000
commitb62faa9f1984c9a24b4b797e784391e27693a9ab (patch)
treecf076d7edd6e8f125cc4a398e2b26fe910a64c7c
parent2720f4a3e5c5fc041694a80a12d2a789213bfec4 (diff)
downloadports-b62faa9f1984c9a24b4b797e784391e27693a9ab.tar.gz
ports-b62faa9f1984c9a24b4b797e784391e27693a9ab.zip
misc/py-pyprind: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--misc/py-pyprind/Makefile5
-rw-r--r--misc/py-pyprind/files/patch-setup.py11
2 files changed, 14 insertions, 2 deletions
diff --git a/misc/py-pyprind/Makefile b/misc/py-pyprind/Makefile
index b27231b35dfd..4f09d5d94638 100644
--- a/misc/py-pyprind/Makefile
+++ b/misc/py-pyprind/Makefile
@@ -1,5 +1,6 @@
PORTNAME= pyprind
PORTVERSION= 2.11.3
+PORTREVISION= 1
CATEGORIES= misc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,10 +13,12 @@ WWW= https://github.com/rasbt/pyprind
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psutil>=3.2.0:sysutils/py-psutil@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils nose
+USE_PYTHON= autoplist concurrent pep517 nose
NO_ARCH= yes
diff --git a/misc/py-pyprind/files/patch-setup.py b/misc/py-pyprind/files/patch-setup.py
index 05a5b6ba64c2..81fc483fd61c 100644
--- a/misc/py-pyprind/files/patch-setup.py
+++ b/misc/py-pyprind/files/patch-setup.py
@@ -1,5 +1,14 @@
---- setup.py.orig 2016-04-14 15:46:12 UTC
+--- setup.py.orig 2021-04-18 17:12:43 UTC
+++ setup.py
+@@ -16,7 +16,7 @@ VERSION = pyprind.__version__
+
+ VERSION = pyprind.__version__
+
+-setup(name='PyPrind',
++setup(name='pyprind',
+ version=VERSION,
+ description='Python Progress Bar and Percent Indicator Utility',
+ author='Sebastian Raschka',
@@ -39,6 +39,7 @@ setup(name='PyPrind',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',