aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-02-26 14:18:29 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-02-26 14:18:29 +0000
commitb689ff00d7b4d831a1d6a453a5b0b63b60a2def0 (patch)
tree25c7758df974bffbaa218181b9eaec6c40199d45
parentcebdc17613c7824f6bb6e7cdca3e3fe5937f4207 (diff)
downloadports-b689ff00d7b4d831a1d6a453a5b0b63b60a2def0.tar.gz
ports-b689ff00d7b4d831a1d6a453a5b0b63b60a2def0.zip
Notes
-rw-r--r--mail/vpopmail-stable/Makefile220
-rw-r--r--mail/vpopmail-stable/distinfo1
-rw-r--r--mail/vpopmail-stable/files/patch-configure53
-rw-r--r--mail/vpopmail-stable/pkg-descr21
-rw-r--r--mail/vpopmail-stable/pkg-install109
-rw-r--r--mail/vpopmail-stable/pkg-plist55
6 files changed, 0 insertions, 459 deletions
diff --git a/mail/vpopmail-stable/Makefile b/mail/vpopmail-stable/Makefile
deleted file mode 100644
index c55a15e54fbd..000000000000
--- a/mail/vpopmail-stable/Makefile
+++ /dev/null
@@ -1,220 +0,0 @@
-# New ports collection makefile for: vpopmail
-# Date created: 21 Sep 2000
-# Whom: Neil Blakey-Milner
-#
-# $FreeBSD$
-#
-
-PORTNAME= vpopmail
-PORTVERSION= 5.2.1
-PORTREVISION= 2
-CATEGORIES= mail
-MASTER_SITES= http://www.inter7.com/vpopmail/
-PKGNAMESUFFIX= -stable
-
-MAINTAINER= roam@FreeBSD.org
-COMMENT= "Easy virtual domain and authentication package for use with qmail"
-
-BUILD_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail \
- ${LOCALBASE}/bin/tcprules:${PORTSDIR}/sysutils/ucspi-tcp
-RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail \
- ${LOCALBASE}/bin/tcprules:${PORTSDIR}/sysutils/ucspi-tcp
-
-GNU_CONFIGURE= YES
-USE_GMAKE= YES
-USE_REINPLACE= YES
-USE_PERL5_BUILD= YES
-
-VCFGDIR?= ${WRKDIR}/vcfg
-VCFGFILES?= inc_deps lib_deps tcp.smtp
-
-CONFIGURE_ENV+= VCFGDIR="${VCFGDIR}"
-CONFIGURE_ARGS= --enable-qmaildir=${QMAIL_DIR} \
- --enable-tcprules-bin=${LOCALBASE}/bin/tcprules \
- --enable-tcpserver-file=${PREFIX}/vpopmail/etc/tcp.smtp
-
-#
-# User-configurable variables
-#
-# Define these to change from the default behaviour
-#
-# WITH_PASSWD - allow authentication off /etc/passwd
-# WITH_MD5_PASSWORDS - store encrypted passwords in MD5 format
-# WITH_MYSQL - allow authentitation via mysql
-# WITH_MYSQL_LARGE_SITE - enables large site layout
-# WITH_CLEAR_PASSWD - store passwords in plaintext into the MySQL db
-# WITH_APOP - allow apop authentication
-# WITHOUT_ROAMING - disallow roaming users
-# WITH_IP_ALIAS - enables IP aliasing
-# WITH_DELIVER_FILTER - enables the experimental vdelivermail filter
-# WITH_QMAIL_EXT - enables qmail-like user-* address extesions processing
-#
-# Set these to the values you'd prefer
-#
-# HARDQUOTA - size of hard quota, or 'n' for no hard quota
-# RELAYCLEAR - time in minutes before clearing relay hole (requires roaming)
-# DEFAULT_DOMAIN - default domain for non-vhost lookups
-# LOGLEVEL - n - no logging, y - log all,
-# e - log errors, p - log passwords in errors
-# APOPFILE - location of apop secrets file
-# QMAIL_DIR - location of qmail directory
-# PREFIX - installation area for vpopmail (see comment below)
-# VCHKPW_GID - the group ID of the new vchkpw group (89)
-# VPOPMAIL_UID - the user ID of the new vpopmail user (89)
-# WITH_MYSQL_SERVER - the hostname of the MySQL server (localhost)
-# WITH_MYSQL_USER - the username for connecting to the MySQL server (root)
-# WITH_MYSQL_PASSWD - the password for connecting to the MySQL server (secret)
-# WITH_MYSQL_DB - the name of the MySQL database to use (vpopmail)
-# The server, user and password variables may be defined separately
-# for read and update access, allowing you to set up a less-priviledged
-# MySQL connection account with read-only access, and another one which
-# is used for administrative purposes:
-# WITH_MYSQL_READ_SERVER, WITH_MYSQL_READ_USER, WITH_MYSQL_READ_PASSWD
-# WITH_MYSQL_UPDATE_SERVER, WITH_MYSQL_UPDATE_USER, WITH_MYSQL_UPDATE_PASSWD
-# Those variables, if defined, override WITH_MYSQL_{SERVER,USER,PASSWD}
-#
-
-HARDQUOTA?= 10000000
-RELAYCLEAR?= 30
-LOGLEVEL?= y
-APOPFILE?= /usr/local/vpopmail/etc/apop-secrets
-
-.if exists(${LOCALBASE}/qmail/bin/qmail-send)
-QMAIL_DIR?= ${LOCALBASE}/qmail
-.else
-QMAIL_DIR?= /var/qmail
-.endif
-
-# Uncomment this, or set PREFIX to /home if you have an existing
-# vpopmail install with the vpopmail users' home directory set to
-# /home/vpopmail - package rules dictate we default to /usr/local/vpopmail
-#
-#PREFIX?= /home
-
-# End of user-configurable variables
-
-#
-# Some suggestions from Gabriel Ambuehl <gabriel_ambuehl@buz.ch>
-#
-
-CONFIGURE_ARGS+= --enable-defaultquota=${HARDQUOTA} \
- --enable-logging=${LOGLEVEL}
-
-.if defined(WITH_PASSWD)
-CONFIGURE_ARGS+= --enable-passwd=y
-.endif
-
-.if defined(WITH_MD5_PASSWORDS)
-CONFIGURE_ARGS+= --enable-md5-passwords=y
-.endif
-
-.if defined(WITH_APOP)
-CONFIGURE_ARGS+= --enable-apop=y \
- --enable-apop-file=${APOPFILE}
-.else
-CONFIGURE_ARGS+= --enable-apop=n
-.endif
-
-.if defined(WITH_SQWEBMAIL)
-CONFIGURE_ARGS+= --enable-sqwebmail-pass=y
-.endif
-
-.if !defined(WITHOUT_ROAMING)
-CONFIGURE_ARGS+= --enable-roaming-users=y \
- --enable-relay-clear-minutes=${RELAYCLEAR}
-.endif
-
-.if !defined(WITH_CLEAR_PASSWD)
-CONFIGURE_ARGS+= --enable-clear-passwd=n
-.endif
-
-.if defined(WITH_MYSQL)
-LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
-CONFIGURE_ARGS+= --enable-mysql=y \
- --enable-sqlincdir=${LOCALBASE}/include/mysql \
- --enable-sqllibdir=${LOCALBASE}/lib/mysql
-.if defined(WITH_MYSQL_LARGE_SITE)
-CONFIGURE_ARGS+= --enable-large-site=y
-.endif
-
-.if defined(WITH_MYSQL_SERVER)
-WITH_MYSQL_READ_SERVER?= ${WITH_MYSQL_SERVER}
-WITH_MYSQL_UPDATE_SERVER?= ${WITH_MYSQL_SERVER}
-.endif
-.if defined(WITH_MYSQL_USER)
-WITH_MYSQL_READ_USER?= ${WITH_MYSQL_USER}
-WITH_MYSQL_UPDATE_USER?= ${WITH_MYSQL_USER}
-.endif
-.if defined(WITH_MYSQL_PASSWD)
-WITH_MYSQL_READ_PASSWD?= ${WITH_MYSQL_PASSWD}
-WITH_MYSQL_UPDATE_PASSWD?= ${WITH_MYSQL_PASSWD}
-.endif
-.endif
-
-.if defined(DEFAULT_DOMAIN)
-CONFIGURE_ARGS+= --enable-default-domain=${DEFAULT_DOMAIN}
-.endif
-
-.if defined(WITH_IP_ALIAS)
-CONFIGURE_ARGS+= --enable-ip-alias-domains=y
-.endif
-
-.if defined(WITH_DELIVER_FILTER)
-CONFIGURE_ARGS+= --enable-deliver-filter=y
-.endif
-
-.if defined(WITH_QMAIL_EXT)
-CONFIGURE_ARGS+= --enable-qmail-ext=y
-.endif
-
-# autoconf and automake can remove our patches to the configure scripts.
-
-post-patch:
- @${FIND} ${WRKSRC} -type f -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -E -e 's,@(ACLOCAL|AUTO(MAKE|CONF|HEADER))@,/usr/bin/true,'
-
-#
-# This port doesn't honour PREFIX, it honours vpopmail's home directory.
-# Since we create vpopmail if it doesn't exist, we set it so that it
-# does honour PREFIX. -- nbm
-#
-
-pre-configure:
- @PKG_PREFIX=${PREFIX}/vpopmail ${PERL5} ${PKGINSTALL}
-.if defined(WITH_MYSQL)
-.if defined(WITH_MYSQL_UPDATE_SERVER)
- ${REINPLACE_CMD} -E "s/(#define MYSQL_UPDATE_SERVER.*)localhost(.*)/\1${WITH_MYSQL_UPDATE_SERVER}\2/" ${WRKSRC}/vmysql.h
-.endif
-.if defined(WITH_MYSQL_READ_SERVER)
- ${REINPLACE_CMD} -E "s/(#define MYSQL_READ_SERVER.*)localhost(.*)/\1${WITH_MYSQL_READ_SERVER}\2/" ${WRKSRC}/vmysql.h
-.endif
-.if defined(WITH_MYSQL_UPDATE_USER)
- ${REINPLACE_CMD} -E "s/(#define MYSQL_UPDATE_USER.*)root(.*)/\1${WITH_MYSQL_UPDATE_USER}\2/" ${WRKSRC}/vmysql.h
-.endif
-.if defined(WITH_MYSQL_READ_USER)
- ${REINPLACE_CMD} -E "s/(#define MYSQL_READ_USER.*)root(.*)/\1${WITH_MYSQL_READ_USER}\2/" ${WRKSRC}/vmysql.h
-.endif
-.if defined(WITH_MYSQL_UPDATE_PASSWD)
- ${REINPLACE_CMD} -E "s/(#define MYSQL_UPDATE_PASSWD.*)secret(.*)/\1${WITH_MYSQL_UPDATE_PASSWD}\2/" ${WRKSRC}/vmysql.h
-.endif
-.if defined(WITH_MYSQL_READ_PASSWD)
- ${REINPLACE_CMD} -E "s/(#define MYSQL_READ_PASSWD.*)secret(.*)/\1${WITH_MYSQL_READ_PASSWD}\2/" ${WRKSRC}/vmysql.h
-.endif
-.if defined(WITH_MYSQL_DB)
- ${REINPLACE_CMD} -E "s/(#define MYSQL_DATABASE.*)vpopmail(.*)/\1${WITH_MYSQL_DB}\2/" ${WRKSRC}/vmysql.h
-.endif
-.endif
- ${MKDIR} ${VCFGDIR}
-
-post-install:
- ${CHMOD} o-rwx ${PREFIX}/vpopmail/bin ${PREFIX}/vpopmail/lib
- ${MKDIR} ${PREFIX}/vpopmail/etc
- if [ ! -f "${PREFIX}/vpopmail/etc/tcp.smtp" ]; then \
- if [ -f "${VCFGDIR}/tcp.smtp" ]; then \
- ${INSTALL_DATA} ${VCFGDIR}/tcp.smtp ${PREFIX}/vpopmail/etc/; \
- else \
- ${TOUCH} ${PREFIX}/vpopmail/etc/tcp.smtp; \
- fi; \
- fi
- ${INSTALL_DATA} ${VCFGDIR}/inc_deps ${VCFGDIR}/lib_deps ${PREFIX}/vpopmail/etc/
-
-.include <bsd.port.mk>
diff --git a/mail/vpopmail-stable/distinfo b/mail/vpopmail-stable/distinfo
deleted file mode 100644
index b7f9413cd519..000000000000
--- a/mail/vpopmail-stable/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (vpopmail-5.2.1.tar.gz) = 1e299a467db955c95c2966c7aa0ef6e5
diff --git a/mail/vpopmail-stable/files/patch-configure b/mail/vpopmail-stable/files/patch-configure
deleted file mode 100644
index df3302d9e94b..000000000000
--- a/mail/vpopmail-stable/files/patch-configure
+++ /dev/null
@@ -1,53 +0,0 @@
---- configure.old Mon Nov 19 17:54:10 2001
-+++ configure Mon Nov 19 17:57:27 2001
-@@ -1535,15 +1535,6 @@
- rm -f vpopusername
-
-
--if test ! -d $vpopmaildir/etc
--then
-- mkdir $vpopmaildir/etc
-- chown $vpopmailuid "$vpopmaildir"/etc
-- chgrp $vpopmailgid "$vpopmaildir"/etc
-- chmod 755 "$vpopmaildir"/etc
-- echo "configure: warning: making a vpopmail etc directory " 1>&2
--fi
--
- # Check whether --enable-roaming-users or --disable-roaming-users was given.
- if test "${enable_roaming_users+set}" = set; then
- enableval="$enable_roaming_users"
-@@ -1605,7 +1596,7 @@
-
- if test "$tcpserver_file" = ""
- then
-- echo "127.:allow,RELAYCLIENT=\"\"" > "$vpopmaildir"/etc/tcp.smtp
-+ echo "127.:allow,RELAYCLIENT=\"\"" > "$VCFGDIR"/tcp.smtp
- tcpserver_file="$vpopmaildir"/etc/tcp.smtp
-
- echo "configure: warning: Unable to find your tcpserver relay file." 1>&2
-@@ -2042,7 +2033,7 @@
- fi
- auth_libs="-L$libdir $extralibflags -lmysqlclient -lz"
-
-- echo "-L$vpopmaildir/lib -lvpopmail -L$libdir -lmysqlclient -lz" > $vpopmaildir/etc/lib_deps
-+ echo "-L$vpopmaildir/lib -lvpopmail -L$libdir -lmysqlclient -lz" > $VCFGDIR/lib_deps
-
- ;;
- *)
-@@ -2277,14 +2268,14 @@
- authlib=
-
- auth_inc="-Icdb"
-- echo "-L$vpopmaildir/lib -lvpopmail" > $vpopmaildir/etc/lib_deps
-+ echo "-L$vpopmaildir/lib -lvpopmail" > $VCFGDIR/lib_deps
-
- ;;
- *)
- ;;
- esac
-
--echo "-I$vpopmaildir/include" > $vpopmaildir/etc/inc_deps
-+echo "-I$vpopmaildir/include" > $VCFGDIR/inc_deps
-
- # Check whether --enable-qmail-ext or --disable-qmail-ext was given.
- if test "${enable_qmail_ext+set}" = set; then
diff --git a/mail/vpopmail-stable/pkg-descr b/mail/vpopmail-stable/pkg-descr
deleted file mode 100644
index a98ec621541b..000000000000
--- a/mail/vpopmail-stable/pkg-descr
+++ /dev/null
@@ -1,21 +0,0 @@
-vpopmail provides an easy way to manage virtual domains and virtual
-accounts on a qmail mail server.
-
-Features:
-
-. Automates all qmail file modifications into documented command line
- programs
-
-. Support for named and IP-based virtual domains
-
-. NFS safe
-
-. dynamic directory creation for scalability using fill-in balanced 3
- level tree
-
-. understands standard qmail .qmail directives
-
-. interacts well with qmailadmin for web-based administration, courier-imap
- for IMAP support, and sqwebmail for web-based mail.
-
-WWW: http://inter7.com/vpopmail/
diff --git a/mail/vpopmail-stable/pkg-install b/mail/vpopmail-stable/pkg-install
deleted file mode 100644
index 101602472771..000000000000
--- a/mail/vpopmail-stable/pkg-install
+++ /dev/null
@@ -1,109 +0,0 @@
-#!/usr/bin/perl
-#
-
-@groups = ("vchkpw");
-%users = ('vpopmail', "vchkpw");
-# daemon, local, pop, queue, remote, deliver, respectively.
-# alias is a special case above...
-%gids = ("vchkpw", 89);
-%uids = ('vpopmail', 89);
-
-sub checkenv () {
- my ($u, $g);
-
- # Users
- foreach $u (keys %users) {
- $var = uc($u)."_UID";
- if (defined($ENV{$var})) {
- $uids{$u} = $ENV{$var};
- }
- }
-
- # Groups
- foreach $g (@groups) {
- $var = uc($g)."_GID";
- if (defined($ENV{$var})) {
- $gids{$g} = $ENV{$var};
- }
- }
-}
-
-if ($ENV{PACKAGE_BUILDING} || $ARGV[1] eq "PRE-INSTALL") {
- $doguid=1; # Make sure we get the assigned guids.
-}
-
-checkenv();
-
-foreach $group (@groups) {
- if (! getgrnam ($group)) {
- do checkrpw; # May exit
-
- $x = "-g $gids{$group}";
- $result = system ("/usr/sbin/pw groupadd $group $x");
- if ($result) {
- die "Failed to add group $group as gid $gids{$group}\n";
- }
- }
-}
-
-if (! getpwnam ("alias")) {
- do checkrpw; # May exit
-
- $x = "-u $uids{'alias'}";
- $result = system ("/usr/sbin/pw useradd alias -g qnofiles -d \"$ENV{PKG_PREFIX}/alias\" -s /nonexistent $x");
- if ($result) {
- die "Failed to add user alias as uid $uids{'alias'}\n";
- }
-}
-
-foreach $user (keys %users) {
- if (! getpwnam ($user)) {
- do checkrpw; # May exit
-
- $x = "-u $uids{$user}";
- $result = system ("/usr/sbin/pw useradd $user -g $users{$user} -d \"$ENV{PKG_PREFIX}\" -s /nonexistent $x");
- if ($result) {
- die "Failed to add user $user as uid $uids{$user}\n";
- }
- }
-}
-
-# Check that all gids/uids are as they should be...
-# If we are being installed as a package...
-if ($doguid) {
- foreach $group (@groups) {
- if (getgrnam($group) != $gids{$group}) {
- die "Group $group should have gid $gids{$group}\n";
- }
- }
-
- foreach $user (keys %users) {
- if (getpwnam($user) != $uids{$user}) {
- die "User $user should have uid $uids{$user}\n";
- }
- }
-}
-
-exit 0;
-
-sub checkrpw {
- if (! -x "/usr/sbin/pw") {
- print <<'EOM';
-This system looks like a pre-2.2 version of FreeBSD. We see that it
-is missing the "pw" utility. We need this utility. Please get and
-install it, and try again. You can get the source from:
-
- ftp://ftp.freebsd.org/pub/FreeBSD/FreeBSD-current/src/usr.sbin/pw.tar.gz
-
-EOM
- die "No /usr/sbin/pw";
- }
-
- if ($> != 0) {
- print "It is necessary to add missing vpopmail users/groups at";
- print "this stage. Please either add them manually or retry";
- print "as root.";
- # Let pw(1) signal the failure so the user can see which
- # group/user is actually missing.
- }
-}
diff --git a/mail/vpopmail-stable/pkg-plist b/mail/vpopmail-stable/pkg-plist
deleted file mode 100644
index 80a845baa619..000000000000
--- a/mail/vpopmail-stable/pkg-plist
+++ /dev/null
@@ -1,55 +0,0 @@
-vpopmail/bin/clearopensmtp
-vpopmail/bin/vaddaliasdomain
-vpopmail/bin/vadddomain
-vpopmail/bin/vadduser
-vpopmail/bin/valias
-vpopmail/bin/vchkpw
-vpopmail/bin/vconvert
-vpopmail/bin/vdeldomain
-vpopmail/bin/vdelivermail
-vpopmail/bin/vdeloldusers
-vpopmail/bin/vdeluser
-vpopmail/bin/vdominfo
-vpopmail/bin/vipmap
-vpopmail/bin/vkill
-vpopmail/bin/vmkpasswd
-vpopmail/bin/vmoduser
-vpopmail/bin/vpasswd
-vpopmail/bin/vpopbull
-vpopmail/bin/vqmaillocal
-vpopmail/bin/vsetuserquota
-vpopmail/bin/vuserinfo
-vpopmail/doc/doc_html/vpopmail.html
-vpopmail/doc/doc_html/vpopmail5.abw
-vpopmail/doc/doc_html/vpopmailapi.png
-vpopmail/doc/man_html/clearopensmtp.html
-vpopmail/doc/man_html/index.html
-vpopmail/doc/man_html/vaddaliasdomain.html
-vpopmail/doc/man_html/vadddomain.html
-vpopmail/doc/man_html/vadduser.html
-vpopmail/doc/man_html/vchkpw.html
-vpopmail/doc/man_html/vconvert.html
-vpopmail/doc/man_html/vdeldomain.html
-vpopmail/doc/man_html/vdelivermail.html
-vpopmail/doc/man_html/vdeluser.html
-vpopmail/doc/man_html/vpasswd.html
-vpopmail/doc/man_html/vpopbull.html
-vpopmail/doc/man_html/vsetuserquota.html
-vpopmail/etc/inc_deps
-vpopmail/etc/lib_deps
-@unexec if [ -f %D/vpopmail/etc/tcp.smtp -a ! -s %D/vpopmail/etc/tcp.smtp ]; then rm -f %D/vpopmail/etc/tcp.smtp; fi
-vpopmail/include/config.h
-vpopmail/include/vauth.h
-vpopmail/include/vpopmail.h
-vpopmail/include/vpopmail_config.h
-vpopmail/lib/libvpopmail.a
-@dirrm vpopmail/users
-@dirrm vpopmail/lib
-@dirrm vpopmail/include
-@dirrm vpopmail/etc
-@dirrm vpopmail/domains
-@dirrm vpopmail/doc/man_html
-@dirrm vpopmail/doc/doc_html
-@dirrm vpopmail/doc
-@dirrm vpopmail/bin
-@dirrm vpopmail