aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2007-09-15 01:41:53 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2007-09-15 01:41:53 +0000
commitb6d6d6785e7b648e4250f7fc6cfe2bc72af87117 (patch)
tree6feeb0cb9f1498fabaea397a2ea8ffcd75aa4ab9
parent759e3adb46541e2e15e2f89cbef455a609b946b0 (diff)
downloadports-b6d6d6785e7b648e4250f7fc6cfe2bc72af87117.tar.gz
ports-b6d6d6785e7b648e4250f7fc6cfe2bc72af87117.zip
Notes
-rw-r--r--emulators/wine-devel/Makefile9
-rw-r--r--emulators/wine-devel/distinfo6
-rw-r--r--emulators/wine-devel/files/patch-avoid-user_shared_data62
-rw-r--r--emulators/wine-devel/pkg-plist8
-rw-r--r--emulators/wine/Makefile9
-rw-r--r--emulators/wine/distinfo6
-rw-r--r--emulators/wine/files/patch-avoid-user_shared_data62
-rw-r--r--emulators/wine/pkg-plist8
8 files changed, 28 insertions, 142 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index ca0281ae76fa..ae4da859fa91 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= wine
-PORTVERSION= 0.9.44
+PORTVERSION= 0.9.45
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED} \
@@ -27,8 +27,7 @@ LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --datadir=${DATADIR} --verbose
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- EXTRA_BINARIES="wine-kthread"
+ LDFLAGS="-L${LOCALBASE}/lib"
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/wine
MAN1= widl.1 wine.1 winebuild.1 winedbg.1 winedump.1 winegcc.1 \
winemaker.1 wineprefixcreate.1 wineserver.1 wmc.1 wrc.1
@@ -45,8 +44,8 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 503000
-IGNORE= fails to work on versions of FreeBSD before 5.3 (due to problems with threading support)
+.if ${OSVERSION} < 602000
+IGNORE= fails to properly work on versions of FreeBSD before 6.2 (due to problems with threading support)
.endif
post-patch:
diff --git a/emulators/wine-devel/distinfo b/emulators/wine-devel/distinfo
index a6f1de19d1f1..b27938f3539d 100644
--- a/emulators/wine-devel/distinfo
+++ b/emulators/wine-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (wine-0.9.44.tar.bz2) = cdfc5cc1d813a955c8e7310346fb5629
-SHA256 (wine-0.9.44.tar.bz2) = f77d53740c05414d74e7b0ffbb901441221d1563bf070026abc95f96774772f7
-SIZE (wine-0.9.44.tar.bz2) = 12377043
+MD5 (wine-0.9.45.tar.bz2) = feecc3ccb4639b672d8446154a4fb700
+SHA256 (wine-0.9.45.tar.bz2) = f91b67573e9065d3aa731744f45be5c12732ef2f4ec811a5816768e2dec2a663
+SIZE (wine-0.9.45.tar.bz2) = 12445353
diff --git a/emulators/wine-devel/files/patch-avoid-user_shared_data b/emulators/wine-devel/files/patch-avoid-user_shared_data
deleted file mode 100644
index 976941fa4db1..000000000000
--- a/emulators/wine-devel/files/patch-avoid-user_shared_data
+++ /dev/null
@@ -1,62 +0,0 @@
-Index: dlls/ntdll/loader.c
-===================================================================
-RCS file: /home/wine/wine/dlls/ntdll/loader.c,v
-retrieving revision 1.155
-diff -u -3 -p -r1.155 loader.c
---- dlls/ntdll/loader.c 23 May 2007 13:12:18 -0000 1.155
-+++ dlls/ntdll/loader.c 3 Jun 2007 14:20:23 -0000
-@@ -2308,7 +2308,9 @@ void __wine_init_windows_dir( const WCHA
- LPWSTR buffer, p;
-
- RtlCreateUnicodeString( &system_dir, sysdir );
-+#if !defined(__FreeBSD__)
- strcpyW( user_shared_data->NtSystemRoot, windir );
-+#endif
-
- /* prepend the system dir to the name of the already created modules */
- mark = &NtCurrentTeb()->Peb->LdrData->InLoadOrderModuleList;
-Index: dlls/ntdll/thread.c
-===================================================================
-RCS file: /home/wine/wine/dlls/ntdll/thread.c,v
-retrieving revision 1.84
-diff -u -3 -p -r1.84 thread.c
---- dlls/ntdll/thread.c 23 May 2007 13:12:18 -0000 1.84
-+++ dlls/ntdll/thread.c 3 Jun 2007 14:20:23 -0000
-@@ -332,12 +332,15 @@ HANDLE thread_init(void)
-
- /* initialize time values in user_shared_data */
- NtQuerySystemTime( &now );
-+
-+#if !defined(__FreeBSD__)
- user_shared_data->SystemTime.LowPart = now.u.LowPart;
- user_shared_data->SystemTime.High1Time = user_shared_data->SystemTime.High2Time = now.u.HighPart;
- user_shared_data->u.TickCountQuad = (now.QuadPart - server_start_time) / 10000;
- user_shared_data->u.TickCount.High2Time = user_shared_data->u.TickCount.High1Time;
- user_shared_data->TickCountLowDeprecated = user_shared_data->u.TickCount.LowPart;
- user_shared_data->TickCountMultiplier = 1 << 24;
-+#endif
-
- return exe_file;
- }
-Index: dlls/ntdll/version.c
-===================================================================
-RCS file: /home/wine/wine/dlls/ntdll/version.c,v
-retrieving revision 1.38
-diff -u -3 -p -r1.38 version.c
---- dlls/ntdll/version.c 18 May 2007 18:57:23 -0000 1.38
-+++ dlls/ntdll/version.c 3 Jun 2007 14:20:25 -0000
-@@ -506,12 +506,14 @@ done:
- NtCurrentTeb()->Peb->OSBuildNumber = current_version->dwBuildNumber;
- NtCurrentTeb()->Peb->OSPlatformId = current_version->dwPlatformId;
-
-+#if ! defined(__FreeBSD__)
- user_shared_data->NtProductType = current_version->wProductType;
- user_shared_data->ProductTypeIsValid = TRUE;
- user_shared_data->MajorNtVersion = current_version->dwMajorVersion;
- user_shared_data->MinorNtVersion = current_version->dwMinorVersion;
- user_shared_data->MinorNtVersion = current_version->dwMinorVersion;
- user_shared_data->SuiteMask = current_version->wSuiteMask;
-+#endif
-
- TRACE( "got %d.%d plaform %d build %x name %s service pack %d.%d product %d\n",
- current_version->dwMajorVersion, current_version->dwMinorVersion,
diff --git a/emulators/wine-devel/pkg-plist b/emulators/wine-devel/pkg-plist
index f418f6cbff84..844dc2a64085 100644
--- a/emulators/wine-devel/pkg-plist
+++ b/emulators/wine-devel/pkg-plist
@@ -7,7 +7,7 @@ bin/regsvr32
bin/uninstaller
bin/widl
bin/wine
-bin/wine-kthread
+bin/wine-pthread
bin/wineboot
bin/winebrowser
bin/winebuild
@@ -90,6 +90,7 @@ include/wine/windows/axcore.idl
include/wine/windows/axextend.idl
include/wine/windows/basetsd.h
include/wine/windows/basetyps.h
+include/wine/windows/bcrypt.h
include/wine/windows/cderr.h
include/wine/windows/cfgmgr32.h
include/wine/windows/cguid.h
@@ -182,6 +183,7 @@ include/wine/windows/dxgi.idl
include/wine/windows/dxgitype.h
include/wine/windows/dxgitype.idl
include/wine/windows/dyngraph.idl
+include/wine/windows/errorrep.h
include/wine/windows/errors.h
include/wine/windows/evcode.h
include/wine/windows/evntrace.h
@@ -209,6 +211,7 @@ include/wine/windows/hlink.idl
include/wine/windows/htiframe.h
include/wine/windows/htiframe.idl
include/wine/windows/htmlhelp.h
+include/wine/windows/i_cryptasn1tls.h
include/wine/windows/iads.h
include/wine/windows/iads.idl
include/wine/windows/icftypes.h
@@ -221,6 +224,7 @@ include/wine/windows/imm.h
include/wine/windows/indexsrv.h
include/wine/windows/indexsrv.idl
include/wine/windows/initguid.h
+include/wine/windows/intshcut.h
include/wine/windows/ipexport.h
include/wine/windows/iphlpapi.h
include/wine/windows/ipifcons.h
@@ -430,6 +434,7 @@ include/wine/windows/windows.h
include/wine/windows/windowsx.h
include/wine/windows/winerror.h
include/wine/windows/wingdi.h
+include/wine/windows/winhttp.h
include/wine/windows/wininet.h
include/wine/windows/winineti.h
include/wine/windows/winioctl.h
@@ -787,6 +792,7 @@ lib/wine/oledlg.dll.so
lib/wine/olepro32.dll.so
lib/wine/olesvr.dll16
lib/wine/olesvr32.dll.so
+lib/wine/olethk32.dll.so
lib/wine/oleview.exe.so
lib/wine/opengl32.dll.so
lib/wine/pdh.dll.so
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index ca0281ae76fa..ae4da859fa91 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= wine
-PORTVERSION= 0.9.44
+PORTVERSION= 0.9.45
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED} \
@@ -27,8 +27,7 @@ LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --datadir=${DATADIR} --verbose
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- EXTRA_BINARIES="wine-kthread"
+ LDFLAGS="-L${LOCALBASE}/lib"
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/wine
MAN1= widl.1 wine.1 winebuild.1 winedbg.1 winedump.1 winegcc.1 \
winemaker.1 wineprefixcreate.1 wineserver.1 wmc.1 wrc.1
@@ -45,8 +44,8 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 503000
-IGNORE= fails to work on versions of FreeBSD before 5.3 (due to problems with threading support)
+.if ${OSVERSION} < 602000
+IGNORE= fails to properly work on versions of FreeBSD before 6.2 (due to problems with threading support)
.endif
post-patch:
diff --git a/emulators/wine/distinfo b/emulators/wine/distinfo
index a6f1de19d1f1..b27938f3539d 100644
--- a/emulators/wine/distinfo
+++ b/emulators/wine/distinfo
@@ -1,3 +1,3 @@
-MD5 (wine-0.9.44.tar.bz2) = cdfc5cc1d813a955c8e7310346fb5629
-SHA256 (wine-0.9.44.tar.bz2) = f77d53740c05414d74e7b0ffbb901441221d1563bf070026abc95f96774772f7
-SIZE (wine-0.9.44.tar.bz2) = 12377043
+MD5 (wine-0.9.45.tar.bz2) = feecc3ccb4639b672d8446154a4fb700
+SHA256 (wine-0.9.45.tar.bz2) = f91b67573e9065d3aa731744f45be5c12732ef2f4ec811a5816768e2dec2a663
+SIZE (wine-0.9.45.tar.bz2) = 12445353
diff --git a/emulators/wine/files/patch-avoid-user_shared_data b/emulators/wine/files/patch-avoid-user_shared_data
deleted file mode 100644
index 976941fa4db1..000000000000
--- a/emulators/wine/files/patch-avoid-user_shared_data
+++ /dev/null
@@ -1,62 +0,0 @@
-Index: dlls/ntdll/loader.c
-===================================================================
-RCS file: /home/wine/wine/dlls/ntdll/loader.c,v
-retrieving revision 1.155
-diff -u -3 -p -r1.155 loader.c
---- dlls/ntdll/loader.c 23 May 2007 13:12:18 -0000 1.155
-+++ dlls/ntdll/loader.c 3 Jun 2007 14:20:23 -0000
-@@ -2308,7 +2308,9 @@ void __wine_init_windows_dir( const WCHA
- LPWSTR buffer, p;
-
- RtlCreateUnicodeString( &system_dir, sysdir );
-+#if !defined(__FreeBSD__)
- strcpyW( user_shared_data->NtSystemRoot, windir );
-+#endif
-
- /* prepend the system dir to the name of the already created modules */
- mark = &NtCurrentTeb()->Peb->LdrData->InLoadOrderModuleList;
-Index: dlls/ntdll/thread.c
-===================================================================
-RCS file: /home/wine/wine/dlls/ntdll/thread.c,v
-retrieving revision 1.84
-diff -u -3 -p -r1.84 thread.c
---- dlls/ntdll/thread.c 23 May 2007 13:12:18 -0000 1.84
-+++ dlls/ntdll/thread.c 3 Jun 2007 14:20:23 -0000
-@@ -332,12 +332,15 @@ HANDLE thread_init(void)
-
- /* initialize time values in user_shared_data */
- NtQuerySystemTime( &now );
-+
-+#if !defined(__FreeBSD__)
- user_shared_data->SystemTime.LowPart = now.u.LowPart;
- user_shared_data->SystemTime.High1Time = user_shared_data->SystemTime.High2Time = now.u.HighPart;
- user_shared_data->u.TickCountQuad = (now.QuadPart - server_start_time) / 10000;
- user_shared_data->u.TickCount.High2Time = user_shared_data->u.TickCount.High1Time;
- user_shared_data->TickCountLowDeprecated = user_shared_data->u.TickCount.LowPart;
- user_shared_data->TickCountMultiplier = 1 << 24;
-+#endif
-
- return exe_file;
- }
-Index: dlls/ntdll/version.c
-===================================================================
-RCS file: /home/wine/wine/dlls/ntdll/version.c,v
-retrieving revision 1.38
-diff -u -3 -p -r1.38 version.c
---- dlls/ntdll/version.c 18 May 2007 18:57:23 -0000 1.38
-+++ dlls/ntdll/version.c 3 Jun 2007 14:20:25 -0000
-@@ -506,12 +506,14 @@ done:
- NtCurrentTeb()->Peb->OSBuildNumber = current_version->dwBuildNumber;
- NtCurrentTeb()->Peb->OSPlatformId = current_version->dwPlatformId;
-
-+#if ! defined(__FreeBSD__)
- user_shared_data->NtProductType = current_version->wProductType;
- user_shared_data->ProductTypeIsValid = TRUE;
- user_shared_data->MajorNtVersion = current_version->dwMajorVersion;
- user_shared_data->MinorNtVersion = current_version->dwMinorVersion;
- user_shared_data->MinorNtVersion = current_version->dwMinorVersion;
- user_shared_data->SuiteMask = current_version->wSuiteMask;
-+#endif
-
- TRACE( "got %d.%d plaform %d build %x name %s service pack %d.%d product %d\n",
- current_version->dwMajorVersion, current_version->dwMinorVersion,
diff --git a/emulators/wine/pkg-plist b/emulators/wine/pkg-plist
index f418f6cbff84..844dc2a64085 100644
--- a/emulators/wine/pkg-plist
+++ b/emulators/wine/pkg-plist
@@ -7,7 +7,7 @@ bin/regsvr32
bin/uninstaller
bin/widl
bin/wine
-bin/wine-kthread
+bin/wine-pthread
bin/wineboot
bin/winebrowser
bin/winebuild
@@ -90,6 +90,7 @@ include/wine/windows/axcore.idl
include/wine/windows/axextend.idl
include/wine/windows/basetsd.h
include/wine/windows/basetyps.h
+include/wine/windows/bcrypt.h
include/wine/windows/cderr.h
include/wine/windows/cfgmgr32.h
include/wine/windows/cguid.h
@@ -182,6 +183,7 @@ include/wine/windows/dxgi.idl
include/wine/windows/dxgitype.h
include/wine/windows/dxgitype.idl
include/wine/windows/dyngraph.idl
+include/wine/windows/errorrep.h
include/wine/windows/errors.h
include/wine/windows/evcode.h
include/wine/windows/evntrace.h
@@ -209,6 +211,7 @@ include/wine/windows/hlink.idl
include/wine/windows/htiframe.h
include/wine/windows/htiframe.idl
include/wine/windows/htmlhelp.h
+include/wine/windows/i_cryptasn1tls.h
include/wine/windows/iads.h
include/wine/windows/iads.idl
include/wine/windows/icftypes.h
@@ -221,6 +224,7 @@ include/wine/windows/imm.h
include/wine/windows/indexsrv.h
include/wine/windows/indexsrv.idl
include/wine/windows/initguid.h
+include/wine/windows/intshcut.h
include/wine/windows/ipexport.h
include/wine/windows/iphlpapi.h
include/wine/windows/ipifcons.h
@@ -430,6 +434,7 @@ include/wine/windows/windows.h
include/wine/windows/windowsx.h
include/wine/windows/winerror.h
include/wine/windows/wingdi.h
+include/wine/windows/winhttp.h
include/wine/windows/wininet.h
include/wine/windows/winineti.h
include/wine/windows/winioctl.h
@@ -787,6 +792,7 @@ lib/wine/oledlg.dll.so
lib/wine/olepro32.dll.so
lib/wine/olesvr.dll16
lib/wine/olesvr32.dll.so
+lib/wine/olethk32.dll.so
lib/wine/oleview.exe.so
lib/wine/opengl32.dll.so
lib/wine/pdh.dll.so