aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-08-08 07:59:02 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-08-08 07:59:02 +0000
commitb93589d5065fa21626dae333ec6b6f02d04c8207 (patch)
tree0ec2e1798fdd6f99fd2a6e4f98bd097cc664503a
parenta56fc17a7e47d57fae1c93fda40a67a3f3d13fb1 (diff)
downloadports-b93589d5065fa21626dae333ec6b6f02d04c8207.tar.gz
ports-b93589d5065fa21626dae333ec6b6f02d04c8207.zip
Notes
-rw-r--r--mail/Makefile1
-rw-r--r--mail/astroid/Makefile37
-rw-r--r--mail/astroid/distinfo3
-rw-r--r--mail/astroid/files/patch-CMakeLists.txt11
-rw-r--r--mail/astroid/pkg-descr7
-rw-r--r--mail/astroid/pkg-plist28
6 files changed, 87 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 996038b1952a..8baa4f9a3511 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -23,6 +23,7 @@
SUBDIR += ask
SUBDIR += asmail
SUBDIR += assp
+ SUBDIR += astroid
SUBDIR += automx
SUBDIR += autorespond
SUBDIR += autosig
diff --git a/mail/astroid/Makefile b/mail/astroid/Makefile
new file mode 100644
index 000000000000..2fe66a68e23f
--- /dev/null
+++ b/mail/astroid/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= astroid
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.15
+CATEGORIES= mail
+
+MAINTAINER= mylan.connolly@gmail.com
+COMMENT= Graphical email client for notmuch, inspired by sup and others
+
+LICENSE= GPLv3+ LGPL21+
+LICENSE_COMB= dual
+LICENSE_FILE_GPLv3+ = ${WRKSRC}/COPYING.GPL-3.0+
+LICENSE_FILE_LGPL21+ = ${WRKSRC}/COPYING.LGPL-2.1+
+
+BUILD_DEPENDS= scdoc:textproc/scdoc \
+ notmuch>0:mail/notmuch
+LIB_DEPENDS= libboost_system.so:devel/boost-libs \
+ libjavascriptcoregtk-4.0.so:www/webkit2-gtk3 \
+ libgmime-3.0.so:mail/gmime30 \
+ libgnutls.so:security/gnutls \
+ libpcre2-8.so:devel/pcre2 \
+ libpeas-1.0.so:devel/libpeas \
+ libprotobuf.so:devel/protobuf \
+ libsass.so:textproc/libsass \
+ libsoup-2.4.so:devel/libsoup
+RUN_DEPENDS= notmuch:mail/notmuch
+
+USES= cmake desktop-file-utils gettext-runtime gnome pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= astroidmail
+GH_PROJECT= astroid
+USE_GNOME= atk atkmm cairo cairomm gdkpixbuf2 glib20 glibmm gtk30 gtkmm30 introspection libsigc++20 pango pangomm vte3
+
+INSTALLS_ICONS= yes
+
+.include <bsd.port.mk>
diff --git a/mail/astroid/distinfo b/mail/astroid/distinfo
new file mode 100644
index 000000000000..37cbf78fb4ca
--- /dev/null
+++ b/mail/astroid/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1565244146
+SHA256 (astroidmail-astroid-v0.15_GH0.tar.gz) = 8581bbdbc71bd00d4cdd473cfad8bc604628bb15616fe5eab5c623461f686c65
+SIZE (astroidmail-astroid-v0.15_GH0.tar.gz) = 3365732
diff --git a/mail/astroid/files/patch-CMakeLists.txt b/mail/astroid/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..738a688ce8c8
--- /dev/null
+++ b/mail/astroid/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2019-08-08 06:21:44 UTC
++++ CMakeLists.txt
+@@ -543,7 +543,7 @@ install ( TARGETS tvextension
+ # Install man page
+ if (NOT DISABLE_DOCS)
+ install ( FILES ${CMAKE_BINARY_DIR}/astroid.1.gz
+- DESTINATION share/man/man1
++ DESTINATION man/man1
+ )
+ endif ()
+
diff --git a/mail/astroid/pkg-descr b/mail/astroid/pkg-descr
new file mode 100644
index 000000000000..3e6d89c241ef
--- /dev/null
+++ b/mail/astroid/pkg-descr
@@ -0,0 +1,7 @@
+Astroid is a lightweight and fast Mail User Agent that provides a graphical
+interface to searching, display and composing email, organized in thread and
+tags. Astroid uses the notmuch backend for blazingly fast searches through tons
+of email. Astroid searches, displays and composes emails - and relies on other
+programs for fetching, syncing and sending email.
+
+WWW: http://astroidmail.github.io/
diff --git a/mail/astroid/pkg-plist b/mail/astroid/pkg-plist
new file mode 100644
index 000000000000..0a878b11d471
--- /dev/null
+++ b/mail/astroid/pkg-plist
@@ -0,0 +1,28 @@
+bin/astroid
+lib/astroid/web-extensions/libtvextension.so
+lib/girepository-1.0/Astroid-0.2.typelib
+man/man1/astroid.1.gz
+share/applications/astroid.desktop
+%%DATADIR%%/ui/edit-message.glade
+%%DATADIR%%/ui/icons/LICENSE
+%%DATADIR%%/ui/icons/astroid.png
+%%DATADIR%%/ui/icons/astroid.svg
+%%DATADIR%%/ui/icons/horizontal_color.png
+%%DATADIR%%/ui/icons/horizontal_color.svg
+%%DATADIR%%/ui/icons/horizontal_white.png
+%%DATADIR%%/ui/icons/horizontal_white.svg
+%%DATADIR%%/ui/icons/icon_color.png
+%%DATADIR%%/ui/icons/icon_color.svg
+%%DATADIR%%/ui/icons/icon_white.png
+%%DATADIR%%/ui/icons/icon_white.svg
+%%DATADIR%%/ui/icons/vertical_color.png
+%%DATADIR%%/ui/icons/vertical_color.svg
+%%DATADIR%%/ui/icons/vertical_white.png
+%%DATADIR%%/ui/icons/vertical_white.svg
+%%DATADIR%%/ui/no-mail.png
+%%DATADIR%%/ui/part.scss
+%%DATADIR%%/ui/thread-view.html
+%%DATADIR%%/ui/thread-view.scss
+share/gir-1.0/Astroid-0.2.gir
+share/icons/hicolor/512x512/apps/astroid.png
+share/icons/hicolor/scalable/apps/astroid.svg