aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2009-07-28 13:36:18 +0000
committerAnton Berezin <tobez@FreeBSD.org>2009-07-28 13:36:18 +0000
commitb97bef31e47bc2fdbc6e0b6bfb1f5ed4519347d0 (patch)
treeaaac5efc34ce5a36259391f793f81099bafdf264
parentf50fc2f6bc2a870f3aec9748305f83c635d2dbbf (diff)
downloadports-b97bef31e47bc2fdbc6e0b6bfb1f5ed4519347d0.tar.gz
ports-b97bef31e47bc2fdbc6e0b6bfb1f5ed4519347d0.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-Parser-Style-EasyTree/Makefile26
-rw-r--r--textproc/p5-XML-Parser-Style-EasyTree/distinfo3
-rw-r--r--textproc/p5-XML-Parser-Style-EasyTree/pkg-descr4
-rw-r--r--textproc/p5-XML-Parser-Style-EasyTree/pkg-plist9
5 files changed, 43 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 981cf169acc0..c03b36bc35eb 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -780,6 +780,7 @@
SUBDIR += p5-XML-Parser
SUBDIR += p5-XML-Parser-EasyTree
SUBDIR += p5-XML-Parser-Lite-Tree
+ SUBDIR += p5-XML-Parser-Style-EasyTree
SUBDIR += p5-XML-Parser-Style-Elemental
SUBDIR += p5-XML-Quote
SUBDIR += p5-XML-RAI
diff --git a/textproc/p5-XML-Parser-Style-EasyTree/Makefile b/textproc/p5-XML-Parser-Style-EasyTree/Makefile
new file mode 100644
index 000000000000..ff741fcb5bd0
--- /dev/null
+++ b/textproc/p5-XML-Parser-Style-EasyTree/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: textproc/p5-XML-Parser-Style-EasyTree
+# Date created: 28 July 2009
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Parser-Style-EasyTree
+PORTVERSION= 0.03
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Parse XML to a simple tree
+
+BUILD_DEPENDS= p5-XML-Parser>0:${PORTSDIR}/textproc/p5-XML-Parser \
+ p5-ex-lib>=0.03:${PORTSDIR}/devel/p5-ex-lib
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Parser::Style::EasyTree.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Parser-Style-EasyTree/distinfo b/textproc/p5-XML-Parser-Style-EasyTree/distinfo
new file mode 100644
index 000000000000..2e495e07c4df
--- /dev/null
+++ b/textproc/p5-XML-Parser-Style-EasyTree/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-Parser-Style-EasyTree-0.03.tar.gz) = befd2d6c7f044c3d4f86e761b267a7fb
+SHA256 (XML-Parser-Style-EasyTree-0.03.tar.gz) = eafbbb8fb5875f0a876439a208273684918ee5b828e4683900e2f42a398cca25
+SIZE (XML-Parser-Style-EasyTree-0.03.tar.gz) = 23280
diff --git a/textproc/p5-XML-Parser-Style-EasyTree/pkg-descr b/textproc/p5-XML-Parser-Style-EasyTree/pkg-descr
new file mode 100644
index 000000000000..cb2d0377ed79
--- /dev/null
+++ b/textproc/p5-XML-Parser-Style-EasyTree/pkg-descr
@@ -0,0 +1,4 @@
+This module provides an XML::Parser style for generating a simple tree
+out of XML.
+
+WWW: http://search.cpan.org/dist/XML-Parser-Style-EasyTree/
diff --git a/textproc/p5-XML-Parser-Style-EasyTree/pkg-plist b/textproc/p5-XML-Parser-Style-EasyTree/pkg-plist
new file mode 100644
index 000000000000..f5f3e3e73457
--- /dev/null
+++ b/textproc/p5-XML-Parser-Style-EasyTree/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/XML/Parser/Style/EasyTree.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Parser/Style/EasyTree/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Parser/Style/EasyTree
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Parser/Style
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Parser
+@dirrmtry %%SITE_PERL%%/XML/Parser/Style
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrmtry %%SITE_PERL%%/XML/Parser
+@dirrmtry %%SITE_PERL%%/XML