aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2005-06-24 10:54:10 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2005-06-24 10:54:10 +0000
commitba54e5418ba4ad960217bb43262478f539dc8118 (patch)
tree2b2638294c3aaa4c4c10c5134a1daafde4ba8cbe
parent0ca245459aebd8bfaa839bdb1848dd052f9fb6e1 (diff)
downloadports-ba54e5418ba4ad960217bb43262478f539dc8118.tar.gz
ports-ba54e5418ba4ad960217bb43262478f539dc8118.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-POE-Component-Client-Keepalive/Makefile28
-rw-r--r--net/p5-POE-Component-Client-Keepalive/distinfo2
-rw-r--r--net/p5-POE-Component-Client-Keepalive/pkg-descr6
-rw-r--r--net/p5-POE-Component-Client-Keepalive/pkg-plist10
5 files changed, 47 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index b67f011f6406..313e06f92b06 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -550,6 +550,7 @@
SUBDIR += p5-NetAddr-IP-Count
SUBDIR += p5-NetPacket
SUBDIR += p5-OAI-Harvester
+ SUBDIR += p5-POE-Component-Client-Keepalive
SUBDIR += p5-POE-Component-Client-Ping
SUBDIR += p5-POE-Component-Jabber
SUBDIR += p5-POE-Component-Pcap
diff --git a/net/p5-POE-Component-Client-Keepalive/Makefile b/net/p5-POE-Component-Client-Keepalive/Makefile
new file mode 100644
index 000000000000..46475e6f9c9c
--- /dev/null
+++ b/net/p5-POE-Component-Client-Keepalive/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: POE-Component-Client-Keepalive
+# Date created: 24 June 2005
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Client-Keepalive
+PORTVERSION= 0.03
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= POE component for managing connections, with keep-alive
+
+BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/POE/Component/Client/DNS.pm:${PORTSDIR}/dns/p5-POE-Component-Client-DNS \
+ ${SITE_PERL}/POE/Component/SSLify.pm:${PORTSDIR}/security/p5-POE-Component-SSLify
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Client::Client-Keepalive.3 \
+ POE::Component::Client::Conn-Keepalive.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-POE-Component-Client-Keepalive/distinfo b/net/p5-POE-Component-Client-Keepalive/distinfo
new file mode 100644
index 000000000000..426999cea35d
--- /dev/null
+++ b/net/p5-POE-Component-Client-Keepalive/distinfo
@@ -0,0 +1,2 @@
+MD5 (POE-Component-Client-Keepalive-0.03.tar.gz) = a0c2049e529f4b71760f2ce7fd58f039
+SIZE (POE-Component-Client-Keepalive-0.03.tar.gz) = 20173
diff --git a/net/p5-POE-Component-Client-Keepalive/pkg-descr b/net/p5-POE-Component-Client-Keepalive/pkg-descr
new file mode 100644
index 000000000000..9e743def6c7a
--- /dev/null
+++ b/net/p5-POE-Component-Client-Keepalive/pkg-descr
@@ -0,0 +1,6 @@
+POE::Component::Client::Keepalive creates and manages connections for
+other components. It maintains a cache of kept-alive connections for
+quick reuse. It is written specifically for clients that can benefit
+from kept-alive connections, such as HTTP clients.
+
+WWW: http://search.cpan.org/dist/POE-Component-Client-Keepalive/
diff --git a/net/p5-POE-Component-Client-Keepalive/pkg-plist b/net/p5-POE-Component-Client-Keepalive/pkg-plist
new file mode 100644
index 000000000000..aafe01088c84
--- /dev/null
+++ b/net/p5-POE-Component-Client-Keepalive/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/POE/Component/Client/Keepalive.pm
+%%SITE_PERL%%/POE/Component/Connection/Keepalive.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/Keepalive/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/Keepalive
+@unexec rmdir %D/%%SITE_PERL%%/POEComponent/Client 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/POEComponent/Connection 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/POE 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE 2>/dev/null || true