aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-01-28 19:24:50 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-01-28 19:24:50 +0000
commitba678193d5ca06dab366dfa24183426fcbfc6dd5 (patch)
tree0d200f0df62324d5f8fbfcf8e82b01303083c1ca
parent39e0c65db935af5d23aea20b48e1055470726b61 (diff)
mail/pop3proxy: Fix build with OpenSSL 1.1.1
- Add license - Fix config file location - Reorder some things to pet portlint - Mark it deprecated too as it appears to have no upstream anymore and only works properly with unencrypted traffic PR: 232134 Submitted by: freebsd_ports@k-worx.org MFH: 2019Q1
Notes
Notes: svn path=/head/; revision=491513
-rw-r--r--mail/pop3proxy/Makefile18
-rw-r--r--mail/pop3proxy/files/patch-Makefile.in11
-rw-r--r--mail/pop3proxy/files/patch-src_imapcommon.c35
-rw-r--r--mail/pop3proxy/pkg-descr4
4 files changed, 55 insertions, 13 deletions
diff --git a/mail/pop3proxy/Makefile b/mail/pop3proxy/Makefile
index 1c85694f3c1d..f6e6ea47b3d4 100644
--- a/mail/pop3proxy/Makefile
+++ b/mail/pop3proxy/Makefile
@@ -3,29 +3,37 @@
PORTNAME= pop3proxy
PORTVERSION= 1.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= http://people.freebsd.org/~mbr/distfiles/
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= POP3 Proxy Server derived from UP IMAP Proxy
-GNU_CONFIGURE= yes
-USES= autoreconf ssl
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+DEPRECATED= no upstream and does not properly initiate SSL/TLS connections
+EXPIRATION_DATE= 2019-04-15
+
+USES= autoreconf ssl tar:tgz
USE_RC_SUBR= pop3proxyd
+GNU_CONFIGURE= yes
+
post-patch:
@${MV} ${WRKSRC}/aclocal.m4 ${WRKSRC}/acinclude.m4
@${REINPLACE_CMD} 's/HAVE_LIBSSL/HAVE_LIBCRYPTO/' \
${WRKSRC}/include/pop3proxy.h ${WRKSRC}/src/icc.c \
${WRKSRC}/src/imapcommon.c ${WRKSRC}/src/main.c \
${WRKSRC}/src/request.c
+ @${REINPLACE_CMD} 's|%%PREFIX%%|${PREFIX}|' \
+ ${WRKSRC}/Makefile.in
do-install:
(cd ${WRKSRC}/bin && ${INSTALL_PROGRAM} pop3proxystat pop3proxyd \
${STAGEDIR}${PREFIX}/sbin)
- ${INSTALL} -c ${WRKSRC}/pop3proxyd.conf \
+ ${INSTALL_DATA} ${WRKSRC}/pop3proxyd.conf \
${STAGEDIR}${PREFIX}/etc/pop3proxyd.conf.sample
.include <bsd.port.mk>
diff --git a/mail/pop3proxy/files/patch-Makefile.in b/mail/pop3proxy/files/patch-Makefile.in
new file mode 100644
index 000000000000..72ec75dbf115
--- /dev/null
+++ b/mail/pop3proxy/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2004-04-21 13:30:34 UTC
++++ Makefile.in
+@@ -24,7 +24,7 @@ mandir = $(prefix)/man/man3
+ rpm_prefix = @rpm_prefix@
+
+ CC = @CC@
+-CPPFLAGS = @CPPFLAGS@ -DDEFAULT_CONFIG_FILE=\"/docsis/etc/pop3proxyd.conf\"
++CPPFLAGS = @CPPFLAGS@ -DDEFAULT_CONFIG_FILE=\"%%PREFIX%%/etc/pop3proxyd.conf\"
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+ DEFINES = @DEFINES@
diff --git a/mail/pop3proxy/files/patch-src_imapcommon.c b/mail/pop3proxy/files/patch-src_imapcommon.c
index 50ab345e84f8..e26f99138ebd 100644
--- a/mail/pop3proxy/files/patch-src_imapcommon.c
+++ b/mail/pop3proxy/files/patch-src_imapcommon.c
@@ -1,10 +1,31 @@
---- src/imapcommon.c.orig
+--- src/imapcommon.c.orig 2005-02-01 15:21:28 UTC
+++ src/imapcommon.c
-@@ -121,6 +121,7 @@
- #include <errno.h>
+@@ -295,16 +295,24 @@ extern ICD_Struct *Get_Server_conn( char *Username,
+ int rc;
+ unsigned int Expiration;
- #include <openssl/evp.h>
-+#include <openssl/md5.h>
+- EVP_MD_CTX mdctx;
++ EVP_MD_CTX *mdctx;
+ int md_len;
- #include <pthread.h>
- #include <sys/types.h>
++#if OPENSSL_VERSION_NUMBER < 0x10100000L
++ EVP_MD_CTX mdctx_;
++#define EVP_MD_CTX_new(x) &mdctx_
++#define EVP_MD_CTX_free(x)
++#endif
++
+ Expiration = PC_Struct.cache_expiration_time;
+ memset( &Server, 0, sizeof Server );
+
+ /* need to md5 the passwd regardless, so do that now */
+- EVP_DigestInit(&mdctx, EVP_md5());
+- EVP_DigestUpdate(&mdctx, Password, strlen(Password));
+- EVP_DigestFinal(&mdctx, md5pw, &md_len);
++ mdctx = EVP_MD_CTX_new();
++ EVP_DigestInit(mdctx, EVP_md5());
++ EVP_DigestUpdate(mdctx, Password, strlen(Password));
++ EVP_DigestFinal(mdctx, md5pw, &md_len);
++ EVP_MD_CTX_free(mdctx);
+
+ /* see if we have a reusable connection available */
+ ICC_Active = NULL;
diff --git a/mail/pop3proxy/pkg-descr b/mail/pop3proxy/pkg-descr
index d7217080303f..2a3d537c8b98 100644
--- a/mail/pop3proxy/pkg-descr
+++ b/mail/pop3proxy/pkg-descr
@@ -1,2 +1,4 @@
-This is a POP3 proxycache server useful for use with webmail clients.
+This is a POP3 proxycache server, derived from up-imapproxy and is
+useful for use with webmail clients.
+
It keeps track of existing connections and caches them.