aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-02-09 11:16:49 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-02-09 11:16:49 +0000
commitba7bd679d1ac0fbdfa7eebfd449c0055dfc2292f (patch)
treeae79a4ec3c715b5ad93d17e15e27df852ba0051e
parent521afd35145b5510baece18a0eb1482144d9fed5 (diff)
downloadports-ba7bd679d1ac0fbdfa7eebfd449c0055dfc2292f.tar.gz
ports-ba7bd679d1ac0fbdfa7eebfd449c0055dfc2292f.zip
Notes
-rw-r--r--games/Makefile1
-rw-r--r--games/tbclock/Makefile28
-rw-r--r--games/tbclock/distinfo3
-rw-r--r--games/tbclock/pkg-descr6
4 files changed, 38 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 85e43783b215..e92d1d0f8a68 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -701,6 +701,7 @@
SUBDIR += taipan
SUBDIR += tank
SUBDIR += taxipilot
+ SUBDIR += tbclock
SUBDIR += tecnoballz
SUBDIR += teg
SUBDIR += tenebrae
diff --git a/games/tbclock/Makefile b/games/tbclock/Makefile
new file mode 100644
index 000000000000..26b4c3408f3f
--- /dev/null
+++ b/games/tbclock/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: tbclock
+# Date created: 9 February 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tbclock
+PORTVERSION= 1.9
+CATEGORIES= games
+MASTER_SITES= http://tamentis.com/projects/tbclock/files/ CSME
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Binary clock in curses
+
+#USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
+
+post-patch:
+ @${REINPLACE_CMD} -e '/ifeq/,/endif/d;/^CC/d;/^CFLAGS/d' ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/games/tbclock/distinfo b/games/tbclock/distinfo
new file mode 100644
index 000000000000..575587e39bc1
--- /dev/null
+++ b/games/tbclock/distinfo
@@ -0,0 +1,3 @@
+MD5 (tbclock-1.9.tar.gz) = 68e30f60ca594fb5c58d9bd4aa1a43a5
+SHA256 (tbclock-1.9.tar.gz) = 23fbf86a3c99f5e0a1f658ecf81e3eb2b981179c2e3c6c06638fc4fae39832d0
+SIZE (tbclock-1.9.tar.gz) = 11287
diff --git a/games/tbclock/pkg-descr b/games/tbclock/pkg-descr
new file mode 100644
index 000000000000..b8019d3950e6
--- /dev/null
+++ b/games/tbclock/pkg-descr
@@ -0,0 +1,6 @@
+tbclock is a dirty little app that displays a full screen binary clock
+in your terminal (using curses). It doesn't support resizing (yet). It
+is quite simple and features modules like 'guessbin' a little game and
+'chrono' a timer with tenth of seconds.
+
+WWW: http://tamentis.com/projects/tbclock/