aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-01-16 00:52:07 +0000
committerClement Laforet <clement@FreeBSD.org>2004-01-16 00:52:07 +0000
commitbb803091c2edae2aeadd85ad56d5f2a364e966f4 (patch)
treea640b62bbb555c3af7bac52a6d03f436770680e8
parent3d90109deac69888eda897fe8492c901179055f4 (diff)
downloadports-bb803091c2edae2aeadd85ad56d5f2a364e966f4.tar.gz
ports-bb803091c2edae2aeadd85ad56d5f2a364e966f4.zip
Notes
-rw-r--r--net-mgmt/bandwidthd/Makefile6
-rw-r--r--net-mgmt/bandwidthd/distinfo2
-rw-r--r--net-mgmt/bandwidthd/files/patch-Makefile14
-rw-r--r--net/bandwidthd/Makefile6
-rw-r--r--net/bandwidthd/distinfo2
-rw-r--r--net/bandwidthd/files/patch-Makefile14
6 files changed, 22 insertions, 22 deletions
diff --git a/net-mgmt/bandwidthd/Makefile b/net-mgmt/bandwidthd/Makefile
index e08fba31b8ca..da7839fec840 100644
--- a/net-mgmt/bandwidthd/Makefile
+++ b/net-mgmt/bandwidthd/Makefile
@@ -6,17 +6,17 @@
#
PORTNAME= bandwidthd
-PORTVERSION= 1.1.7
+PORTVERSION= 1.2.0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-1.1.7b
+DISTNAME= ${PORTNAME}-1.2.0b
EXTRACT_SUFX= .tgz
MAINTAINER= clement@FreeBSD.org
COMMENT= Tracks bandwidth usage by IP address
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+WRKSRC= ${WRKDIR}/${DISTNAME}
LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd\
iconv.3:${PORTSDIR}/converters/libiconv
diff --git a/net-mgmt/bandwidthd/distinfo b/net-mgmt/bandwidthd/distinfo
index 3225ba2e58ef..f1eb362b8da7 100644
--- a/net-mgmt/bandwidthd/distinfo
+++ b/net-mgmt/bandwidthd/distinfo
@@ -1 +1 @@
-MD5 (bandwidthd-1.1.7b.tgz) = c58100aefc62e0d2b20024838ba527bf
+MD5 (bandwidthd-1.2.0b.tgz) = 001e361f312dac69a2a5eec6ce52e550
diff --git a/net-mgmt/bandwidthd/files/patch-Makefile b/net-mgmt/bandwidthd/files/patch-Makefile
index 6e22c8e7cc16..e066326b0d40 100644
--- a/net-mgmt/bandwidthd/files/patch-Makefile
+++ b/net-mgmt/bandwidthd/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Tue Dec 2 21:39:05 2003
-+++ Makefile Fri Dec 5 02:30:31 2003
+--- Makefile.orig Wed Jan 14 21:38:17 2004
++++ Makefile Fri Jan 16 01:39:20 2004
@@ -1,8 +1,8 @@
#Possible optimizations -fomit-frame-pointer -ffast-math
OBS= bandwidthd.o graph.o conf.tab.o conf.l.o
@@ -16,15 +16,15 @@
rm -f *.o bandwidthd *~ conf.tab.c conf.tab.h conf.l.c DEADJOE
install: all
-- mkdir -p $(DESTDIR)/usr/local/bandwidthd/etc
-- mkdir -p $(DESTDIR)/usr/local/bandwidthd/htdocs
+- if [ ! -d $(DESTDIR)/usr/local/bandwidthd/etc ] ; then mkdir -p $(DESTDIR)/usr/local/bandwidthd/etc ; fi
+- if [ ! -d $(DESTDIR)/usr/local/bandwidthd/htdocs ] ; then mkdir -p $(DESTDIR)/usr/local/bandwidthd/htdocs ; fi
- cp bandwidthd $(DESTDIR)/usr/local/bandwidthd
-- cp etc/bandwidthd.conf $(DESTDIR)/usr/local/bandwidthd/etc/
+- if [ ! -f $(DESTDIR)/usr/local/bandwidthd/etc/bandwidthd.conf ] ; then cp etc/bandwidthd.conf $(DESTDIR)/usr/local/bandwidthd/etc/ ; fi
- cp htdocs/legend.gif $(DESTDIR)/usr/local/bandwidthd/htdocs/
- cp htdocs/logo.gif $(DESTDIR)/usr/local/bandwidthd/htdocs/
+ mkdir -p $(DESTDIR)${PREFIX}/bandwidthd/etc
+ mkdir -p $(DESTDIR)${PREFIX}/bandwidthd/htdocs
-+ ${BSD_INSTALL_PROGRAM} bandwidthd $(DESTDIR)${PREFIX}/bandwidthd
++ ${BSD_INSTALL_PROGRAM} bandwidthd $(DESTDIR)${PREFIX}/bandwidthd
+ ${BSD_INSTALL_DATA} etc/bandwidthd.conf $(DESTDIR)${PREFIX}/bandwidthd/etc/bandwidthd.conf-dist
+ ${BSD_INSTALL_DATA} htdocs/legend.gif $(DESTDIR)${PREFIX}/bandwidthd/htdocs/
+ ${BSD_INSTALL_DATA} htdocs/logo.gif $(DESTDIR)${PREFIX}/bandwidthd/htdocs/
@@ -32,4 +32,4 @@
#**** Stuff where -WALL is turned off to reduce the noise in a compile so I can see my own errors *******************
conf.l.o: conf.l.c
- $(CC) $(NONWALLCFLAGS) -c -o conf.l.o conf.l.c
-+ $(CC) -c -o conf.l.o conf.l.c
++ $(CC) -c -o conf.l.o conf.l.c
diff --git a/net/bandwidthd/Makefile b/net/bandwidthd/Makefile
index e08fba31b8ca..da7839fec840 100644
--- a/net/bandwidthd/Makefile
+++ b/net/bandwidthd/Makefile
@@ -6,17 +6,17 @@
#
PORTNAME= bandwidthd
-PORTVERSION= 1.1.7
+PORTVERSION= 1.2.0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-1.1.7b
+DISTNAME= ${PORTNAME}-1.2.0b
EXTRACT_SUFX= .tgz
MAINTAINER= clement@FreeBSD.org
COMMENT= Tracks bandwidth usage by IP address
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+WRKSRC= ${WRKDIR}/${DISTNAME}
LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd\
iconv.3:${PORTSDIR}/converters/libiconv
diff --git a/net/bandwidthd/distinfo b/net/bandwidthd/distinfo
index 3225ba2e58ef..f1eb362b8da7 100644
--- a/net/bandwidthd/distinfo
+++ b/net/bandwidthd/distinfo
@@ -1 +1 @@
-MD5 (bandwidthd-1.1.7b.tgz) = c58100aefc62e0d2b20024838ba527bf
+MD5 (bandwidthd-1.2.0b.tgz) = 001e361f312dac69a2a5eec6ce52e550
diff --git a/net/bandwidthd/files/patch-Makefile b/net/bandwidthd/files/patch-Makefile
index 6e22c8e7cc16..e066326b0d40 100644
--- a/net/bandwidthd/files/patch-Makefile
+++ b/net/bandwidthd/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Tue Dec 2 21:39:05 2003
-+++ Makefile Fri Dec 5 02:30:31 2003
+--- Makefile.orig Wed Jan 14 21:38:17 2004
++++ Makefile Fri Jan 16 01:39:20 2004
@@ -1,8 +1,8 @@
#Possible optimizations -fomit-frame-pointer -ffast-math
OBS= bandwidthd.o graph.o conf.tab.o conf.l.o
@@ -16,15 +16,15 @@
rm -f *.o bandwidthd *~ conf.tab.c conf.tab.h conf.l.c DEADJOE
install: all
-- mkdir -p $(DESTDIR)/usr/local/bandwidthd/etc
-- mkdir -p $(DESTDIR)/usr/local/bandwidthd/htdocs
+- if [ ! -d $(DESTDIR)/usr/local/bandwidthd/etc ] ; then mkdir -p $(DESTDIR)/usr/local/bandwidthd/etc ; fi
+- if [ ! -d $(DESTDIR)/usr/local/bandwidthd/htdocs ] ; then mkdir -p $(DESTDIR)/usr/local/bandwidthd/htdocs ; fi
- cp bandwidthd $(DESTDIR)/usr/local/bandwidthd
-- cp etc/bandwidthd.conf $(DESTDIR)/usr/local/bandwidthd/etc/
+- if [ ! -f $(DESTDIR)/usr/local/bandwidthd/etc/bandwidthd.conf ] ; then cp etc/bandwidthd.conf $(DESTDIR)/usr/local/bandwidthd/etc/ ; fi
- cp htdocs/legend.gif $(DESTDIR)/usr/local/bandwidthd/htdocs/
- cp htdocs/logo.gif $(DESTDIR)/usr/local/bandwidthd/htdocs/
+ mkdir -p $(DESTDIR)${PREFIX}/bandwidthd/etc
+ mkdir -p $(DESTDIR)${PREFIX}/bandwidthd/htdocs
-+ ${BSD_INSTALL_PROGRAM} bandwidthd $(DESTDIR)${PREFIX}/bandwidthd
++ ${BSD_INSTALL_PROGRAM} bandwidthd $(DESTDIR)${PREFIX}/bandwidthd
+ ${BSD_INSTALL_DATA} etc/bandwidthd.conf $(DESTDIR)${PREFIX}/bandwidthd/etc/bandwidthd.conf-dist
+ ${BSD_INSTALL_DATA} htdocs/legend.gif $(DESTDIR)${PREFIX}/bandwidthd/htdocs/
+ ${BSD_INSTALL_DATA} htdocs/logo.gif $(DESTDIR)${PREFIX}/bandwidthd/htdocs/
@@ -32,4 +32,4 @@
#**** Stuff where -WALL is turned off to reduce the noise in a compile so I can see my own errors *******************
conf.l.o: conf.l.c
- $(CC) $(NONWALLCFLAGS) -c -o conf.l.o conf.l.c
-+ $(CC) -c -o conf.l.o conf.l.c
++ $(CC) -c -o conf.l.o conf.l.c