aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-01-22 15:58:23 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-01-22 15:58:23 +0000
commitbc033e9fec6f3f3e2e33e3db8a6cf17ca4fde3ba (patch)
tree8cebc697c89364480a67bf4de21540e929ab7190
parentf69b6ad118aac1593fbd64bd2bba065b9f1a7e19 (diff)
downloadports-bc033e9fec6f3f3e2e33e3db8a6cf17ca4fde3ba.tar.gz
ports-bc033e9fec6f3f3e2e33e3db8a6cf17ca4fde3ba.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-jsonslicer/Makefile27
-rw-r--r--textproc/py-jsonslicer/distinfo3
-rw-r--r--textproc/py-jsonslicer/pkg-descr10
4 files changed, 41 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 5c6b50cc7f49..e451bb829525 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1316,6 +1316,7 @@
SUBDIR += py-hyperestraier-python
SUBDIR += py-hypua2jamo
SUBDIR += py-jaxml
+ SUBDIR += py-jsonslicer
SUBDIR += py-jtextfsm
SUBDIR += py-junit-xml
SUBDIR += py-laserhammer
diff --git a/textproc/py-jsonslicer/Makefile b/textproc/py-jsonslicer/Makefile
new file mode 100644
index 000000000000..4cc763551b7a
--- /dev/null
+++ b/textproc/py-jsonslicer/Makefile
@@ -0,0 +1,27 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= jsonslicer
+PORTVERSION= 0.1.0
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Stream JSON parser for Python
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libyajl.so:devel/yajl
+
+USES= python:3.5+ pkgconfig
+USE_PYTHON= autoplist distutils
+
+# pydistutils problem, it uses CC for compiling C++ code
+CC= ${CXX}
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>
diff --git a/textproc/py-jsonslicer/distinfo b/textproc/py-jsonslicer/distinfo
new file mode 100644
index 000000000000..2fd2f219436b
--- /dev/null
+++ b/textproc/py-jsonslicer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1548164974
+SHA256 (jsonslicer-0.1.0.tar.gz) = 9e2e4b9e0cb03b7b5519c5289f5b1b9b43ec69f0d0c617a264f650fc3d9c99bd
+SIZE (jsonslicer-0.1.0.tar.gz) = 21458
diff --git a/textproc/py-jsonslicer/pkg-descr b/textproc/py-jsonslicer/pkg-descr
new file mode 100644
index 000000000000..152028f32e1a
--- /dev/null
+++ b/textproc/py-jsonslicer/pkg-descr
@@ -0,0 +1,10 @@
+JsonSlicer performs a stream or iterative, pull JSON parsing, which
+means it does not load whole JSON into memory and is able to parse
+very large JSON files or streams. The module is written in C and
+uses YAJL JSON parsing library, so it's also quite fast.
+
+JsonSlicer takes a path of JSON map keys or array indexes, and
+provides iterator interface which yields JSON data matching given
+path as complete Python objects.
+
+WWW: https://pypi.org/project/jsonslicer/