aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-12 12:11:04 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-12 12:11:04 +0000
commitbc211ca30d70acaea21155d3adcba4e3cb004809 (patch)
treefdd0b2f1922cb4552a3ae146f4bcce9304ceb25e
parent7aa0a38bf055df623aa1e31f21f004d0985e345b (diff)
Notes
-rw-r--r--math/Makefile1
-rw-r--r--math/clipper/Makefile20
-rw-r--r--math/clipper/distinfo2
-rw-r--r--math/clipper/pkg-descr7
-rw-r--r--math/clipper/pkg-plist5
5 files changed, 35 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 026761f578a3..c67a498c9c4f 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -73,6 +73,7 @@
SUBDIR += chaco
SUBDIR += chryzodus
SUBDIR += clarence
+ SUBDIR += clipper
SUBDIR += cln
SUBDIR += clp
SUBDIR += coinmp
diff --git a/math/clipper/Makefile b/math/clipper/Makefile
new file mode 100644
index 000000000000..1f5238b2fb6e
--- /dev/null
+++ b/math/clipper/Makefile
@@ -0,0 +1,20 @@
+# Created by: Martin Dieringer <martin.dieringer@gmx.de>
+# $FreeBSD$
+
+PORTNAME= clipperlib
+PORTVERSION= 5.0.3
+CATEGORIES= math
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= polyclipping
+DISTNAME= clipper_ver${PORTVERSION}
+
+MAINTAINER= martin.dieringer@gmx.de
+COMMENT= Polygon clipping library
+
+WRKSRC= ${WRKDIR}/cpp
+
+USE_LDCONFIG= yes
+USE_ZIP= yes
+USE_CMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/math/clipper/distinfo b/math/clipper/distinfo
new file mode 100644
index 000000000000..929e960f73ce
--- /dev/null
+++ b/math/clipper/distinfo
@@ -0,0 +1,2 @@
+SHA256 (clipper_ver5.0.3.zip) = e48178e84b51b4ef7a1d13c0c6e1536e4e55ade71d893c26ba533915fc98fac3
+SIZE (clipper_ver5.0.3.zip) = 1557310
diff --git a/math/clipper/pkg-descr b/math/clipper/pkg-descr
new file mode 100644
index 000000000000..8d9e2757d84e
--- /dev/null
+++ b/math/clipper/pkg-descr
@@ -0,0 +1,7 @@
+The Clipper library primarily performs boolean clipping (intersection,
+union, difference and xor) on polygons in 2D space. There are no
+restrictions on either the number nor the type of polygon that can be
+clipped. They can have holes, be self-intersecting and even have coincident
+edges. The library also performs polygon offsetting
+
+WWW: http://www.angusj.com/delphi/clipper.php
diff --git a/math/clipper/pkg-plist b/math/clipper/pkg-plist
new file mode 100644
index 000000000000..31914c3b1928
--- /dev/null
+++ b/math/clipper/pkg-plist
@@ -0,0 +1,5 @@
+include/polyclipping/clipper.hpp
+lib/libpolyclipping.so.5.0.0
+lib/libpolyclipping.so.5
+lib/libpolyclipping.so
+@dirrmtry include/polyclipping