aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2018-01-11 20:29:52 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2018-01-11 20:29:52 +0000
commitbd7f4e1d0f199bc375337d8549a9f830205826b8 (patch)
tree5f0959b0e16a2761f76071adfbf9c21d4576d6fb
parentc37370b2fcee045d3c102ae64b23a0ddb5292f43 (diff)
downloadports-bd7f4e1d0f199bc375337d8549a9f830205826b8.tar.gz
ports-bd7f4e1d0f199bc375337d8549a9f830205826b8.zip
Rename editors/vim-lite to editors/vim-console. The vim-console port isn't
actually any lighter---it's built with exactly the same feature-set as the main vim port. The only difference is lack of gtk20 GUI, and the language bindings are off by default. An UPDATING entry is included.
Notes
Notes: svn path=/head/; revision=458784
-rw-r--r--MOVED1
-rw-r--r--UPDATING14
-rw-r--r--editors/Makefile2
-rw-r--r--editors/vim-console/Makefile (renamed from editors/vim-lite/Makefile)6
-rw-r--r--editors/vim-console/pkg-descr (renamed from editors/vim-lite/pkg-descr)6
-rw-r--r--editors/vim-tiny/Makefile2
-rw-r--r--editors/vim/Makefile4
7 files changed, 25 insertions, 10 deletions
diff --git a/MOVED b/MOVED
index c6a689de76b0..cffe836b19a8 100644
--- a/MOVED
+++ b/MOVED
@@ -9844,3 +9844,4 @@ devel/p5-MooseX-Role-WithOverloading||2018-01-06|Has expired: deprecated by upst
devel/p5-Test-Block||2018-01-06|Has expired: Marked as deprecated upstream
sysutils/socket||2018-01-06|Has expired: Out of date
x11-toolkits/qt5-declarative-render2d/||2018-01-06|Merged into x11-toolkits/qt5-quick
+editors/vim-lite|editors/vim-console|2018-01-11|Renamed to reflect that it is console-only, not any lighter
diff --git a/UPDATING b/UPDATING
index 3722314844d8..cf913936d9b7 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,20 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20180111
+ AFFECTS: users of editors/vim-lite
+ AUTHOR: adamw@FreeBSD.org
+
+ The vim-lite port has been renamed to vim-console, because it isn't
+ actually any lighter. All three vim packages are built with
+ --enable-features=huge. pkg should handle the change transparently,
+ but portmaster users might need to run this command:
+
+ portmaster -o editors/vim-console editors/vim-lite
+
+ If the switch doesn't happen automatically for you, just delete the
+ vim-lite package and install vim-console.
+
20180109
AFFECTS: users of www/qt5-webengine
AUTHOR: kde@FreeBSD.org
diff --git a/editors/Makefile b/editors/Makefile
index 28fe8debe1e8..ac5b41682945 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -243,7 +243,7 @@
SUBDIR += vigor
SUBDIR += vile
SUBDIR += vim
- SUBDIR += vim-lite
+ SUBDIR += vim-console
SUBDIR += vim-tiny
SUBDIR += web-mode
SUBDIR += with-editor
diff --git a/editors/vim-lite/Makefile b/editors/vim-console/Makefile
index dc1251dfd113..5392f8c47bf5 100644
--- a/editors/vim-lite/Makefile
+++ b/editors/vim-console/Makefile
@@ -1,13 +1,13 @@
# Created by: David O'Brien (obrien@NUXI.com)
# $FreeBSD$
-PKGNAMESUFFIX= -lite
+PKGNAMESUFFIX= -console
-COMMENT= Improved version of the vi editor (lite package)
+COMMENT= Improved version of the vi editor (console only)
CONFLICTS_INSTALL= vim vim-tiny
-LITE= yes
+CONSOLE= yes
MASTERDIR= ${.CURDIR}/../vim
.include "${MASTERDIR}/Makefile"
diff --git a/editors/vim-lite/pkg-descr b/editors/vim-console/pkg-descr
index 3dcc27c71e4b..bef080aff377 100644
--- a/editors/vim-lite/pkg-descr
+++ b/editors/vim-console/pkg-descr
@@ -6,9 +6,9 @@ many consider it an entire IDE. It's not just for programmers, though. Vim is
perfect for all kinds of text editing, from composing email to editing
configuration files.
-This is the "lite" version, which is console-only and contains no external
-languange bindings (for Ruby, Python, etc.). The editing experience for files
-of those languages is unaffected.
+This is the console-only version. It differs from the main vim package only in
+lack of Gtk2 GUI and no external language bindings. The editing experience is
+identical.
WWW: http://www.vim.org/
WWW: https://github.com/vim/vim
diff --git a/editors/vim-tiny/Makefile b/editors/vim-tiny/Makefile
index 028e3344685f..0423f8044180 100644
--- a/editors/vim-tiny/Makefile
+++ b/editors/vim-tiny/Makefile
@@ -5,7 +5,7 @@ PKGNAMESUFFIX= -tiny
COMMENT= Improved version of the vi editor (vim binary only)
-CONFLICTS_INSTALL= vim vim-lite
+CONFLICTS_INSTALL= vim vim-console
TINY= yes
MASTERDIR= ${.CURDIR}/../vim
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index c50c1fb1641e..7ea54b490c50 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -14,7 +14,7 @@ LICENSE_NAME= VIM License
LICENSE_FILE= ${WRKSRC}/runtime/doc/uganda.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-CONFLICTS_INSTALL?= vim-lite vim-tiny
+CONFLICTS_INSTALL?= vim-console vim-tiny
USES= cpe iconv ncurses pkgconfig shebangfix
USE_GITHUB= yes
@@ -45,7 +45,7 @@ OPTIONS_GROUP= LANGBIND
OPTIONS_GROUP_LANGBIND= LUA PERL PYTHON2 PYTHON3 RUBY SCHEME TCL
OPTIONS_SUB= yes
-.if defined(LITE)
+.if defined(CONSOLE)
OPTIONS_DEFAULT= DEFAULT_VIMRC
OPTIONS_SLAVE= CONSOLE
# Exclude everything except the two options above