aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-08-18 12:52:48 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-08-18 12:52:48 +0000
commitbe54add2e8d0c2cd99a1ccb6b9e71cb7ee12ef44 (patch)
treef2886a19d3ff4c089dc4443acfd068129a50fb61
parent4b31a0397855bc53159f02edb869b74a26189c9f (diff)
downloadports-be54add2e8d0c2cd99a1ccb6b9e71cb7ee12ef44.tar.gz
ports-be54add2e8d0c2cd99a1ccb6b9e71cb7ee12ef44.zip
Notes
-rw-r--r--security/ruby-ssl/Makefile21
-rw-r--r--security/ruby-ssl/distinfo2
-rw-r--r--security/ruby-ssl/pkg-plist5
3 files changed, 24 insertions, 4 deletions
diff --git a/security/ruby-ssl/Makefile b/security/ruby-ssl/Makefile
index 7d97c69d07bf..b8035ddcb656 100644
--- a/security/ruby-ssl/Makefile
+++ b/security/ruby-ssl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ssl
-PORTVERSION= 0.3.1c
+PORTVERSION= 0.3.2
CATEGORIES= security ruby
MASTER_SITES= http://www.notwork.org/~gotoyuzo/ruby/src/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -22,12 +22,27 @@ CONFIGURE_ARGS= --with-openssl-include="${OPENSSLBASE}/include/openssl" \
--with-openssl-lib="${OPENSSLBASE}/lib"
INSTALL_TARGET= site-install
+DOCS_EN= ChangeLog doc/ssl.html doc/ssl.rd
+DOCS_JA= doc/ssl.ja.html doc/ssl.ja.rd
+
+post-build:
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC}; \
+ ${RUBY_RD} doc/ssl.rd > doc/ssl.html; \
+ ${RUBY_RD} doc/ssl.ja.rd > doc/ssl.ja.html
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
- ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${RUBY_DOCDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/ja/
+.endfor
.endif
.include <bsd.port.mk>
diff --git a/security/ruby-ssl/distinfo b/security/ruby-ssl/distinfo
index 76225d039b97..268fa5b31608 100644
--- a/security/ruby-ssl/distinfo
+++ b/security/ruby-ssl/distinfo
@@ -1 +1 @@
-MD5 (ruby/ssl-0.3.1c.tar.gz) = be81df1ab45b8260064a11b3c2ff11f5
+MD5 (ruby/ssl-0.3.2.tar.gz) = a9743e897c54e28b64b725485f2f6d1a
diff --git a/security/ruby-ssl/pkg-plist b/security/ruby-ssl/pkg-plist
index d91f6337cefb..e968b35ce50f 100644
--- a/security/ruby-ssl/pkg-plist
+++ b/security/ruby-ssl/pkg-plist
@@ -16,4 +16,9 @@
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/ssl/x509.rb
%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/ssl
%%PORTDOCS%%%%RUBY_DOCDIR%%/ssl/ChangeLog
+%%PORTDOCS%%%%RUBY_DOCDIR%%/ssl/ssl.html
+%%PORTDOCS%%%%RUBY_DOCDIR%%/ssl/ssl.rd
+%%PORTDOCS%%%%RUBY_DOCDIR%%/ssl/ja/ssl.ja.html
+%%PORTDOCS%%%%RUBY_DOCDIR%%/ssl/ja/ssl.ja.rd
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/ssl/ja
%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/ssl