aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2024-05-07 08:11:25 +0000
committerJason E. Hale <jhale@FreeBSD.org>2024-05-07 09:05:20 +0000
commitbf067dc10cfd953b3a49ce2fdd4b89e34b3dcf98 (patch)
treeb07ebb3e3f4312a2faa125a24e287236f5ecc806
parent35d45549fc975bcf40590c38f6aa1dec5fbb38b8 (diff)
downloadports-bf067dc10cfd953b3a49ce2fdd4b89e34b3dcf98.tar.gz
ports-bf067dc10cfd953b3a49ce2fdd4b89e34b3dcf98.zip
net-im/psi: Fix build with ninja >= 1.12.0
Address a race condition where included headers generated by uic are not created before they used in the build. Not upstreaming this as the last release was in 2020 and the codebase has diverged too much since then. PR: 278693 Approved by: portmgr (blanket)
-rw-r--r--net-im/psi/files/patch-src_tabs_CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/net-im/psi/files/patch-src_tabs_CMakeLists.txt b/net-im/psi/files/patch-src_tabs_CMakeLists.txt
new file mode 100644
index 000000000000..7065720f7dfe
--- /dev/null
+++ b/net-im/psi/files/patch-src_tabs_CMakeLists.txt
@@ -0,0 +1,10 @@
+Fix a race condition with ninja >= 1.12.0 where included headers have not
+yet been generated by uic.
+
+--- src/tabs/CMakeLists.txt.orig 2020-09-06 07:44:34 UTC
++++ src/tabs/CMakeLists.txt
+@@ -22,3 +22,4 @@ target_include_directories(tabs PUBLIC ${CMAKE_CURRENT
+ add_library(tabs STATIC ${HEADERS} ${MOC_SOURCES} ${PLAIN_SOURCES})
+ target_link_libraries(tabs ${QT_LIBRARIES} ${iris_LIB} tools widgets)
+ target_include_directories(tabs PUBLIC ${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR})
++add_dependencies(tabs build_ui_files)