aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2016-01-10 16:15:29 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2016-01-10 16:15:29 +0000
commitbf548998cb24c05770825e2daebd4c059d48e3d9 (patch)
tree346e9748a622055ab082c022cb1bed48887ade9c
parente259244a333dbb1aa3da1ccbb780c9c0a6c81b2f (diff)
downloadports-bf548998cb24c05770825e2daebd4c059d48e3d9.tar.gz
ports-bf548998cb24c05770825e2daebd4c059d48e3d9.zip
Introduce 2 new USES: sqlite and firebird
sqlite and firebird handling code has been extracted from bsd.databases.mk add an entry in bsd.sanity.mk to mark USE_SQLITE and USE_FIREBIRD as deprecated
Notes
Notes: svn path=/head/; revision=405716
-rw-r--r--CHANGES6
-rw-r--r--Mk/Uses/firebird.mk23
-rw-r--r--Mk/Uses/sqlite.mk24
-rw-r--r--Mk/bsd.sanity.mk5
4 files changed, 57 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index 9b7db386c938..5f4838338c4c 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,12 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20150110:
+AUTHOR: bapt@FreeBSD.org
+
+ USE_FIREBIRD and USE_SQLITE has been replaced by USES=firebird and
+ USES=sqlite
+
20151105:
AUTHOR: mat@FreeBSD.org
diff --git a/Mk/Uses/firebird.mk b/Mk/Uses/firebird.mk
new file mode 100644
index 000000000000..2f9b9662a1d2
--- /dev/null
+++ b/Mk/Uses/firebird.mk
@@ -0,0 +1,23 @@
+# $FreeBSD$
+#
+# Provide support for SQLite
+# Feature: sqlite
+# Usage: USES= sqlite[:version]
+# MAINTAINER: ports@FreeBSD.org
+
+.if !defined(_INCLUDE_USES_FIREBIRD_MK)
+_INCLUDE_USES_FIREBIRD_MK= yes
+.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
+
+.if !empty(firebird_ARGS)
+FIREBIRD_VER= ${firebird_ARGS}
+.endif
+
+FIREBIRD_VER?= ${FIREBIRD_DEFAULT:S/.//}
+
+.if ${FIREBIRD_VER} == 25
+LIB_DEPENDS+= libfbclient.so:${PORTSDIR}/databases/firebird25-client
+.else
+IGNORE= cannot install: unknown Firebird version: ${FIREBIRD_VER}
+.endif
+.endif
diff --git a/Mk/Uses/sqlite.mk b/Mk/Uses/sqlite.mk
new file mode 100644
index 000000000000..9110140ec30b
--- /dev/null
+++ b/Mk/Uses/sqlite.mk
@@ -0,0 +1,24 @@
+# $FreeBSD$
+#
+# Provide support for SQLite
+# Feature: sqlite
+# Usage: USES= sqlite[:version]
+# MAINTAINER: ports@FreeBSD.org
+
+.if !defined(_INCLUDE_USES_SQLITE_MK)
+_INCLUDE_USES_SQLITE_MK= yes
+
+.if !empty(sqlite_ARGS)
+SQLITE_VER= ${sqlite_ARGS}
+.endif
+SQLITE_VER?= 3
+
+.if ${SQLITE_VER} == 3
+LIB_DEPENDS+= libsqlite3.so:${PORTSDIR}/databases/sqlite${SQLITE_VER}
+.elif ${SQLITE_VER} == 2
+LIB_DEPENDS+= libsqlite.so:${PORTSDIR}/databases/sqlite${SQLITE_VER}
+.else
+IGNORE= cannot install: unknown SQLite version: ${SQLITE_VER}
+.endif
+
+.endif
diff --git a/Mk/bsd.sanity.mk b/Mk/bsd.sanity.mk
index fa5e543183f6..0bfaae46f35a 100644
--- a/Mk/bsd.sanity.mk
+++ b/Mk/bsd.sanity.mk
@@ -165,7 +165,8 @@ SANITY_UNSUPPORTED= USE_OPENAL USE_FAM USE_MAKESELF USE_ZIP USE_LHA USE_CMAKE \
PYDISTUTILS_AUTOPLIST PYTHON_PY3K_PLIST_HACK PYDISTUTILS_NOEGGINFO \
USE_PYTHON_PREFIX USE_BZIP2 USE_XZ USE_PGSQL NEED_ROOT \
UNIQUENAME LATEST_LINK
-SANITY_DEPRECATED= PYTHON_PKGNAMESUFFIX USE_AUTOTOOLS PLIST_DIRSTRY
+SANITY_DEPRECATED= PYTHON_PKGNAMESUFFIX USE_AUTOTOOLS PLIST_DIRSTRY USE_SQLITE \
+ USE_FIREBIRD
SANITY_NOTNEEDED= WX_UNICODE
USE_AUTOTOOLS_ALT= USES=autoreconf and GNU_CONFIGURE=yes
@@ -204,6 +205,8 @@ UNIQUENAME_ALT= PKGBASE
LATEST_LINK_ALT= PKGBASE
WX_UNICODE_REASON= Now no-op as only unicode is supported now
PLIST_DIRSTRY_ALT= PLIST_DIRS
+USE_SQLITE_ALT= USES=sqlite
+USE_FIREBIRD_ALT= USES=firebird
.for a in ${SANITY_DEPRECATED}
.if defined(${a})