aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-01-11 13:29:02 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-01-11 13:29:02 +0000
commitbfc190d08abef7f813405b4ea12388d6d8f37048 (patch)
treeaf09617e58211d4b5cc7f9dee1ddf9a2779b4c82
parent7f515c0660e246b662515697d4cd3d3921584caa (diff)
downloadports-bfc190d08abef7f813405b4ea12388d6d8f37048.tar.gz
ports-bfc190d08abef7f813405b4ea12388d6d8f37048.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-URI-ws/Makefile22
-rw-r--r--net/p5-URI-ws/distinfo2
-rw-r--r--net/p5-URI-ws/pkg-descr4
-rw-r--r--net/p5-URI-ws/pkg-plist4
5 files changed, 33 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 17bbc4a67f9e..51427d8e6d55 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -748,6 +748,7 @@
SUBDIR += p5-URI-SmartURI
SUBDIR += p5-URI-Template
SUBDIR += p5-URI-Template-Restrict
+ SUBDIR += p5-URI-ws
SUBDIR += p5-Validate-Net
SUBDIR += p5-WebService-Dropbox
SUBDIR += p5-WebService-Prowl
diff --git a/net/p5-URI-ws/Makefile b/net/p5-URI-ws/Makefile
new file mode 100644
index 000000000000..4c756cbccca6
--- /dev/null
+++ b/net/p5-URI-ws/Makefile
@@ -0,0 +1,22 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= URI-ws
+PORTVERSION= 0.03
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= WebSocket support for URI package
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/net/p5-URI-ws/distinfo b/net/p5-URI-ws/distinfo
new file mode 100644
index 000000000000..3f0220c75a35
--- /dev/null
+++ b/net/p5-URI-ws/distinfo
@@ -0,0 +1,2 @@
+SHA256 (URI-ws-0.03.tar.gz) = 6e6b0e4172acb6a53c222639c000608c2dd61d50848647482ac8600d50e541ef
+SIZE (URI-ws-0.03.tar.gz) = 11724
diff --git a/net/p5-URI-ws/pkg-descr b/net/p5-URI-ws/pkg-descr
new file mode 100644
index 000000000000..f23931245d98
--- /dev/null
+++ b/net/p5-URI-ws/pkg-descr
@@ -0,0 +1,4 @@
+After URI::ws is installed, the URI package provides the same set of methods for
+WebSocket URIs as it does for HTTP ones. For secure WebSockets, see URI::wss.
+
+WWW: http://search.cpan.org/dist/URI-ws/
diff --git a/net/p5-URI-ws/pkg-plist b/net/p5-URI-ws/pkg-plist
new file mode 100644
index 000000000000..b5684eb988b4
--- /dev/null
+++ b/net/p5-URI-ws/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/URI/ws.pm
+%%SITE_PERL%%/URI/wss.pm
+%%PERL5_MAN3%%/URI::ws.3.gz
+%%PERL5_MAN3%%/URI::wss.3.gz