aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-03-10 04:29:40 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-03-10 04:29:40 +0000
commitc03074170cb86338e6f82313fba9dbcf8fd4fa52 (patch)
treeaa41acef77d91a41b6bcd41a926788b83b0a655b
parent61de6b5254884d2b9155a72a92609e79412f191d (diff)
downloadports-c03074170cb86338e6f82313fba9dbcf8fd4fa52.tar.gz
ports-c03074170cb86338e6f82313fba9dbcf8fd4fa52.zip
Notes
-rw-r--r--audio/audacity/Makefile15
-rw-r--r--audio/audacity/distinfo6
-rw-r--r--audio/audacity/files/patch-configure.ac19
-rw-r--r--audio/audacity/files/patch-src_MemoryX.h12
-rw-r--r--audio/audacity/pkg-plist4
5 files changed, 35 insertions, 21 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index 517e0f4c2db2..2674167d0612 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= audacity
-PORTVERSION= 2.3.0
+PORTVERSION= 2.3.1
DISTVERSIONPREFIX= Audacity-
-PORTREVISION= 5
CATEGORIES= audio
MAINTAINER= xxjack12xx@gmail.com
@@ -25,7 +24,9 @@ LIB_DEPENDS= libasound.so:audio/alsa-lib \
libsoxr.so:audio/libsoxr \
libsndfile.so:audio/libsndfile
-USES= autoreconf compiler:c++11-lib cpe desktop-file-utils gettext-tools gmake iconv libtool pkgconfig shared-mime-info shebangfix dos2unix localbase
+USES= autoreconf compiler:c++11-lib cpe desktop-file-utils dos2unix \
+ gettext-tools gmake gnome iconv libtool localbase pkgconfig \
+ shared-mime-info shebangfix
GNU_CONFIGURE= yes
NLS_USES= gettext-runtime
NLS_CONFIGURE_ENABLE= nls
@@ -39,8 +40,9 @@ DOS2UNIX_GLOB= Makefile.* *.c* *.h
SHEBANG_FILES= lib-src/lv2/build
USE_GITHUB= yes
-OPTIONS_DEFINE= NLS DEBUG DOCS DYNLOAD FFMPEG FLAC ID3TAG LADSPA LAME LV2 \
- MAD MOD_SCRIPT_PIPE MOD_NYQ_BENCH SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS VST
+OPTIONS_DEFINE= DEBUG DOCS DYNLOAD FFMPEG FLAC ID3TAG LADSPA LAME LV2 MAD \
+ MOD_NYQ_BENCH MOD_SCRIPT_PIPE NLS SBSMS SOUNDTOUCH STATIC_WX \
+ TWOLAME VAMP VORBIS VST
OPTIONS_DEFAULT= FLAC ID3TAG LADSPA MAD \
SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS VST
@@ -57,6 +59,7 @@ MOD_SCRIPT_PIPE_DESC= mod-script-pipe scripting support
MOD_NYQ_BENCH_DESC= Enable Nyquist Workbench
SBSMS_DESC= Use libsbsms for pitch and tempo changing
SOUNDTOUCH_DESC= Use libSoundTouch for pitch and tempo changing
+STATIC_WX_DESC= Link wx statically
TAGLIB_DESC= Use TagLib for metadata support
TWOLAME_DESC= Use libtwolame for MP2 export support
VAMP_DESC= Vamp plug-in support
@@ -128,6 +131,8 @@ SOUNDTOUCH_LIB_DEPENDS= libSoundTouch.so:audio/soundtouch
SSE_CONFIGURE_ENABLE= sse
+STATIC_WX_ENABLE= static-wx
+
TWOLAME_CONFIGURE_WITH= libtwolame=system
TWOLAME_LIB_DEPENDS= libtwolame.so:audio/twolame
diff --git a/audio/audacity/distinfo b/audio/audacity/distinfo
index e828e68409e1..3d758166f60e 100644
--- a/audio/audacity/distinfo
+++ b/audio/audacity/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1538360236
-SHA256 (audacity-audacity-Audacity-2.3.0_GH0.tar.gz) = 37127f68dceeb5da08d008ec9373a65e2d5d0a9b937c808a5d7c3b88aa9e275e
-SIZE (audacity-audacity-Audacity-2.3.0_GH0.tar.gz) = 27479664
+TIMESTAMP = 1552123965
+SHA256 (audacity-audacity-Audacity-2.3.1_GH0.tar.gz) = 2ef1c06f9cdc2ee3d315b8e575dc2bea5b372f4f415f3dc6570c3cfca0f93321
+SIZE (audacity-audacity-Audacity-2.3.1_GH0.tar.gz) = 27618480
diff --git a/audio/audacity/files/patch-configure.ac b/audio/audacity/files/patch-configure.ac
index 536f23a7145e..55b13b364147 100644
--- a/audio/audacity/files/patch-configure.ac
+++ b/audio/audacity/files/patch-configure.ac
@@ -1,6 +1,21 @@
---- configure.ac.orig 2018-09-20 14:35:07 UTC
+--- configure.ac.orig 2019-02-24 08:28:05 UTC
+++ configure.ac
-@@ -235,20 +235,7 @@ dnl check if alloca.h exists. If it does, we need to i
+@@ -204,14 +204,6 @@ if test x$enable_universal_binary = xyes; then
+ esac
+ fi
+
+-dnl Check if $CXX is clang by evaluating the version string because
+-dnl $ax_cv_cxx_compiler_vendor seems not to work (it is either "gnu" or just empty).
+-dnl If $CXX is clang (string is found), grep returns 0 and the if is executed.
+-dnl Use /dev/null to suppress grep output to shell.
+-if ($CXX --version | grep 'clang version' > /dev/null); then
+- LDFLAGS="${LDFLAGS} -latomic"
+-fi
+-
+ if test x$enable_sse = xyes; then
+
+ if test "${ax_cv_cxx_compiler_vendor}" = "gnu"; then
+@@ -243,20 +235,7 @@ dnl check if alloca.h exists. If it does, we need to i
dnl Solaris builds, by defining HAVE_ALLOCA_H
AC_CHECK_HEADERS_ONCE(alloca.h)
diff --git a/audio/audacity/files/patch-src_MemoryX.h b/audio/audacity/files/patch-src_MemoryX.h
index e8c86f8af7be..6cb3fd6cc396 100644
--- a/audio/audacity/files/patch-src_MemoryX.h
+++ b/audio/audacity/files/patch-src_MemoryX.h
@@ -1,14 +1,6 @@
---- src/MemoryX.h.orig 2018-10-01 14:07:33 UTC
+--- src/MemoryX.h.orig 2019-03-09 11:55:09 UTC
+++ src/MemoryX.h
-@@ -1,6 +1,7 @@
- #ifndef __AUDACITY_MEMORY_X_H__
- #define __AUDACITY_MEMORY_X_H__
-
-+#include <stdlib.h>
- // C++ standard header <memory> with a few extensions
- #include <memory>
- #include <cstdlib> // Needed for free.
-@@ -706,7 +707,7 @@ make_value_transform_iterator(const Iterator &iterator
+@@ -628,7 +628,7 @@ make_iterator_range( const Container &container )
// For using std::unordered_map on wxString
namespace std
{
diff --git a/audio/audacity/pkg-plist b/audio/audacity/pkg-plist
index e09054f96464..adadc23e101c 100644
--- a/audio/audacity/pkg-plist
+++ b/audio/audacity/pkg-plist
@@ -3,14 +3,15 @@ man/man1/audacity.1.gz
share/appdata/audacity.appdata.xml
share/applications/audacity.desktop
%%DATADIR%%/EQDefaultCurves.xml
+%%DATADIR%%/include/audacity/ComponentInterface.h
%%DATADIR%%/include/audacity/ConfigInterface.h
%%DATADIR%%/include/audacity/EffectAutomationParameters.h
%%DATADIR%%/include/audacity/EffectInterface.h
-%%DATADIR%%/include/audacity/IdentInterface.h
%%DATADIR%%/include/audacity/ImporterInterface.h
%%DATADIR%%/include/audacity/ModuleInterface.h
%%DATADIR%%/include/audacity/PluginInterface.h
%%DATADIR%%/include/audacity/Types.h
+%%DATADIR%%/nyquist/aud-do-support.lsp
%%DATADIR%%/nyquist/dspprims.lsp
%%DATADIR%%/nyquist/envelopes.lsp
%%DATADIR%%/nyquist/equalizer.lsp
@@ -73,6 +74,7 @@ share/applications/audacity.desktop
%%DATADIR%%/plug-ins/pluck.ny
%%DATADIR%%/plug-ins/rhythmtrack.ny
%%DATADIR%%/plug-ins/rissetdrum.ny
+%%DATADIR%%/plug-ins/rms.ny
%%DATADIR%%/plug-ins/sample-data-export.ny
%%DATADIR%%/plug-ins/sample-data-import.ny
%%DATADIR%%/plug-ins/tremolo.ny