aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-03-17 17:28:19 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-03-17 17:28:19 +0000
commitc06199448ab07086de7c0aaf24fcb234087abf6f (patch)
tree953f32b32ff4992a85d05f142be6b164c39068fc
parent46698bd4b8e20864430c8bcb7f1c028d1c32db43 (diff)
downloadports-c06199448ab07086de7c0aaf24fcb234087abf6f.tar.gz
ports-c06199448ab07086de7c0aaf24fcb234087abf6f.zip
Notes
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/hastmon/Makefile46
-rw-r--r--net-mgmt/hastmon/distinfo2
-rw-r--r--net-mgmt/hastmon/pkg-descr8
4 files changed, 57 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 9321bef64acd..21b382985eb6 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -80,6 +80,7 @@
SUBDIR += grepcidr
SUBDIR += grepip
SUBDIR += gsnmp
+ SUBDIR += hastmon
SUBDIR += horde-nic
SUBDIR += icinga
SUBDIR += icmpmonitor
diff --git a/net-mgmt/hastmon/Makefile b/net-mgmt/hastmon/Makefile
new file mode 100644
index 000000000000..db2db380745b
--- /dev/null
+++ b/net-mgmt/hastmon/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: hastmon
+# Date created: 23 October 2010
+# Whom: Mikolaj Golub <to.my.trociny@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hastmon
+PORTVERSION= 0.3.0
+CATEGORIES= net-mgmt
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= to.my.trociny@gmail.com
+COMMENT= Cluster monitoring daemon
+
+BUILD_DEPENDS= mk-configure>=0.20:${PORTSDIR}/devel/mk-configure
+
+LICENSE= BSD
+
+MKCMAKE?= ${LOCALBASE}/bin/mkcmake
+INSTALL_TARGET= installdirs install
+
+PORTDOCS= ChangeLog COPYRIGHT README
+
+MAN5= hastmon.conf.5
+MAN8= hastmon.8 hastmonctl.8
+
+PLIST_FILES= sbin/hastmon \
+ sbin/hastmonctl \
+ etc/rc.d/hastmon
+
+do-build:
+ ${SETENV} ${MKCMAKE_ENV} ${MKCMAKE} -C ${WRKSRC}
+
+do-install:
+ ${SETENV} ${MKCMAKE_ENV} ${MKCMAKE} -C ${WRKSRC} ${INSTALL_TARGET}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/hastmon/distinfo b/net-mgmt/hastmon/distinfo
new file mode 100644
index 000000000000..10e5c71d4854
--- /dev/null
+++ b/net-mgmt/hastmon/distinfo
@@ -0,0 +1,2 @@
+SHA256 (hastmon-0.3.0.tar.gz) = 13e374f8cf269baaf0d7b9f3cc416113fcef833a7638d282e2e40d0f540de8f2
+SIZE (hastmon-0.3.0.tar.gz) = 73129
diff --git a/net-mgmt/hastmon/pkg-descr b/net-mgmt/hastmon/pkg-descr
new file mode 100644
index 000000000000..3f2f50ad71d9
--- /dev/null
+++ b/net-mgmt/hastmon/pkg-descr
@@ -0,0 +1,8 @@
+hastmon is a monitoring daemon that allows a couple of hosts to run a
+service providing automatic failover. Those machines will be called a
+cluster and each machine is one cluster node. hastmon is designed for
+clusters that work in Primary-Secondary configuration, which means
+that only one of the cluster nodes can be active at any given time.
+
+WWW: http://hastmon.googlecode.com/
+Author: Mikolaj Golub <to.my.trociny@gmail.com>