aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-04-13 13:45:28 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-04-14 14:16:10 +0000
commitc2358eae9711252708bd98cbcca6352053e648fc (patch)
tree9d139abec5608f2f709345c97ec28785f8e0faca
parente19be2d61bfbee1d5b8975fc8e223385beb9cf5c (diff)
downloadports-c2358eae9711252708bd98cbcca6352053e648fc.tar.gz
ports-c2358eae9711252708bd98cbcca6352053e648fc.zip
-rw-r--r--games/sdlroids/Makefile7
-rw-r--r--games/sdlroids/files/patch-getargs.h8
2 files changed, 10 insertions, 5 deletions
diff --git a/games/sdlroids/Makefile b/games/sdlroids/Makefile
index 5acf611a9dc9..e2dd47fe9b49 100644
--- a/games/sdlroids/Makefile
+++ b/games/sdlroids/Makefile
@@ -1,6 +1,6 @@
PORTNAME= sdlroids
-PORTVERSION= 1.3.4
-PORTREVISION= 18
+DISTVERSION= 1.3.4
+PORTREVISION= 19
CATEGORIES= games
MASTER_SITES= SF \
SF/nemysisfreebsdp/${CATEGORIES}/:icons
@@ -16,9 +16,6 @@ WWW= https://sourceforge.net/projects/sdlroids/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_FreeBSD_13= ld: error: duplicate symbol: flagargs
-BROKEN_FreeBSD_14= ld: error: duplicate symbol: flagargs
-
USES= gmake sdl tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --datadir=${PREFIX}/share
diff --git a/games/sdlroids/files/patch-getargs.h b/games/sdlroids/files/patch-getargs.h
new file mode 100644
index 000000000000..7d3a4d7be14d
--- /dev/null
+++ b/games/sdlroids/files/patch-getargs.h
@@ -0,0 +1,8 @@
+--- getargs.h.orig 2023-04-13 13:43:47 UTC
++++ getargs.h
+@@ -37,4 +37,4 @@
+
+ /* getargs() prototype */
+ void getargs(int, char *[]);
+-int flagargs[NUMARGS];
++extern int flagargs[NUMARGS];