aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-12-06 21:05:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-12-06 21:05:20 +0000
commitc2925123a1af56b2e9def4377f9f777f4ca9cf7c (patch)
tree573f0e3d777d909d41c02bc4302e0d43050d9eea
parent03109fc783b6d728952ab7a8a34d9747554e3a1b (diff)
Notes
-rw-r--r--lang/ohugs/Makefile9
-rw-r--r--misc/fcalc/Makefile4
-rw-r--r--science/ics/Makefile4
3 files changed, 9 insertions, 8 deletions
diff --git a/lang/ohugs/Makefile b/lang/ohugs/Makefile
index 6e1cb69d3168..4fed82fe5447 100644
--- a/lang/ohugs/Makefile
+++ b/lang/ohugs/Makefile
@@ -6,7 +6,7 @@
PORTNAME= ohugs
PORTVERSION= 0.5
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= lang haskell
MASTER_SITES= http://www.math.chalmers.se/~nordland/ohugs/
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -16,7 +16,7 @@ COMMENT= Interpreter for Haskell with object-oriented features
LIB_DEPENDS= readline.6:${PORTSDIR}/devel/readline
.if !defined(WITHOUT_X11)
-LIB_DEPENDS+= tix8184:${PORTSDIR}/x11-toolkits/tix
+LIB_DEPENDS= Tix8.4.3.0:${PORTSDIR}/x11-toolkits/tix
.endif
WRKSRC= ${WRKDIR}/${DISTNAME:S/.src//}
@@ -24,8 +24,9 @@ BUILD_WRKSRC= ${WRKSRC}/src
USE_BISON= build
LDFLAGS+= -lm -lreadline -ltermcap
.if !defined(WITHOUT_X11)
-CFLAGS+= -I${LOCALBASE}/include/tk8.4 -I${LOCALBASE}/include/tcl8.4 -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -ltk84 -ltcl84 -ltix8184
+USE_TK= 84+
+CFLAGS+= -I${TK_INCLUDEDIR} -I${TCL_INCLUDEDIR} -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -ltk${TK_VER:S/.//} -ltcl${TCL_VER:S/.//} -lTix8.4.3
.endif
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
INSTBIN=${PREFIX}/bin INSTLIB=${PREFIX}/lib/ohugs
diff --git a/misc/fcalc/Makefile b/misc/fcalc/Makefile
index c1051fb5bec5..795167aa953f 100644
--- a/misc/fcalc/Makefile
+++ b/misc/fcalc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fcalc
PORTVERSION= 1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc
MASTER_SITES= ftp://quenix2.dyndns.org/FreeBSD/ports/distfiles/
DISTNAME= ${PORTNAME}-tcl
@@ -15,7 +15,7 @@ DISTNAME= ${PORTNAME}-tcl
MAINTAINER= ports@FreeBSD.org
COMMENT= F/Calc is a calculator for photographic formulas
-RUN_DEPENDS= ${LOCALBASE}/lib/tix8.1/Tix.tcl:${PORTSDIR}/x11-toolkits/tix
+RUN_DEPENDS= ${LOCALBASE}/lib/Tix8.4.3/Tix.tcl:${PORTSDIR}/x11-toolkits/tix
NO_BUILD= yes
USE_XORG= x11 xt
diff --git a/science/ics/Makefile b/science/ics/Makefile
index 532013d1d517..8047cd4575f7 100644
--- a/science/ics/Makefile
+++ b/science/ics/Makefile
@@ -16,8 +16,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= thierry@FreeBSD.org
COMMENT= Code_Saturne Graphical User Interface
-LIB_DEPENDS= tix8184:${PORTSDIR}/x11-toolkits/tix
-RUN_DEPENDS= ${CS_HOME}/bin/info_cs:${PORTSDIR}/science/ncs \
+RUN_DEPENDS= ${LOCALBASE}/lib/Tix8.4.3/Tix.tcl:${PORTSDIR}/x11-toolkits/tix \
+ ${CS_HOME}/bin/info_cs:${PORTSDIR}/science/ncs \
${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
NO_BUILD= yes