aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEugene Grosbein <eugen@FreeBSD.org>2018-10-04 05:49:09 +0000
committerEugene Grosbein <eugen@FreeBSD.org>2018-10-04 05:49:09 +0000
commitc2a56941a0371901e506820c56346b6051465177 (patch)
tree95b6caff86999b1361b17b9111079f0fd292e7fa
parent7009b8a1da3e4b11cbc094ce18b04892a760e152 (diff)
downloadports-c2a56941a0371901e506820c56346b6051465177.tar.gz
ports-c2a56941a0371901e506820c56346b6051465177.zip
Notes
-rw-r--r--net/mpd5/Makefile2
-rw-r--r--net/mpd5/files/patch-mtu-override14
2 files changed, 15 insertions, 1 deletions
diff --git a/net/mpd5/Makefile b/net/mpd5/Makefile
index e8fb903fd3c1..149c152c04ac 100644
--- a/net/mpd5/Makefile
+++ b/net/mpd5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mpd
DISTVERSION= 5.8
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/Mpd5/Mpd-${PORTVERSION}
PKGNAMESUFFIX= 5
diff --git a/net/mpd5/files/patch-mtu-override b/net/mpd5/files/patch-mtu-override
index c487f80027ff..2bd957df1bfa 100644
--- a/net/mpd5/files/patch-mtu-override
+++ b/net/mpd5/files/patch-mtu-override
@@ -105,3 +105,17 @@ Index: src/iface.c
snprintf(tcpmsscfg.inHook, sizeof(tcpmsscfg.inHook), "in");
snprintf(tcpmsscfg.outHook, sizeof(tcpmsscfg.outHook), "out");
if (NgSendMsg(gLinksCsock, path, NGM_TCPMSS_COOKIE, NGM_TCPMSS_CONFIG,
+Index: src/bund.c
+===================================================================
+--- src/bund.c (revision 2253)
++++ src/bund.c (revision 2254)
+@@ -328,7 +328,8 @@ BundJoin(Link l)
+
+ /* Configure this link */
+ b->pppConfig.links[l->bundleIndex].enableLink = 1;
+- b->pppConfig.links[l->bundleIndex].mru = lcp->peer_mru;
++ b->pppConfig.links[l->bundleIndex].mru = b->iface.mtu_override ?
++ b->iface.mtu_override : lcp->peer_mru;
+ b->pppConfig.links[l->bundleIndex].enableACFComp = lcp->peer_acfcomp;
+ b->pppConfig.links[l->bundleIndex].enableProtoComp = lcp->peer_protocomp;
+ b->pppConfig.links[l->bundleIndex].bandwidth =