aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-11-04 21:36:13 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-11-04 21:36:13 +0000
commitc2e845d0c8bc7c9f164cff0518da23f674677570 (patch)
tree7fc33d51c49bd9a7ccd279ab581748918852d482
parent2f557a46788f7ec9b1355f7a17e8ca1cfe208f8b (diff)
downloadports-c2e845d0c8bc7c9f164cff0518da23f674677570.tar.gz
ports-c2e845d0c8bc7c9f164cff0518da23f674677570.zip
Add USES=xorg USES=gl, ports categories c
Add USES=xorg, USES=gl and in a few cases USES=gnome to ports in categories starting with 'c'.
Notes
Notes: svn path=/head/; revision=516745
-rw-r--r--cad/calculix/Makefile2
-rw-r--r--cad/dinotrace/Makefile2
-rw-r--r--cad/feappv/Makefile2
-rw-r--r--cad/gmsh/Makefile3
-rw-r--r--cad/irsim/Makefile2
-rw-r--r--cad/kicad-devel/Makefile2
-rw-r--r--cad/kicad/Makefile2
-rw-r--r--cad/librecad/Makefile2
-rw-r--r--cad/linuxcnc-devel/Makefile3
-rw-r--r--cad/magic/Makefile2
-rw-r--r--cad/netgen/Makefile2
-rw-r--r--cad/openscad-devel/Makefile2
-rw-r--r--cad/openscad/Makefile2
-rw-r--r--cad/pcb/Makefile2
-rw-r--r--cad/qcad/Makefile2
-rw-r--r--cad/qelectrotech/Makefile3
-rw-r--r--cad/repsnapper/Makefile4
-rw-r--r--cad/solvespace/Makefile2
-rw-r--r--cad/sumo/Makefile2
-rw-r--r--cad/varkon/Makefile2
-rw-r--r--cad/z88/Makefile2
-rw-r--r--chinese/aterm/Makefile1
-rw-r--r--chinese/fcitx-ui-light/Makefile2
-rw-r--r--chinese/fcitx/Makefile2
-rw-r--r--chinese/gcin/Makefile2
-rw-r--r--chinese/ibus-chewing/Makefile2
-rw-r--r--chinese/libcangjie/Makefile2
-rw-r--r--chinese/librime/Makefile2
-rw-r--r--comms/acfax/Makefile2
-rw-r--r--comms/flcluster/Makefile2
-rw-r--r--comms/fldigi/Makefile3
-rw-r--r--comms/flrig/Makefile2
-rw-r--r--comms/geoid/Makefile2
-rw-r--r--comms/ibp/Makefile2
-rw-r--r--comms/linrad/Makefile2
-rw-r--r--comms/lirc/Makefile2
-rw-r--r--comms/py-qt5-serialport/Makefile2
-rw-r--r--comms/seyon/Makefile2
-rw-r--r--comms/syncterm/Makefile1
-rw-r--r--comms/twpsk/Makefile2
-rw-r--r--comms/viewfax/Makefile2
-rw-r--r--comms/xastir/Makefile2
-rw-r--r--converters/wkhtmltopdf/Makefile2
43 files changed, 48 insertions, 42 deletions
diff --git a/cad/calculix/Makefile b/cad/calculix/Makefile
index c956264dd3ae..4db0bae187cd 100644
--- a/cad/calculix/Makefile
+++ b/cad/calculix/Makefile
@@ -19,7 +19,7 @@ BROKEN_aarch64= fails to link: shapeFunctions.c:(function attach_new): relocati
RUN_DEPENDS= ccx:cad/calculix-ccx
-USES= gmake tar:bzip2 compiler:c++11-lib
+USES= gl gmake tar:bzip2 compiler:c++11-lib xorg
USE_XORG= ice sm x11 xext xi xmu xt
USE_GL= gl glu # uses its own glut
diff --git a/cad/dinotrace/Makefile b/cad/dinotrace/Makefile
index 87479ae4f20b..98ae24eda48b 100644
--- a/cad/dinotrace/Makefile
+++ b/cad/dinotrace/Makefile
@@ -14,7 +14,7 @@ COMMENT= Graphical signal trace waveform viewer
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake motif perl5 tar:tgz
+USES= gmake motif perl5 tar:tgz xorg
USE_XORG= x11 sm ice xmu xt
USE_PERL5= build
diff --git a/cad/feappv/Makefile b/cad/feappv/Makefile
index b4caa889978e..4e77a541ba1e 100644
--- a/cad/feappv/Makefile
+++ b/cad/feappv/Makefile
@@ -13,7 +13,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Finite element analysis program (personal version)
-USES= fortran gmake localbase:ldflags
+USES= fortran gmake localbase:ldflags xorg
USE_GITHUB= yes
GH_ACCOUNT= sanjayg0
USE_XORG= x11
diff --git a/cad/gmsh/Makefile b/cad/gmsh/Makefile
index d84bbbf51a5e..49984a7d4ac7 100644
--- a/cad/gmsh/Makefile
+++ b/cad/gmsh/Makefile
@@ -24,7 +24,8 @@ LIB_DEPENDS= libfltk.so:x11-toolkits/fltk \
libfreetype.so:print/freetype2
RUN_DEPENDS= getdp:science/getdp
-USES= blaslapack compiler:c++11-lang cmake fortran gl jpeg tar:tgz
+USES= blaslapack compiler:c++11-lang cmake fortran gl jpeg tar:tgz \
+ xorg
USE_GL= gl glu
USE_XORG= x11 xcursor xext xinerama xfixes xft xrender
diff --git a/cad/irsim/Makefile b/cad/irsim/Makefile
index 1a3782dab6fa..529048483ac9 100644
--- a/cad/irsim/Makefile
+++ b/cad/irsim/Makefile
@@ -25,7 +25,7 @@ TCL_USES= tk:tea
CONFIGURE_WRKSRC= ${WRKSRC}/scripts
-USES= gmake tar:tgz
+USES= gmake tar:tgz xorg
USE_XORG= x11
GNU_CONFIGURE= yes
diff --git a/cad/kicad-devel/Makefile b/cad/kicad-devel/Makefile
index a60d2af11e67..bf2d599b5639 100644
--- a/cad/kicad-devel/Makefile
+++ b/cad/kicad-devel/Makefile
@@ -47,7 +47,7 @@ BINS= cvpcb eeschema gerbview kicad pcbnew
EXTRAS2RM= linux-non_unicode linux wings3d LINUX.README \
contrib_makefiles.txt running_kicad_under_W98.txt
USES= desktop-file-utils shared-mime-info compiler:c++11-lib tar:bzip2 cmake:insource,noninja \
- gettext python:2.7 shebangfix ssl
+ gettext python:2.7 shebangfix ssl gl xorg gnome
SHEBANG_FILES= pcbnew/python/plugins/touch_slider_wizard.py
CMAKE_ARGS= -DLOCALBASE="${LOCALBASE}" \
diff --git a/cad/kicad/Makefile b/cad/kicad/Makefile
index cd557e8de138..d838ec02c6b9 100644
--- a/cad/kicad/Makefile
+++ b/cad/kicad/Makefile
@@ -28,7 +28,7 @@ GH_ACCOUNT= KiCad
GH_PROJECT= kicad-source-mirror
USES= cmake:noninja compiler:c++11-lib desktop-file-utils gl gnome \
- pkgconfig python:2.7 shared-mime-info shebangfix ssl tar:xz
+ pkgconfig python:2.7 shared-mime-info shebangfix ssl tar:xz xorg
SHEBANG_FILES= pcbnew/python/plugins/touch_slider_wizard.py
USE_XORG= ice x11 xext
diff --git a/cad/librecad/Makefile b/cad/librecad/Makefile
index b1b54a6ee5d8..4ce9402b1b67 100644
--- a/cad/librecad/Makefile
+++ b/cad/librecad/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/version.hpp:devel/boost-libs
LIB_DEPENDS= libmuparser.so:math/muparser \
libfreetype.so:print/freetype2
-USES= compiler:c++11-lib desktop-file-utils pkgconfig qmake qt:5
+USES= compiler:c++11-lib desktop-file-utils pkgconfig gl qmake qt:5
USE_GITHUB= yes
GH_ACCOUNT= LibreCAD
GH_PROJECT= LibreCAD
diff --git a/cad/linuxcnc-devel/Makefile b/cad/linuxcnc-devel/Makefile
index c2066cdacb7e..4d8ac88baee5 100644
--- a/cad/linuxcnc-devel/Makefile
+++ b/cad/linuxcnc-devel/Makefile
@@ -40,7 +40,8 @@ CONFIGURE_ARGS= --with-realtime=uspace --enable-non-distributable=yes \
--with-locale-dir="${PREFIX}/share/locale" --with-python=${PYTHON_CMD} \
--with-boost-python=boost_python27
MAKE_ENV= BUILD_VERBOSE=1
-USES= autoreconf gettext gmake ncurses pkgconfig python:2.7 readline shebangfix tk
+USES= autoreconf gettext gl gmake gnome ncurses pkgconfig python:2.7 \
+ readline shebangfix tk xorg
USE_GL= gl glu
USE_GNOME= cairo gdkpixbuf2 libgnomeprintui pygtksourceview
USE_XORG= ice sm x11 xext xft xinerama xmu xrender xscrnsaver xt
diff --git a/cad/magic/Makefile b/cad/magic/Makefile
index 6d0603d1b7b8..2373120b57d8 100644
--- a/cad/magic/Makefile
+++ b/cad/magic/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${FILESDIR}/license.txt
LIB_DEPENDS= libBLT25.so:x11-toolkits/blt
-USES= gmake tk:tea tar:tgz
+USES= gmake gl tk:tea tar:tgz xorg
USE_XORG= ice xext xi xmu
USE_GL= gl
CONFIGURE_ARGS= --with-opengl
diff --git a/cad/netgen/Makefile b/cad/netgen/Makefile
index 17561f9d535d..b0983c7ae4d7 100644
--- a/cad/netgen/Makefile
+++ b/cad/netgen/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libTix8.4.3.so:x11-toolkits/tix \
OCC_BROKEN= Does not compile because of issues with cad/opencascade
USE_LDCONFIG= yes
-USES= gmake jpeg libtool localbase tk:tea
+USES= gl gmake jpeg libtool localbase tk:tea xorg
USE_GL= gl glu
USE_XORG= x11 xmu xi
MAKE_JOBS_UNSAFE= yes
diff --git a/cad/openscad-devel/Makefile b/cad/openscad-devel/Makefile
index 9135088cf761..25ceaf3a65d5 100644
--- a/cad/openscad-devel/Makefile
+++ b/cad/openscad-devel/Makefile
@@ -32,7 +32,7 @@ LIB_DEPENDS= libzip.so:archivers/libzip \
CONFLICTS= openscad
USES= bison compiler:c++11-lib desktop-file-utils eigen:3 gettext \
- pkgconfig qmake qt:5 shared-mime-info
+ gl gnome pkgconfig qmake qt:5 shared-mime-info xorg
USE_GITHUB= yes
USE_GL= gl glu glew
USE_GNOME= glib20 libxml2
diff --git a/cad/openscad/Makefile b/cad/openscad/Makefile
index 2719719d4186..f30a57a32c74 100644
--- a/cad/openscad/Makefile
+++ b/cad/openscad/Makefile
@@ -32,7 +32,7 @@ LIB_DEPENDS= libzip.so:archivers/libzip \
CONFLICTS= openscad
USES= bison compiler:c++11-lib desktop-file-utils eigen:3 gettext \
- pkgconfig qmake qt:5 shared-mime-info
+ gl gnome pkgconfig qmake qt:5 shared-mime-info xorg
USE_GITHUB= yes
USE_GL= gl glu glew
USE_GNOME= glib20 libxml2
diff --git a/cad/pcb/Makefile b/cad/pcb/Makefile
index cf7a96249629..24c54d435002 100644
--- a/cad/pcb/Makefile
+++ b/cad/pcb/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= m4>=1.4.11:devel/m4 \
${LOCALBASE}/libdata/pkgconfig/dbus-1.pc:devel/dbus
USES= gl gmake gnome pkgconfig tk:run shared-mime-info \
- desktop-file-utils
+ desktop-file-utils xorg
USE_GL= gl glu
USE_GNOME= intltool cairo pangox-compat
USE_XORG= x11 xrender xinerama
diff --git a/cad/qcad/Makefile b/cad/qcad/Makefile
index 84a225835683..28aa18178606 100644
--- a/cad/qcad/Makefile
+++ b/cad/qcad/Makefile
@@ -23,7 +23,7 @@ BUILD_DEPENDS= bash:shells/bash \
MAKE_JOBS_UNSAFE=yes
-USES= compiler:c++11-lang gmake qmake qt:5
+USES= compiler:c++11-lang gl gmake qmake qt:5
USE_GITHUB= yes
USE_LDCONFIG= yes
USE_QT= buildtools qmake_build \
diff --git a/cad/qelectrotech/Makefile b/cad/qelectrotech/Makefile
index bf59d626b259..1aa88b37df82 100644
--- a/cad/qelectrotech/Makefile
+++ b/cad/qelectrotech/Makefile
@@ -14,7 +14,8 @@ COMMENT= QElectroTech is application to design electric diagrams
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= compiler:c++11-lib desktop-file-utils kde:5 qmake qt:5 shared-mime-info
+USES= compiler:c++11-lib desktop-file-utils gl kde:5 qmake qt:5 \
+ shared-mime-info
USE_GL= gl
USE_QT= concurrent core gui network printsupport sql sql-sqlite3 \
svg widgets xml \
diff --git a/cad/repsnapper/Makefile b/cad/repsnapper/Makefile
index c5ab42f86911..4eac1355ab57 100644
--- a/cad/repsnapper/Makefile
+++ b/cad/repsnapper/Makefile
@@ -16,8 +16,8 @@ LIB_DEPENDS= libgtkglextmm-x11-1.2.so:x11-toolkits/gtkglextmm \
libpolyclipping.so:graphics/polyclipping \
libzip.so:archivers/libzip
-USES= compiler:c++11-lib autoreconf gettext gmake libtool localbase \
- perl5 pkgconfig
+USES= compiler:c++11-lib autoreconf gettext gl gmake gnome libtool \
+ localbase perl5 pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= timschmidt
USE_GNOME= gtkmm24 intltool libxml++26
diff --git a/cad/solvespace/Makefile b/cad/solvespace/Makefile
index f40e167048f6..2f8f978a1a3c 100644
--- a/cad/solvespace/Makefile
+++ b/cad/solvespace/Makefile
@@ -23,7 +23,7 @@ GH_PROJECT= libdxfrw:libdxfrw
GH_TAGNAME= 8f95895:libdxfrw
GH_SUBDIR= extlib/libdxfrw:libdxfrw
-USES= cmake compiler:c++11-lang gl gnome pkgconfig
+USES= cmake compiler:c++11-lang gl gnome pkgconfig xorg
USE_GL= gl glu glew
USE_GNOME= atkmm gtk20 pangomm
USE_XORG= x11
diff --git a/cad/sumo/Makefile b/cad/sumo/Makefile
index 45992d253992..0cb449d6665c 100644
--- a/cad/sumo/Makefile
+++ b/cad/sumo/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libtiff.so:graphics/tiff \
libxerces-c.so:textproc/xerces-c3
-USES= cmake jpeg python shebangfix zip
+USES= cmake gl jpeg python shebangfix zip xorg
SHEBANG_FILES= tools/*.py tools/*/*.py \
tools/*/*/*.py tools/*/*/*/*.py \
tools/*/*/*/*/*/*.py \
diff --git a/cad/varkon/Makefile b/cad/varkon/Makefile
index 6f4011ea03da..04ba7c972603 100644
--- a/cad/varkon/Makefile
+++ b/cad/varkon/Makefile
@@ -21,9 +21,9 @@ RUN_DEPENDS= xdg-open:devel/xdg-utils
WRKSRC= ${WRKDIR}/Varkon_${PORTVERSION}
BUILD_WRKSRC= ${WRKSRC}/sources
+USES= gl gmake xorg
USE_XORG= xpm
USE_GL= glu
-USES= gmake
MAKE_ENV= PLATFORM=FreeBSD
ALL_TARGET= # none
MAKE_JOBS_UNSAFE= yes
diff --git a/cad/z88/Makefile b/cad/z88/Makefile
index e5b4a71a3957..64824f709635 100644
--- a/cad/z88/Makefile
+++ b/cad/z88/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libgtkglext-x11-1.0.so:x11-toolkits/gtkglext \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= gl gnome pkgconfig
+USES= gl gnome pkgconfig xorg
USE_GITHUB= yes
USE_GL= gl glu
USE_GNOME= cairo gdkpixbuf2 gtk20
diff --git a/chinese/aterm/Makefile b/chinese/aterm/Makefile
index eb65511656b3..83ccab04c066 100644
--- a/chinese/aterm/Makefile
+++ b/chinese/aterm/Makefile
@@ -9,6 +9,7 @@ MASTER_SITES= SF
MAINTAINER= gugod@gugod.org
COMMENT= Color vt102 terminal emulator with transparency support
+USES= xorg
USE_XORG= xpm
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-xim --enable-big5
diff --git a/chinese/fcitx-ui-light/Makefile b/chinese/fcitx-ui-light/Makefile
index 363070ad6bc3..6bf64d9e031b 100644
--- a/chinese/fcitx-ui-light/Makefile
+++ b/chinese/fcitx-ui-light/Makefile
@@ -16,8 +16,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libfcitx-config.so:chinese/fcitx \
libfontconfig.so:x11-fonts/fontconfig
+USES= tar:bzip2 cmake gettext gnome pkgconfig xorg
USE_XORG= x11 xft xpm
-USES= tar:bzip2 cmake gettext pkgconfig
USE_GNOME= intltool
.include <bsd.port.mk>
diff --git a/chinese/fcitx/Makefile b/chinese/fcitx/Makefile
index f3458258c22c..633d3f0705a1 100644
--- a/chinese/fcitx/Makefile
+++ b/chinese/fcitx/Makefile
@@ -45,7 +45,7 @@ USE_XORG= x11 xext xkbfile sm ice
USE_LDCONFIG= yes
USES= compiler:c++11-lang gnome tar:xz cmake:noninja desktop-file-utils \
gettext-tools:build,run gettext-runtime iconv:wchar_t \
- kde:5 pkgconfig shared-mime-info compiler:c++14-lang
+ kde:5 pkgconfig shared-mime-info compiler:c++14-lang xorg
INSTALLS_ICONS= yes
OPTIONS_DEFINE= GTK2 GTK3 OPENCC TPUNC DOCS
diff --git a/chinese/gcin/Makefile b/chinese/gcin/Makefile
index c05120d7b833..12cb23fd55df 100644
--- a/chinese/gcin/Makefile
+++ b/chinese/gcin/Makefile
@@ -16,7 +16,7 @@ BROKEN_powerpc64= fails to build: gmake[3]: *** [Makefile:30: en-american] Error
LIB_DEPENDS= libcurl.so:ftp/curl
-USES= gmake gnome pkgconfig tar:xz
+USES= gmake gnome pkgconfig tar:xz xorg
HAS_CONFIGURE= YES
CONFIGURE_ARGS+= --use_gtk3=N --use_qt5=N
USE_GNOME= gtk30
diff --git a/chinese/ibus-chewing/Makefile b/chinese/ibus-chewing/Makefile
index 207c153cc2af..3b1b46155960 100644
--- a/chinese/ibus-chewing/Makefile
+++ b/chinese/ibus-chewing/Makefile
@@ -20,7 +20,7 @@ CMAKE_ARGS= -DSYSCONF_INSTALL_DIR=${PREFIX}/etc \
-DLIB_DIR=${PREFIX}/lib
LDFLAGS+= -L${LOCALBASE}/lib
GLIB_SCHEMAS= org.freedesktop.IBus.Chewing.gschema.xml
-USES= cmake:noninja gettext pkgconfig
+USES= cmake:noninja gettext gnome pkgconfig xorg
USE_GNOME= gtk20
USE_XORG= xtst
diff --git a/chinese/libcangjie/Makefile b/chinese/libcangjie/Makefile
index b0948dd617df..1a1896e521f1 100644
--- a/chinese/libcangjie/Makefile
+++ b/chinese/libcangjie/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libsqlite3.so:databases/sqlite3 \
libfreetype.so:print/freetype2 \
libdbus-1.so:devel/dbus
-USES= autoreconf gmake libtool localbase pkgconfig sqlite
+USES= autoreconf gmake libtool localbase pkgconfig sqlite xorg
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/chinese/librime/Makefile b/chinese/librime/Makefile
index 1ae496099ebb..ba5b518ac7d9 100644
--- a/chinese/librime/Makefile
+++ b/chinese/librime/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libopencc.so:chinese/opencc \
libyaml-cpp.so:devel/yaml-cpp
-USES= cmake compiler:c++11-lib gettext pathfix perl5 pkgconfig
+USES= cmake compiler:c++11-lib gettext pathfix perl5 pkgconfig xorg
USE_PERL5= build patch
USE_CXXSTD= c++11
diff --git a/comms/acfax/Makefile b/comms/acfax/Makefile
index c5d76be256b8..c7a822a627ca 100644
--- a/comms/acfax/Makefile
+++ b/comms/acfax/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libXaw3d.so:x11-toolkits/Xaw3d
PLIST_FILES= bin/acfax
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= imake
+USES= imake xorg
USE_XORG= x11 xext xmu xt sm ice
post-extract:
diff --git a/comms/flcluster/Makefile b/comms/flcluster/Makefile
index 9f02bcf9458e..5bdfef3ef915 100644
--- a/comms/flcluster/Makefile
+++ b/comms/flcluster/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libpng.so:graphics/png \
libfltk.so:x11-toolkits/fltk \
libfontconfig.so:x11-fonts/fontconfig
-USES= autoreconf compiler:c++11-lib gmake pkgconfig
+USES= autoreconf compiler:c++11-lib gmake pkgconfig xorg
USE_CXXSTD= gnu++0x
GNU_CONFIGURE= yes
USE_XORG= x11 xft xext xfixes xcursor xinerama
diff --git a/comms/fldigi/Makefile b/comms/fldigi/Makefile
index 0559555f60b9..9dee17a01b6d 100644
--- a/comms/fldigi/Makefile
+++ b/comms/fldigi/Makefile
@@ -22,7 +22,8 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs\
libsndfile.so:audio/libsndfile \
libsamplerate.so:audio/libsamplerate
-USES= autoreconf compiler:c++11-lib jpeg gmake perl5 pkgconfig shebangfix
+USES= autoreconf compiler:c++11-lib jpeg gmake perl5 pkgconfig \
+ shebangfix xorg
USE_CXXSTD= gnu++0x
GNU_CONFIGURE= yes
diff --git a/comms/flrig/Makefile b/comms/flrig/Makefile
index 38c66657f512..67b861a1df28 100644
--- a/comms/flrig/Makefile
+++ b/comms/flrig/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libpng.so:graphics/png \
libfontconfig.so:x11-fonts/fontconfig \
libfltk.so:x11-toolkits/fltk
-USES= gmake jpeg
+USES= gmake jpeg xorg
USE_XORG= x11 xrender xcursor xfixes xext xft xinerama
GNU_CONFIGURE= yes
diff --git a/comms/geoid/Makefile b/comms/geoid/Makefile
index 745ecaeec3b2..01ce864ff4ba 100644
--- a/comms/geoid/Makefile
+++ b/comms/geoid/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libfltk.so:x11-toolkits/fltk \
libfontconfig.so:x11-fonts/fontconfig \
libpng.so:graphics/png
-USES= gmake jpeg
+USES= gmake jpeg xorg
USE_XORG= x11 xcursor xext xfixes xft xinerama xrender
MAKEFILE= makefile
diff --git a/comms/ibp/Makefile b/comms/ibp/Makefile
index fac082fd7af8..328dff720058 100644
--- a/comms/ibp/Makefile
+++ b/comms/ibp/Makefile
@@ -11,7 +11,7 @@ MASTER_SITES= http://wwwhome.cs.utwente.nl/~ptdeboer/ham/ \
MAINTAINER= hamradio@FreeBSD.org
COMMENT= Little program for monitoring amateur radio beacons
-USES= imake ncurses tar:tgz
+USES= imake ncurses tar:tgz xorg
USE_XORG= x11
post-patch:
diff --git a/comms/linrad/Makefile b/comms/linrad/Makefile
index 084a8ae121b0..f6cc22b13458 100644
--- a/comms/linrad/Makefile
+++ b/comms/linrad/Makefile
@@ -23,7 +23,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --sysconfdir=${PREFIX}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USES= gmake tar:bzip2
+USES= gmake tar:bzip2 xorg
USE_XORG= x11
LINRAD_DOCFILES= z_APM.txt z_BUFFERS.txt z_CALIBRATE.txt \
z_COPYRIGHT.txt z_GIFINFO.txt \
diff --git a/comms/lirc/Makefile b/comms/lirc/Makefile
index fb435adf21ff..046a4f9000f2 100644
--- a/comms/lirc/Makefile
+++ b/comms/lirc/Makefile
@@ -13,7 +13,7 @@ COMMENT= Linux Infrared Remote Control
BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto
-USES= alias autoreconf gmake libtool localbase python tar:bzip2
+USES= alias autoreconf gmake libtool localbase python tar:bzip2 xorg
USE_XORG= sm x11 ice
USE_CSTD= gnu89
INSTALL_TARGET= install-strip
diff --git a/comms/py-qt5-serialport/Makefile b/comms/py-qt5-serialport/Makefile
index 823c80b955a4..eee5008a6fdd 100644
--- a/comms/py-qt5-serialport/Makefile
+++ b/comms/py-qt5-serialport/Makefile
@@ -12,7 +12,7 @@ RUN_DEPENDS= ${PY_ENUM34}
CONFIGURE_ARGS= --enable QtSerialPort
PYQT_DIST= yes
-USES= python pyqt:5 qt:5
+USES= gl python pyqt:5 qt:5
USE_GL= gl
USE_PYQT= sip_build core_run
USE_PYTHON= concurrent flavors py3kplist
diff --git a/comms/seyon/Makefile b/comms/seyon/Makefile
index b6a93cffdff4..574201600625 100644
--- a/comms/seyon/Makefile
+++ b/comms/seyon/Makefile
@@ -10,7 +10,7 @@ DISTFILES= ${DISTNAME:S/-/_/}.orig${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Communications package for the X Window system
-USES= imake
+USES= imake xorg
USE_XORG= x11 xext xpm xmu xaw xt sm ice
MAKE_JOBS_UNSAFE= yes
diff --git a/comms/syncterm/Makefile b/comms/syncterm/Makefile
index db159d72e549..635d9ed847b6 100644
--- a/comms/syncterm/Makefile
+++ b/comms/syncterm/Makefile
@@ -31,6 +31,7 @@ MAKE_ARGS+= RELEASE=1
OPTIONS_DEFINE= X11 SDL
OPTIONS_DEFAULT= X11 SDL
+X11_USES= xorg
X11_USE= xorg=x11
X11_MAKE_ARGS_OFF= NO_X=1
diff --git a/comms/twpsk/Makefile b/comms/twpsk/Makefile
index 95a07fdbf71d..ba39af3ad375 100644
--- a/comms/twpsk/Makefile
+++ b/comms/twpsk/Makefile
@@ -12,7 +12,7 @@ COMMENT= X psk31 client
LICENSE= GPLv3
-USES= motif pkgconfig
+USES= motif pkgconfig xorg
USE_XORG= sm ice xt x11
LIB_DEPENDS= libpulse.so:audio/pulseaudio
diff --git a/comms/viewfax/Makefile b/comms/viewfax/Makefile
index d6424a0b403b..4dcc438f6455 100644
--- a/comms/viewfax/Makefile
+++ b/comms/viewfax/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= ftp://ftp.ping.de/pub/unix/
MAINTAINER= ports@FreeBSD.org
COMMENT= Display files containing g3 and/or g4 coded fax pages
-USES= imake
+USES= imake xorg
USE_XORG= x11 xext
PLIST_FILES= bin/viewfax lib/viewfax.tif \
diff --git a/comms/xastir/Makefile b/comms/xastir/Makefile
index b566ea3dcad1..73f8d4f87b04 100644
--- a/comms/xastir/Makefile
+++ b/comms/xastir/Makefile
@@ -26,7 +26,7 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libwebpmux.so:graphics/webp \
libwmflite.so:graphics/libwmf
-USES= gettext gmake jpeg motif python:run shebangfix
+USES= gettext gmake gnome jpeg motif python:run shebangfix xorg
USE_XORG= ice sm x11 xext xt
USE_GNOME+= libxml2
diff --git a/converters/wkhtmltopdf/Makefile b/converters/wkhtmltopdf/Makefile
index caf4c0c20898..cad62e09f9c6 100644
--- a/converters/wkhtmltopdf/Makefile
+++ b/converters/wkhtmltopdf/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libpng.so:graphics/png \
libQt5WebKit.so:www/qt5-webkit
-USES= compiler:c++11-lang gmake iconv jpeg perl5 pkgconfig ssl
+USES= compiler:c++11-lang gmake iconv jpeg perl5 pkgconfig ssl xorg
USE_XORG= x11 xext xrender
USE_PERL5= build
USE_LDCONFIG= yes