aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-03-19 18:00:29 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-03-19 18:00:29 +0000
commitc2ecbb4d3b50b4cf1719b2a6fbedc39afa49fde5 (patch)
tree2a5b612378ac94556510108048081b0517e04fba
parentbcb788934511e3ae13e6bd8f7b1bb0108483e50e (diff)
downloadports-c2ecbb4d3b50b4cf1719b2a6fbedc39afa49fde5.tar.gz
ports-c2ecbb4d3b50b4cf1719b2a6fbedc39afa49fde5.zip
Notes
-rw-r--r--devel/cmake-gui/Makefile15
-rw-r--r--devel/cmake-gui/distinfo2
-rw-r--r--devel/cmake-modules/Makefile7
-rw-r--r--devel/cmake-modules/pkg-plist36
4 files changed, 35 insertions, 25 deletions
diff --git a/devel/cmake-gui/Makefile b/devel/cmake-gui/Makefile
index 41e9f84682d2..ec52d8205509 100644
--- a/devel/cmake-gui/Makefile
+++ b/devel/cmake-gui/Makefile
@@ -1,23 +1,16 @@
-# New ports collection makefile for: cmake-gui
-# Date created: 2009-08-27
-# Whom: Max Brazhnikov <makc@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= cmake
-PORTVERSION= 2.8.9
+PORTVERSION= 2.8.10.2
CATEGORIES= devel
-MASTER_SITES= http://www.${PORTNAME}.org/files/v${PORTVERSION:C/\.[[:digit:]]+$//}/
+MASTER_SITES= http://www.cmake.org/files/v2.8/
PKGNAMESUFFIX= -gui
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt4 GUI for cmake
-RUN_DEPENDS= ${CMAKE_BIN}:${CMAKE_PORT}
-
USE_QT4= gui qmake_build moc_build uic_build rcc_build
-USE_CMAKE= yes
+USES= cmake:run
CMAKE_ARGS= -DBUILD_QtDialog:bool=on \
-DCMAKE_DATA_DIR:STRING="/${DATADIR_REL}" \
-DCMAKE_DOC_DIR:STRING="/${DOCSDIR_REL}"
@@ -26,6 +19,8 @@ MAN1= cmake-gui.1
BUILD_WRKSRC= ${WRKSRC}/Source/QtDialog
INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DISTINFO_FILE= ${.CURDIR}/../cmake/distinfo
+
post-patch:
@(${FIND} ${WRKSRC}/Modules -name "*.cmake" -print0; \
${FIND} ${WRKSRC}/Tests -name "CMakeLists.txt" -print0 ) | \
diff --git a/devel/cmake-gui/distinfo b/devel/cmake-gui/distinfo
deleted file mode 100644
index dbb858ceb077..000000000000
--- a/devel/cmake-gui/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (cmake-2.8.9.tar.gz) = dc3dcc7399be8636471975f955086cdf800739862c240858a98e89719e45e6f9
-SIZE (cmake-2.8.9.tar.gz) = 5658837
diff --git a/devel/cmake-modules/Makefile b/devel/cmake-modules/Makefile
index c300fe4394bf..4f798321e29b 100644
--- a/devel/cmake-modules/Makefile
+++ b/devel/cmake-modules/Makefile
@@ -1,10 +1,5 @@
-# New ports collection Makefile for: cmake-modules
-# Date created: 12 July 2012
-# Whom: gahr
-#
+# Created by: gahr
# $FreeBSD$
-#
-#
PORTREVISION= 0
PKGNAMESUFFIX= -modules
diff --git a/devel/cmake-modules/pkg-plist b/devel/cmake-modules/pkg-plist
index aebcfe9f6a27..86cee9627ca5 100644
--- a/devel/cmake-modules/pkg-plist
+++ b/devel/cmake-modules/pkg-plist
@@ -37,6 +37,7 @@
%%DATADIR%%/Modules/CMakeDetermineASM_NASMCompiler.cmake
%%DATADIR%%/Modules/CMakeDetermineCCompiler.cmake
%%DATADIR%%/Modules/CMakeDetermineCXXCompiler.cmake
+%%DATADIR%%/Modules/CMakeDetermineCompiler.cmake
%%DATADIR%%/Modules/CMakeDetermineCompilerABI.cmake
%%DATADIR%%/Modules/CMakeDetermineCompilerId.cmake
%%DATADIR%%/Modules/CMakeDetermineFortranCompiler.cmake
@@ -86,11 +87,9 @@
%%DATADIR%%/Modules/CMakeTestCCompiler.cmake
%%DATADIR%%/Modules/CMakeTestCXXCompiler.cmake
%%DATADIR%%/Modules/CMakeTestCompilerCommon.cmake
-%%DATADIR%%/Modules/CMakeTestForFreeVC.cxx
%%DATADIR%%/Modules/CMakeTestFortranCompiler.cmake
%%DATADIR%%/Modules/CMakeTestGNU.c
%%DATADIR%%/Modules/CMakeTestJavaCompiler.cmake
-%%DATADIR%%/Modules/CMakeTestNMakeCLVersion.c
%%DATADIR%%/Modules/CMakeTestRCCompiler.cmake
%%DATADIR%%/Modules/CMakeTestWatcomVersion.c
%%DATADIR%%/Modules/CMakeUnixFindMake.cmake
@@ -129,6 +128,7 @@
%%DATADIR%%/Modules/CTest.cmake
%%DATADIR%%/Modules/CTestScriptMode.cmake
%%DATADIR%%/Modules/CTestTargets.cmake
+%%DATADIR%%/Modules/CTestUseLaunchers.cmake
%%DATADIR%%/Modules/CheckCCompilerFlag.cmake
%%DATADIR%%/Modules/CheckCSourceCompiles.cmake
%%DATADIR%%/Modules/CheckCSourceRuns.cmake
@@ -159,8 +159,10 @@
%%DATADIR%%/Modules/CheckVariableExists.c
%%DATADIR%%/Modules/CheckVariableExists.cmake
%%DATADIR%%/Modules/Compiler/Absoft-Fortran.cmake
+%%DATADIR%%/Modules/Compiler/Clang-ASM.cmake
%%DATADIR%%/Modules/Compiler/Clang-C.cmake
%%DATADIR%%/Modules/Compiler/Clang-CXX.cmake
+%%DATADIR%%/Modules/Compiler/Clang.cmake
%%DATADIR%%/Modules/Compiler/Cray-C.cmake
%%DATADIR%%/Modules/Compiler/Cray-CXX.cmake
%%DATADIR%%/Modules/Compiler/Cray-Fortran.cmake
@@ -206,6 +208,12 @@
%%DATADIR%%/Modules/Compiler/XL-CXX.cmake
%%DATADIR%%/Modules/Compiler/XL-Fortran.cmake
%%DATADIR%%/Modules/Compiler/XL.cmake
+%%DATADIR%%/Modules/CompilerId/VS-10.vcxproj.in
+%%DATADIR%%/Modules/CompilerId/VS-6.dsp.in
+%%DATADIR%%/Modules/CompilerId/VS-7.vcproj.in
+%%DATADIR%%/Modules/CompilerId/Xcode-1.pbxproj.in
+%%DATADIR%%/Modules/CompilerId/Xcode-2.pbxproj.in
+%%DATADIR%%/Modules/CompilerId/Xcode-3.pbxproj.in
%%DATADIR%%/Modules/Dart.cmake
%%DATADIR%%/Modules/DartConfiguration.tcl.in
%%DATADIR%%/Modules/DeployQt4.cmake
@@ -247,6 +255,7 @@
%%DATADIR%%/Modules/FindGCCXML.cmake
%%DATADIR%%/Modules/FindGDAL.cmake
%%DATADIR%%/Modules/FindGIF.cmake
+%%DATADIR%%/Modules/FindGLEW.cmake
%%DATADIR%%/Modules/FindGLU.cmake
%%DATADIR%%/Modules/FindGLUT.cmake
%%DATADIR%%/Modules/FindGTK.cmake
@@ -259,6 +268,7 @@
%%DATADIR%%/Modules/FindHDF5.cmake
%%DATADIR%%/Modules/FindHSPELL.cmake
%%DATADIR%%/Modules/FindHTMLHelp.cmake
+%%DATADIR%%/Modules/FindHg.cmake
%%DATADIR%%/Modules/FindITK.cmake
%%DATADIR%%/Modules/FindImageMagick.cmake
%%DATADIR%%/Modules/FindJNI.cmake
@@ -418,6 +428,7 @@
%%DATADIR%%/Modules/Platform/BlueGeneP-static-XL-CXX.cmake
%%DATADIR%%/Modules/Platform/BlueGeneP-static-XL-Fortran.cmake
%%DATADIR%%/Modules/Platform/BlueGeneP-static.cmake
+%%DATADIR%%/Modules/Platform/CYGWIN-CXX.cmake
%%DATADIR%%/Modules/Platform/CYGWIN-GNU-C.cmake
%%DATADIR%%/Modules/Platform/CYGWIN-GNU-CXX.cmake
%%DATADIR%%/Modules/Platform/CYGWIN-GNU-Fortran.cmake
@@ -426,6 +437,10 @@
%%DATADIR%%/Modules/Platform/CYGWIN.cmake
%%DATADIR%%/Modules/Platform/Catamount.cmake
%%DATADIR%%/Modules/Platform/Darwin-Absoft-Fortran.cmake
+%%DATADIR%%/Modules/Platform/Darwin-CXX.cmake
+%%DATADIR%%/Modules/Platform/Darwin-Clang-C.cmake
+%%DATADIR%%/Modules/Platform/Darwin-Clang-CXX.cmake
+%%DATADIR%%/Modules/Platform/Darwin-Clang.cmake
%%DATADIR%%/Modules/Platform/Darwin-GNU-C.cmake
%%DATADIR%%/Modules/Platform/Darwin-GNU-CXX.cmake
%%DATADIR%%/Modules/Platform/Darwin-GNU-Fortran.cmake
@@ -441,14 +456,14 @@
%%DATADIR%%/Modules/Platform/DragonFly.cmake
%%DATADIR%%/Modules/Platform/FreeBSD.cmake
%%DATADIR%%/Modules/Platform/GNU.cmake
+%%DATADIR%%/Modules/Platform/GNUtoMS_lib.bat.in
+%%DATADIR%%/Modules/Platform/GNUtoMS_lib.cmake
%%DATADIR%%/Modules/Platform/Generic-ADSP-ASM.cmake
%%DATADIR%%/Modules/Platform/Generic-ADSP-C.cmake
%%DATADIR%%/Modules/Platform/Generic-ADSP-CXX.cmake
%%DATADIR%%/Modules/Platform/Generic-ADSP-Common.cmake
%%DATADIR%%/Modules/Platform/Generic-SDCC-C.cmake
%%DATADIR%%/Modules/Platform/Generic.cmake
-%%DATADIR%%/Modules/Platform/GNUtoMS_lib.bat.in
-%%DATADIR%%/Modules/Platform/GNUtoMS_lib.cmake
%%DATADIR%%/Modules/Platform/HP-UX-GNU-C.cmake
%%DATADIR%%/Modules/Platform/HP-UX-GNU-CXX.cmake
%%DATADIR%%/Modules/Platform/HP-UX-GNU-Fortran.cmake
@@ -463,6 +478,7 @@
%%DATADIR%%/Modules/Platform/IRIX.cmake
%%DATADIR%%/Modules/Platform/IRIX64.cmake
%%DATADIR%%/Modules/Platform/Linux-Absoft-Fortran.cmake
+%%DATADIR%%/Modules/Platform/Linux-CXX.cmake
%%DATADIR%%/Modules/Platform/Linux-Clang-C.cmake
%%DATADIR%%/Modules/Platform/Linux-Clang-CXX.cmake
%%DATADIR%%/Modules/Platform/Linux-GNU-C.cmake
@@ -513,6 +529,7 @@
%%DATADIR%%/Modules/Platform/UnixWare.cmake
%%DATADIR%%/Modules/Platform/Windows-Borland-C.cmake
%%DATADIR%%/Modules/Platform/Windows-Borland-CXX.cmake
+%%DATADIR%%/Modules/Platform/Windows-CXX.cmake
%%DATADIR%%/Modules/Platform/Windows-Embarcadero-C.cmake
%%DATADIR%%/Modules/Platform/Windows-Embarcadero-CXX.cmake
%%DATADIR%%/Modules/Platform/Windows-Embarcadero.cmake
@@ -529,16 +546,20 @@
%%DATADIR%%/Modules/Platform/Windows-Intel-CXX.cmake
%%DATADIR%%/Modules/Platform/Windows-Intel-Fortran.cmake
%%DATADIR%%/Modules/Platform/Windows-Intel.cmake
+%%DATADIR%%/Modules/Platform/Windows-MSVC-C.cmake
+%%DATADIR%%/Modules/Platform/Windows-MSVC-CXX.cmake
+%%DATADIR%%/Modules/Platform/Windows-MSVC.cmake
%%DATADIR%%/Modules/Platform/Windows-NMcl.cmake
-%%DATADIR%%/Modules/Platform/Windows-cl.cmake
-%%DATADIR%%/Modules/Platform/Windows-cl.cmake.in
%%DATADIR%%/Modules/Platform/Windows-df.cmake
%%DATADIR%%/Modules/Platform/Windows-wcl386.cmake
%%DATADIR%%/Modules/Platform/Windows-windres.cmake
%%DATADIR%%/Modules/Platform/Windows.cmake
+%%DATADIR%%/Modules/Platform/WindowsCE-MSVC-C.cmake
+%%DATADIR%%/Modules/Platform/WindowsCE-MSVC-CXX.cmake
+%%DATADIR%%/Modules/Platform/WindowsCE-MSVC.cmake
+%%DATADIR%%/Modules/Platform/WindowsCE.cmake
%%DATADIR%%/Modules/Platform/WindowsPaths.cmake
%%DATADIR%%/Modules/Platform/Xenix.cmake
-%%DATADIR%%/Modules/Platform/cl.cmake
%%DATADIR%%/Modules/Platform/eCos.cmake
%%DATADIR%%/Modules/Platform/gas.cmake
%%DATADIR%%/Modules/Platform/kFreeBSD.cmake
@@ -609,6 +630,7 @@
@dirrm %%DATADIR%%/Modules/FortranCInterface/Verify
@dirrm %%DATADIR%%/Modules/FortranCInterface
@dirrm %%DATADIR%%/Modules/FindCUDA
+@dirrm %%DATADIR%%/Modules/CompilerId
@dirrm %%DATADIR%%/Modules/Compiler
@dirrm %%DATADIR%%/Modules/CMakeAddFortranSubdirectory
@dirrmtry %%DATADIR%%/Modules