aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-20 12:28:42 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-20 12:28:42 +0000
commitc3b89a682fe8f4b2d00949bb550188d03915a640 (patch)
tree63d135383ba776c3dc4fd732329a1828e5871dec
parenteec6a546fcf507f16a8f189c7156f8a01df93b4f (diff)
downloadports-c3b89a682fe8f4b2d00949bb550188d03915a640.tar.gz
ports-c3b89a682fe8f4b2d00949bb550188d03915a640.zip
Notes
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/dclibc/Makefile30
-rw-r--r--net-p2p/dclibc/distinfo3
-rw-r--r--net-p2p/dclibc/files/patch-Makefile.in11
-rw-r--r--net-p2p/dclibc/pkg-descr6
-rw-r--r--net-p2p/dclibc/pkg-plist14
6 files changed, 65 insertions, 0 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index db431c525d18..9fbd78bfd4b9 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -14,6 +14,7 @@
SUBDIR += ctorrent
SUBDIR += dcd
SUBDIR += dclib
+ SUBDIR += dclibc
SUBDIR += dctc
SUBDIR += dctc-gui
SUBDIR += dctc-gui-qt
diff --git a/net-p2p/dclibc/Makefile b/net-p2p/dclibc/Makefile
new file mode 100644
index 000000000000..fd50a5401fb6
--- /dev/null
+++ b/net-p2p/dclibc/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: dclibc
+# Date created: 2006-08-20
+# Whom: Pankov Pavel <pankov_@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dclibc
+PORTVERSION= 0.1.1.d1
+CATEGORIES= net-p2p
+MASTER_SITES= http://www.gtkdc.org/gtkdc_files/dclibc/0.1/
+DISTNAME= dclibc-0.1.1-debug1
+
+MAINTAINER= pankov_p@mail.ru
+COMMENT= A Direct Connect peer-to-peer protocol C library
+
+GNU_CONFIGURE= yes
+
+USE_GETTEXT= yes
+USE_ICONV= yes
+USE_GNOME= glib20 pkgconfig
+USE_LDCONFIG= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= doesn't build on FreeBSD < 5.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/dclibc/distinfo b/net-p2p/dclibc/distinfo
new file mode 100644
index 000000000000..5785f7ae89cf
--- /dev/null
+++ b/net-p2p/dclibc/distinfo
@@ -0,0 +1,3 @@
+MD5 (dclibc-0.1.1-debug1.tar.gz) = e62affd68344b9c1ef9dec29be540c00
+SHA256 (dclibc-0.1.1-debug1.tar.gz) = d22e5fee5ffbc42799506df9affb55c1b94a4d949eaf9014d7e9c9742c1cb618
+SIZE (dclibc-0.1.1-debug1.tar.gz) = 340603
diff --git a/net-p2p/dclibc/files/patch-Makefile.in b/net-p2p/dclibc/files/patch-Makefile.in
new file mode 100644
index 000000000000..d15d03c5a79e
--- /dev/null
+++ b/net-p2p/dclibc/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in-orig Mon May 22 10:23:09 2006
++++ Makefile.in Sun Aug 20 01:23:21 2006
+@@ -193,7 +193,7 @@
+ target_alias = @target_alias@
+ SUBDIRS = dclibc
+ EXTRA_DIST = TODO dclibc.pc.in
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = @exec_prefix@/libdata/pkgconfig
+ pkgconfig_DATA = dclibc.pc
+ all: config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-recursive
diff --git a/net-p2p/dclibc/pkg-descr b/net-p2p/dclibc/pkg-descr
new file mode 100644
index 000000000000..b9a1a62fa3f3
--- /dev/null
+++ b/net-p2p/dclibc/pkg-descr
@@ -0,0 +1,6 @@
+DCLibC is a library for implementing the Direct Connect peer-to-peer
+protocol. It offers support for the NMDC protocol (client-hub
+commands and client-client operations) and an interface to the
+most common filelists.
+
+WWW: http://www.gtkdc.org/
diff --git a/net-p2p/dclibc/pkg-plist b/net-p2p/dclibc/pkg-plist
new file mode 100644
index 000000000000..7e30bc5641b3
--- /dev/null
+++ b/net-p2p/dclibc/pkg-plist
@@ -0,0 +1,14 @@
+include/dclibc/dclibc/dclibc.h
+include/dclibc/dclibc/dcproto.h
+include/dclibc/dclibc/hub.h
+include/dclibc/dclibc/hubconn.h
+include/dclibc/dclibc/search.h
+include/dclibc/dclibc/userinfo.h
+include/dclibc/dclibc/userlist.h
+lib/libdclibc.a
+lib/libdclibc.la
+lib/libdclibc.so
+lib/libdclibc.so.8
+libdata/pkgconfig/dclibc.pc
+@dirrm include/dclibc/dclibc
+@dirrm include/dclibc