aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-06-02 18:07:32 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-06-02 18:07:32 +0000
commitc3cea8c93fd26d98d0cbcecda6b4d296940428c4 (patch)
tree3d7b312a7855214188aaf26f1654622b36972108
parentd0155c5387c5d53cb7b3092e7636fcebdd3b481d (diff)
downloadports-c3cea8c93fd26d98d0cbcecda6b4d296940428c4.tar.gz
ports-c3cea8c93fd26d98d0cbcecda6b4d296940428c4.zip
Notes
-rw-r--r--audio/openal-soft/Makefile2
-rw-r--r--audio/openal-soft/files/patch-Alc-ALu.c4
2 files changed, 3 insertions, 3 deletions
diff --git a/audio/openal-soft/Makefile b/audio/openal-soft/Makefile
index 6a55639cc575..50029de5059f 100644
--- a/audio/openal-soft/Makefile
+++ b/audio/openal-soft/Makefile
@@ -2,7 +2,7 @@
PORTNAME= openal-soft
PORTVERSION= 1.15.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://kcat.strangesoft.net/openal-releases/
diff --git a/audio/openal-soft/files/patch-Alc-ALu.c b/audio/openal-soft/files/patch-Alc-ALu.c
index 5e673f703562..75b767f31d96 100644
--- a/audio/openal-soft/files/patch-Alc-ALu.c
+++ b/audio/openal-soft/files/patch-Alc-ALu.c
@@ -26,12 +26,12 @@
{ return aluF2I(val)+2147483648u; }
static __inline ALshort aluF2S(ALfloat val)
-{ return aluF2I(val)>>16; }
-+{ return aluF2I(val)>>9; }
++{ return aluF2I25(val)>>9; }
static __inline ALushort aluF2US(ALfloat val)
{ return aluF2S(val)+32768; }
static __inline ALbyte aluF2B(ALfloat val)
-{ return aluF2I(val)>>24; }
-+{ return aluF2I(val)>>17; }
++{ return aluF2I25(val)>>17; }
static __inline ALubyte aluF2UB(ALfloat val)
{ return aluF2B(val)+128; }