aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-03-18 21:18:04 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-03-18 21:18:04 +0000
commitc3dba571af705f4620ec8808a299a283def99a70 (patch)
tree4498bce6c10e7ddbfc5c1d10e844aaaa7eb98f7b
parent3dc70abafe3e0ebe88ff6bf1c20c013c7d5cd6fc (diff)
downloadports-c3dba571af705f4620ec8808a299a283def99a70.tar.gz
ports-c3dba571af705f4620ec8808a299a283def99a70.zip
Notes
-rw-r--r--games/Makefile1
-rw-r--r--games/flobopuyo/Makefile31
-rw-r--r--games/flobopuyo/distinfo3
-rw-r--r--games/flobopuyo/pkg-descr7
-rw-r--r--games/flobopuyo/pkg-plist86
5 files changed, 128 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index ed5ba9bcfd70..3a4ce781f144 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -174,6 +174,7 @@
SUBDIR += flightgear-atlas
SUBDIR += flightgear-l410
SUBDIR += flightgear-mb339-pan
+ SUBDIR += flobopuyo
SUBDIR += flying
SUBDIR += fmars
SUBDIR += foobillard
diff --git a/games/flobopuyo/Makefile b/games/flobopuyo/Makefile
new file mode 100644
index 000000000000..671d8e026802
--- /dev/null
+++ b/games/flobopuyo/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: flobopuyo
+# Date created: 24 Feb 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flobopuyo
+PORTVERSION= 0.20
+CATEGORIES= games
+MASTER_SITES= http://www.ios-software.com/flobopuyo/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Clone of the famous PuyoPuyo
+
+USE_BISON= yes
+USE_GMAKE= yes
+USE_SDL= sdl mixer image
+USE_GCC= 3.4+
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/audio.h ${WRKSRC}/glSDL.h ${WRKSRC}/main.cpp
+ @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|g++|${CXX}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|^CFLAGS=|CFLAGS+=|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|^DATADIR=.*$$|DATADIR=${DATADIR}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|^INSTALL_DATADIR=.*$$|INSTALL_DATADIR=${DATADIR}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|^INSTALL_BINDIR=.*$$|INSTALL_BINDIR=${PREFIX}/bin|' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/games/flobopuyo/distinfo b/games/flobopuyo/distinfo
new file mode 100644
index 000000000000..0aa317d40788
--- /dev/null
+++ b/games/flobopuyo/distinfo
@@ -0,0 +1,3 @@
+MD5 (flobopuyo-0.20.tgz) = 88961898c9dd48b60464f6f10f695b8b
+SHA256 (flobopuyo-0.20.tgz) = 46d12af706fba7281e7f92f733e70cc38e9965a550e06a8a38ea4f65620da130
+SIZE (flobopuyo-0.20.tgz) = 2949681
diff --git a/games/flobopuyo/pkg-descr b/games/flobopuyo/pkg-descr
new file mode 100644
index 000000000000..1ba838267d11
--- /dev/null
+++ b/games/flobopuyo/pkg-descr
@@ -0,0 +1,7 @@
+Puyos are fancy smiling bubbles... But they can really be invading
+sometimes! Your goal is to make groups of colored puyos to make
+them explode and send bad ghost Puyos to your oponent. You win the
+game if your oponent reaches the top of the board. You can play
+against computer or an other human.
+
+WWW: http://www.ios-software.com/?page=projet&quoi=29&lg=AN
diff --git a/games/flobopuyo/pkg-plist b/games/flobopuyo/pkg-plist
new file mode 100644
index 000000000000..fb8bf7f92b43
--- /dev/null
+++ b/games/flobopuyo/pkg-plist
@@ -0,0 +1,86 @@
+bin/flobopuyo
+%%DATADIR%%/gfx/0live.png
+%%DATADIR%%/gfx/1live.png
+%%DATADIR%%/gfx/2live.png
+%%DATADIR%%/gfx/3live.png
+%%DATADIR%%/gfx/Background.jpg
+%%DATADIR%%/gfx/BackgroundDark.jpg
+%%DATADIR%%/gfx/BigNeutral.png
+%%DATADIR%%/gfx/Explode1.png
+%%DATADIR%%/gfx/Explode2.png
+%%DATADIR%%/gfx/Explode3.png
+%%DATADIR%%/gfx/Explode4.png
+%%DATADIR%%/gfx/MenuBackground.jpg
+%%DATADIR%%/gfx/Neutral.png
+%%DATADIR%%/gfx/Shadow.png
+%%DATADIR%%/gfx/Shrink1.png
+%%DATADIR%%/gfx/Shrink2.png
+%%DATADIR%%/gfx/Shrink3.png
+%%DATADIR%%/gfx/Shrink4.png
+%%DATADIR%%/gfx/circle.png
+%%DATADIR%%/gfx/crosseye.png
+%%DATADIR%%/gfx/eye0.png
+%%DATADIR%%/gfx/eye1.png
+%%DATADIR%%/gfx/eye2.png
+%%DATADIR%%/gfx/font3b.png
+%%DATADIR%%/gfx/font4b.png
+%%DATADIR%%/gfx/fontdark.png
+%%DATADIR%%/gfx/grid.png
+%%DATADIR%%/gfx/menusel.png
+%%DATADIR%%/gfx/perso1_1.png
+%%DATADIR%%/gfx/perso1_2.png
+%%DATADIR%%/gfx/speed.png
+%%DATADIR%%/gfx/speed_black.png
+%%DATADIR%%/gfx/twirleye0.png
+%%DATADIR%%/gfx/twirleye1.png
+%%DATADIR%%/gfx/twirleye2.png
+%%DATADIR%%/gfx/twirleye3.png
+%%DATADIR%%/gfx/v0.png
+%%DATADIR%%/gfx/v1a.png
+%%DATADIR%%/gfx/v1b.png
+%%DATADIR%%/gfx/v1c.png
+%%DATADIR%%/gfx/v1d.png
+%%DATADIR%%/gfx/v2ab.png
+%%DATADIR%%/gfx/v2ac.png
+%%DATADIR%%/gfx/v2ad.png
+%%DATADIR%%/gfx/v2bc.png
+%%DATADIR%%/gfx/v2bd.png
+%%DATADIR%%/gfx/v2cd.png
+%%DATADIR%%/gfx/v3abc.png
+%%DATADIR%%/gfx/v3abd.png
+%%DATADIR%%/gfx/v3acd.png
+%%DATADIR%%/gfx/v3bcd.png
+%%DATADIR%%/gfx/v4abcd.png
+%%DATADIR%%/sfx/._bi
+%%DATADIR%%/sfx/applose.wav
+%%DATADIR%%/sfx/bam1.wav
+%%DATADIR%%/sfx/bim1.wav
+%%DATADIR%%/sfx/bim2.wav
+%%DATADIR%%/sfx/fff.wav
+%%DATADIR%%/sfx/flobopuyo_game1.xm
+%%DATADIR%%/sfx/flobopuyo_game2.xm
+%%DATADIR%%/sfx/flobopuyo_gameover.xm
+%%DATADIR%%/sfx/flobopuyo_menu.xm
+%%DATADIR%%/sfx/pastaga.wav
+%%DATADIR%%/sfx/pop.wav
+%%DATADIR%%/sfx/remove.wav
+%%DATADIR%%/sfx/slide.wav
+%%DATADIR%%/sfx/splash1.wav
+%%DATADIR%%/sfx/splash2.wav
+%%DATADIR%%/sfx/splash3.wav
+%%DATADIR%%/sfx/splash4.wav
+%%DATADIR%%/sfx/splash5.wav
+%%DATADIR%%/sfx/splash6.wav
+%%DATADIR%%/sfx/splash7.wav
+%%DATADIR%%/sfx/splash8.wav
+%%DATADIR%%/sfx/strange_fear.xm
+%%DATADIR%%/sfx/strange_fear2.xm
+%%DATADIR%%/sfx/strange_gameover.xm
+%%DATADIR%%/sfx/woho.wav
+%%DATADIR%%/sfx/woo.wav
+%%DATADIR%%/sfx/yahoohoo.wav
+%%DATADIR%%/story/intro.txt
+@dirrm %%DATADIR%%/gfx
+@dirrm %%DATADIR%%/sfx
+@dirrm %%DATADIR%%/story
+@dirrm %%DATADIR%%