aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2020-09-25 15:53:43 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2020-09-25 15:53:43 +0000
commitc44ccc450b455c7ad3ca4f3256d5f49725742c81 (patch)
tree368655b4a4e97b4a5e09690f00c949aa15756987
parent2a5c178e776fcb0946505f1f1aa01b1420498a5e (diff)
downloadports-c44ccc450b455c7ad3ca4f3256d5f49725742c81.tar.gz
ports-c44ccc450b455c7ad3ca4f3256d5f49725742c81.zip
Fix depenedency for postgresql13-contrib
And avoid hardcoding the version for all other versions as well, per suggestion in the PR. PR: 249888 Submitted by: Christian Ullrich
Notes
Notes: svn path=/head/; revision=550051
-rw-r--r--databases/postgresql10-contrib/Makefile2
-rw-r--r--databases/postgresql11-contrib/Makefile2
-rw-r--r--databases/postgresql12-contrib/Makefile2
-rw-r--r--databases/postgresql13-contrib/Makefile4
-rw-r--r--databases/postgresql95-contrib/Makefile2
5 files changed, 6 insertions, 6 deletions
diff --git a/databases/postgresql10-contrib/Makefile b/databases/postgresql10-contrib/Makefile
index 126181668894..7ecfd557423c 100644
--- a/databases/postgresql10-contrib/Makefile
+++ b/databases/postgresql10-contrib/Makefile
@@ -10,7 +10,7 @@ COMMENT= The contrib utilities from the PostgreSQL distribution
MASTERDIR= ${.CURDIR}/../postgresql10-server
-USES= bison pgsql:10
+USES= bison pgsql:${DISTVERSION:C/([0-9]\.?[0-9]).*/\1/g}
BUILD_DIRS= src/port src/include src/common contrib
INSTALL_DIRS= contrib
diff --git a/databases/postgresql11-contrib/Makefile b/databases/postgresql11-contrib/Makefile
index 776a215d7951..ccf602a34638 100644
--- a/databases/postgresql11-contrib/Makefile
+++ b/databases/postgresql11-contrib/Makefile
@@ -10,7 +10,7 @@ COMMENT= The contrib utilities from the PostgreSQL distribution
MASTERDIR= ${.CURDIR}/../postgresql11-server
-USES= bison pgsql:11
+USES= bison pgsql:${DISTVERSION:C/([0-9]\.?[0-9]).*/\1/g}
BUILD_DIRS= src/port src/include src/common contrib
INSTALL_DIRS= contrib
diff --git a/databases/postgresql12-contrib/Makefile b/databases/postgresql12-contrib/Makefile
index f7c88aa12cd4..d53ed4574b44 100644
--- a/databases/postgresql12-contrib/Makefile
+++ b/databases/postgresql12-contrib/Makefile
@@ -10,7 +10,7 @@ COMMENT= The contrib utilities from the PostgreSQL distribution
MASTERDIR= ${.CURDIR}/../postgresql12-server
-USES= bison pgsql:12
+USES= bison pgsql:${DISTVERSION:C/([0-9]\.?[0-9]).*/\1/g}
BUILD_DIRS= src/port src/include src/common contrib
INSTALL_DIRS= contrib
diff --git a/databases/postgresql13-contrib/Makefile b/databases/postgresql13-contrib/Makefile
index 289411be396f..c69d325e0ac3 100644
--- a/databases/postgresql13-contrib/Makefile
+++ b/databases/postgresql13-contrib/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= postgresql
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= databases
MAINTAINER= pgsql@FreeBSD.org
@@ -10,7 +10,7 @@ COMMENT= The contrib utilities from the PostgreSQL distribution
MASTERDIR= ${.CURDIR}/../postgresql13-server
-USES= bison pgsql:12
+USES= bison pgsql:${DISTVERSION:C/([0-9]\.?[0-9]).*/\1/g}
BUILD_DIRS= src/port src/include src/common contrib
INSTALL_DIRS= contrib
diff --git a/databases/postgresql95-contrib/Makefile b/databases/postgresql95-contrib/Makefile
index 760edb6a941d..592c19c8a228 100644
--- a/databases/postgresql95-contrib/Makefile
+++ b/databases/postgresql95-contrib/Makefile
@@ -13,7 +13,7 @@ LIB_DEPENDS= libxslt.so:textproc/libxslt \
MASTERDIR= ${.CURDIR}/../postgresql95-server
-USES= bison pgsql:9.5
+USES= bison pgsql:${DISTVERSION:C/([0-9]\.?[0-9]).*/\1/g}
BUILD_DIRS= src/port src/common contrib
INSTALL_DIRS= contrib