aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-10-15 21:06:25 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-10-15 21:21:45 +0000
commitc519e8d8982d5a628411a8543fa533d0bb4fd302 (patch)
tree9499f15c6151e41fa7316eb7725a97eefc5c72f4
parentf51593e1046d3d363e2d8f50742613899fdd847d (diff)
-rw-r--r--multimedia/gstreamer1-plugins-rust/Makefile2
-rw-r--r--multimedia/gstreamer1-plugins-rust/files/patch-gst-1.1638
2 files changed, 1 insertions, 39 deletions
diff --git a/multimedia/gstreamer1-plugins-rust/Makefile b/multimedia/gstreamer1-plugins-rust/Makefile
index 190d25c67ca6..200a217b0c22 100644
--- a/multimedia/gstreamer1-plugins-rust/Makefile
+++ b/multimedia/gstreamer1-plugins-rust/Makefile
@@ -1,6 +1,6 @@
PORTNAME= gstreamer1-plugins-rust
DISTVERSION= 0.7.2
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= multimedia
MAINTAINER= jbeich@FreeBSD.org
diff --git a/multimedia/gstreamer1-plugins-rust/files/patch-gst-1.16 b/multimedia/gstreamer1-plugins-rust/files/patch-gst-1.16
deleted file mode 100644
index 61b69b8708e7..000000000000
--- a/multimedia/gstreamer1-plugins-rust/files/patch-gst-1.16
+++ /dev/null
@@ -1,38 +0,0 @@
-Drop after multimedia/gstreamer1-plugins is updated to 1.18 or later
-
-Package dependency requirement 'gstreamer-1.0 >= 1.18' could not be satisfied.
-Package 'gstreamer-1.0' has version '1.16.2', required version is '>= 1.18'
-
-error[E0599]: no method named `pull_until_eos` found for struct `Harness` in the current scope
- --> audio/audiofx/tests/ebur128level.rs:113:33
- |
-113 | while let Some(_buffer) = h.pull_until_eos().unwrap() {
- | ^^^^^^^^^^^^^^ method not found in `Harness`
-
---- audio/audiofx/Cargo.toml
-+++ audio/audiofx/Cargo.toml 2021-08-15 06:32:37.895468529 +0000
-@@ -25,7 +25,7 @@ crate-type = ["cdylib", "rlib"]
- path = "src/lib.rs"
-
- [dev-dependencies]
--gst-check = { package = "gstreamer-check", version = "0.17", features = ["v1_18"] }
-+gst-check = { package = "gstreamer-check", version = "0.17", features = ["v1_16"] }
- gst-app = { package = "gstreamer-app", version = "0.17" }
-
- [build-dependencies]
---- audio/audiofx/tests/ebur128level.rs.orig 2021-08-05 15:13:43 UTC
-+++ audio/audiofx/tests/ebur128level.rs
-@@ -110,7 +110,13 @@ fn run_test(layout: gst_audio::AudioLayout, format: gs
-
- // Pull all buffers until EOS
- let mut num_buffers = 0;
-+ #[cfg(feature = "v1_18")]
- while let Some(_buffer) = h.pull_until_eos().unwrap() {
-+ num_buffers += 1;
-+ }
-+ #[cfg(not(feature = "v1_18"))]
-+ for _ in 0..5 {
-+ h.pull().unwrap();
- num_buffers += 1;
- }
- assert_eq!(num_buffers, 5);