aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2015-04-05 18:03:56 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2015-04-05 18:03:56 +0000
commitc66f90fb7d7fad80e99fb66a03dfe068d1331b0d (patch)
tree1eb31ea025ef7d23c0759898d5d558b677f35430
parentf4e1a5b6b20f59d5f0c9c918282358302dea37c0 (diff)
downloadports-c66f90fb7d7fad80e99fb66a03dfe068d1331b0d.tar.gz
ports-c66f90fb7d7fad80e99fb66a03dfe068d1331b0d.zip
Notes
-rw-r--r--Mk/bsd.qt.mk5
-rw-r--r--multimedia/Makefile4
-rw-r--r--multimedia/qt5-phonon4-designerplugin/Makefile28
-rw-r--r--multimedia/qt5-phonon4-designerplugin/pkg-descr3
-rw-r--r--multimedia/qt5-phonon4-gstreamer/Makefile29
-rw-r--r--multimedia/qt5-phonon4-gstreamer/distinfo2
-rw-r--r--multimedia/qt5-phonon4-gstreamer/pkg-descr3
-rw-r--r--multimedia/qt5-phonon4-gstreamer/pkg-plist7
-rw-r--r--multimedia/qt5-phonon4-vlc/Makefile24
-rw-r--r--multimedia/qt5-phonon4-vlc/distinfo2
-rw-r--r--multimedia/qt5-phonon4-vlc/pkg-descr3
-rw-r--r--multimedia/qt5-phonon4/Makefile34
-rw-r--r--multimedia/qt5-phonon4/distinfo2
-rw-r--r--multimedia/qt5-phonon4/files/patch-CMakeLists.txt11
-rw-r--r--multimedia/qt5-phonon4/pkg-descr4
-rw-r--r--multimedia/qt5-phonon4/pkg-message7
-rw-r--r--multimedia/qt5-phonon4/pkg-plist181
17 files changed, 348 insertions, 1 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index 837066807f89..56cbbeda125d 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -297,7 +297,7 @@ _USE_QT4_ONLY= accessible assistant-adp assistantclient codecs-cn codecs-jp \
qtestlib qvfb rcc uic uic3 xmlpatterns-tool
_USE_QT5_ONLY= buildtools concurrent core graphicaleffects \
- paths printsupport qdbus qdoc qev qml quick \
+ paths phonon4 printsupport qdbus qdoc qev qml quick \
quickcontrols serialport uitools widgets x11extras
accessible_PORT= accessibility/${_QT_RELNAME}-accessible
@@ -411,6 +411,9 @@ pixeltool_PATH= ${QT_BINDIR}/pixeltool
phonon_PORT= multimedia/phonon
phonon_PATH= ${QT_LIBDIR}/libphonon.so
+phonon4_PORT= multimedia/${_QT_RELNAME}-phonon4
+phonon4_PATH= ${QT_LIBDIR}/libphonon4${_QT_RELNAME}.so
+
phonon-gst_PORT= multimedia/phonon-gstreamer
phonon-gst_PATH= ${QT_PLUGINDIR}/phonon_backend/libphonon_gstreamer.so
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 1073b290da86..3ae89436b9bf 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -322,6 +322,10 @@
SUBDIR += qt4-mobility
SUBDIR += qt4-multimedia
SUBDIR += qt5-multimedia
+ SUBDIR += qt5-phonon4
+ SUBDIR += qt5-phonon4-designerplugin
+ SUBDIR += qt5-phonon4-gstreamer
+ SUBDIR += qt5-phonon4-vlc
SUBDIR += quark
SUBDIR += quodlibet
SUBDIR += quvi
diff --git a/multimedia/qt5-phonon4-designerplugin/Makefile b/multimedia/qt5-phonon4-designerplugin/Makefile
new file mode 100644
index 000000000000..0201ff7e4507
--- /dev/null
+++ b/multimedia/qt5-phonon4-designerplugin/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= phonon
+PORTVERSION= 4.8.3
+CATEGORIES= multimedia
+PKGNAMEPREFIX= qt5-
+PKGNAMESUFFIX= 4
+MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}/src
+PKGNAMESUFFIX= -designerplugin
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt 5 Designer plugin for Phonon 4
+
+LICENSE= LGPL21
+
+USES= cmake tar:xz
+USE_QT5= buildtools_build qmake_build designer phonon4
+CMAKE_ARGS= -DPHONON_QT_PLUGIN_INSTALL_DIR=${PREFIX}/${QT_PLUGINDIR_REL}/designer \
+ -DPHONON_BUILD_PHONON4QT5=ON
+
+BUILD_WRKSRC= ${WRKSRC}/designer
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DISTINFO_FILE= ${.CURDIR:H}/qt5-phonon4/distinfo
+
+PLIST_FILES= ${QT_PLUGINDIR_REL}/designer/libphononwidgets.so
+
+.include <bsd.port.mk>
diff --git a/multimedia/qt5-phonon4-designerplugin/pkg-descr b/multimedia/qt5-phonon4-designerplugin/pkg-descr
new file mode 100644
index 000000000000..8975e8b9c9d1
--- /dev/null
+++ b/multimedia/qt5-phonon4-designerplugin/pkg-descr
@@ -0,0 +1,3 @@
+This port installs Qt 5 Designer plugin for Phonon 4.
+
+WWW: http://phonon.kde.org
diff --git a/multimedia/qt5-phonon4-gstreamer/Makefile b/multimedia/qt5-phonon4-gstreamer/Makefile
new file mode 100644
index 000000000000..9465742d0f01
--- /dev/null
+++ b/multimedia/qt5-phonon4-gstreamer/Makefile
@@ -0,0 +1,29 @@
+# Created by: Martin Wilke <miwi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= phonon
+PORTVERSION= 4.8.2
+CATEGORIES= multimedia
+MASTER_SITES= KDE/stable/${PORTNAME}/${PORTNAME}-backend-gstreamer/${PORTVERSION}/src
+PKGNAMEPREFIX= qt5-
+PKGNAMESUFFIX= 4-gstreamer
+DISTNAME= ${PORTNAME}-backend-gstreamer-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= GStreamer backend for Phonon 4 Qt 5
+
+LICENSE= LGPL21
+
+USES= cmake pkgconfig tar:xz
+USE_GL= gl
+USE_GNOME= glib20 libxml2
+USE_GSTREAMER1= yes
+USE_QT5= buildtools_build qmake_build core gui opengl widgets phonon4
+CMAKE_ARGS= -DPHONON_BUILD_PHONON4QT5=ON
+
+OPTIONS_DEFINE= GST_PLUGINS
+GST_PLUGINS_DESC= Install GStreamer plugins
+GST_PLUGINS_RUN_DEPENDS= gstreamer1-plugins-all>=0:${PORTSDIR}/multimedia/gstreamer1-plugins-all
+
+.include <bsd.port.mk>
diff --git a/multimedia/qt5-phonon4-gstreamer/distinfo b/multimedia/qt5-phonon4-gstreamer/distinfo
new file mode 100644
index 000000000000..d0a1351adf83
--- /dev/null
+++ b/multimedia/qt5-phonon4-gstreamer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/phonon-backend-gstreamer-4.8.2.tar.xz) = 20e0f71f2beb4f859db8385079a13aef5473863ee6f27aad7b065aa7bfe931e0
+SIZE (KDE/phonon-backend-gstreamer-4.8.2.tar.xz) = 76044
diff --git a/multimedia/qt5-phonon4-gstreamer/pkg-descr b/multimedia/qt5-phonon4-gstreamer/pkg-descr
new file mode 100644
index 000000000000..295fadc9b5f8
--- /dev/null
+++ b/multimedia/qt5-phonon4-gstreamer/pkg-descr
@@ -0,0 +1,3 @@
+This port provides the GStreamer backend for Phonon 4 Qt 5.
+
+WWW: http://phonon.kde.org
diff --git a/multimedia/qt5-phonon4-gstreamer/pkg-plist b/multimedia/qt5-phonon4-gstreamer/pkg-plist
new file mode 100644
index 000000000000..86aad2fbc083
--- /dev/null
+++ b/multimedia/qt5-phonon4-gstreamer/pkg-plist
@@ -0,0 +1,7 @@
+%%QT_PLUGINDIR%%/phonon4qt5_backend/phonon_gstreamer.so
+share/icons/hicolor/128x128/apps/phonon-gstreamer.png
+share/icons/hicolor/16x16/apps/phonon-gstreamer.png
+share/icons/hicolor/22x22/apps/phonon-gstreamer.png
+share/icons/hicolor/48x48/apps/phonon-gstreamer.png
+share/icons/hicolor/64x64/apps/phonon-gstreamer.png
+share/icons/hicolor/scalable/apps/phonon-gstreamer.svgz
diff --git a/multimedia/qt5-phonon4-vlc/Makefile b/multimedia/qt5-phonon4-vlc/Makefile
new file mode 100644
index 000000000000..3d9b7b095b7d
--- /dev/null
+++ b/multimedia/qt5-phonon4-vlc/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= phonon
+PORTVERSION= 0.8.2
+CATEGORIES= multimedia
+MASTER_SITES= KDE/stable/${PORTNAME}/${PORTNAME}-backend${PKGNAMESUFFIX}/${PORTVERSION}/src
+PKGNAMEPREFIX= qt5-
+PKGNAMESUFFIX= -vlc
+DISTNAME= ${PORTNAME}-backend${PKGNAMESUFFIX}-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= VLC backend for Phonon 4 Qt 5
+
+LIB_DEPENDS= libvlc.so:${PORTSDIR}/multimedia/vlc
+
+USES= cmake pkgconfig tar:xz
+USE_QT5= core gui widgets phonon4 \
+ buildtools_build qmake_build
+CMAKE_ARGS= -DPHONON_BUILD_PHONON4QT5=ON
+
+PLIST_FILES= ${QT_PLUGINDIR_REL}/phonon4qt5_backend/phonon_vlc.so
+
+.include <bsd.port.mk>
diff --git a/multimedia/qt5-phonon4-vlc/distinfo b/multimedia/qt5-phonon4-vlc/distinfo
new file mode 100644
index 000000000000..e2011a3fefff
--- /dev/null
+++ b/multimedia/qt5-phonon4-vlc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/phonon-backend-vlc-0.8.2.tar.xz) = dab7f8edf53ee90998e5e3fcf2f6bd0a13750511b0ecde6939be0664d46bdaa3
+SIZE (KDE/phonon-backend-vlc-0.8.2.tar.xz) = 59832
diff --git a/multimedia/qt5-phonon4-vlc/pkg-descr b/multimedia/qt5-phonon4-vlc/pkg-descr
new file mode 100644
index 000000000000..b4fb5fce1334
--- /dev/null
+++ b/multimedia/qt5-phonon4-vlc/pkg-descr
@@ -0,0 +1,3 @@
+This port provides the VLC backend for Phonon 4 Qt 5.
+
+WWW: http://phonon.kde.org
diff --git a/multimedia/qt5-phonon4/Makefile b/multimedia/qt5-phonon4/Makefile
new file mode 100644
index 000000000000..59a93e7993df
--- /dev/null
+++ b/multimedia/qt5-phonon4/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= phonon
+PORTVERSION= 4.8.3
+CATEGORIES= multimedia
+PKGNAMEPREFIX= qt5-
+PKGNAMESUFFIX= 4
+MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}/src
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Phonon 4 transitional library for Qt 5
+
+LICENSE= LGPL21
+
+USES= cmake tar:xz
+USE_QT5= core dbus declarative gui opengl widgets \
+ buildtools_build qmake_build
+CMAKE_ARGS= -DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT:BOOL=TRUE \
+ -DPHONON_NO_PLATFORMPLUGIN:BOOL=TRUE \
+ -DPHONON_BUILD_DESIGNER_PLUGIN:BOOL=OFF \
+ -DPHONON_BUILD_PHONON4QT5=ON
+USE_LDCONFIG= yes
+
+PLIST_SUB= SHLIB_VER=${PORTVERSION}
+
+OPTIONS_DEFINE= PULSEAUDIO
+
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
+PULSEAUDIO_USE= GNOME=glib20
+PULSEAUDIO_CMAKE_ON= -DWITH_PulseAudio:BOOL=ON
+PULSEAUDIO_CMAKE_OFF= -DWITH_PulseAudio:BOOL=OFF
+
+.include <bsd.port.mk>
diff --git a/multimedia/qt5-phonon4/distinfo b/multimedia/qt5-phonon4/distinfo
new file mode 100644
index 000000000000..d0bceaf3c4d0
--- /dev/null
+++ b/multimedia/qt5-phonon4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/phonon-4.8.3.tar.xz) = a1149c961ca1570968d070bbd23671e614aa506f847ca93748960e309f85da16
+SIZE (KDE/phonon-4.8.3.tar.xz) = 322012
diff --git a/multimedia/qt5-phonon4/files/patch-CMakeLists.txt b/multimedia/qt5-phonon4/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..2797b9e62e2e
--- /dev/null
+++ b/multimedia/qt5-phonon4/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2013-11-10 20:21:04.000000000 +0200
++++ CMakeLists.txt 2013-11-10 20:21:49.000000000 +0200
+@@ -216,7 +216,7 @@
+ make_abs_install_path(ABS_BUILDSYSTEM_INSTALL_DIR "${BUILDSYSTEM_INSTALL_DIR}")
+
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/phonon.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/${PHONON_LIB_SONAME}.pc @ONLY)
+- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${PHONON_LIB_SONAME}.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
++ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${PHONON_LIB_SONAME}.pc DESTINATION libdata/pkgconfig)
+ endif(NOT WIN32)
+
+ set(CMAKECONFIG_INSTALL_DIR ${LIB_INSTALL_DIR}/cmake/${PHONON_LIB_SONAME} )
diff --git a/multimedia/qt5-phonon4/pkg-descr b/multimedia/qt5-phonon4/pkg-descr
new file mode 100644
index 000000000000..dee53e50404d
--- /dev/null
+++ b/multimedia/qt5-phonon4/pkg-descr
@@ -0,0 +1,4 @@
+Phonon is a multimedia framework by KDE project. This port provides Phonon 4
+transitional library for Qt 5.
+
+WWW: http://phonon.kde.org
diff --git a/multimedia/qt5-phonon4/pkg-message b/multimedia/qt5-phonon4/pkg-message
new file mode 100644
index 000000000000..a943c101ccba
--- /dev/null
+++ b/multimedia/qt5-phonon4/pkg-message
@@ -0,0 +1,7 @@
+======================================================================
+
+Please, consider installing backends for Phonon:
+- multimedia/qt5-phonon4-gstreamer GStreamer backend
+- multimedia/qt5-phonon4-vlc VLC backend
+
+======================================================================
diff --git a/multimedia/qt5-phonon4/pkg-plist b/multimedia/qt5-phonon4/pkg-plist
new file mode 100644
index 000000000000..592b48aebdc6
--- /dev/null
+++ b/multimedia/qt5-phonon4/pkg-plist
@@ -0,0 +1,181 @@
+include/phonon4qt5/KDE/Phonon/AbstractAudioOutput
+include/phonon4qt5/KDE/Phonon/AbstractMediaStream
+include/phonon4qt5/KDE/Phonon/AbstractVideoOutput
+include/phonon4qt5/KDE/Phonon/AddonInterface
+include/phonon4qt5/KDE/Phonon/AudioDevice
+include/phonon4qt5/KDE/Phonon/AudioDeviceEnumerator
+include/phonon4qt5/KDE/Phonon/AudioOutput
+include/phonon4qt5/KDE/Phonon/AudioOutputDevice
+include/phonon4qt5/KDE/Phonon/AudioOutputDeviceModel
+include/phonon4qt5/KDE/Phonon/AudioOutputInterface
+include/phonon4qt5/KDE/Phonon/BackendCapabilities
+include/phonon4qt5/KDE/Phonon/BackendInterface
+include/phonon4qt5/KDE/Phonon/Effect
+include/phonon4qt5/KDE/Phonon/EffectDescription
+include/phonon4qt5/KDE/Phonon/EffectDescriptionModel
+include/phonon4qt5/KDE/Phonon/EffectInterface
+include/phonon4qt5/KDE/Phonon/EffectParameter
+include/phonon4qt5/KDE/Phonon/EffectWidget
+include/phonon4qt5/KDE/Phonon/Experimental/AbstractVideoDataOutput
+include/phonon4qt5/KDE/Phonon/Experimental/AudioDataOutput
+include/phonon4qt5/KDE/Phonon/Experimental/SnapshotInterface
+include/phonon4qt5/KDE/Phonon/Experimental/VideoDataOutput
+include/phonon4qt5/KDE/Phonon/Experimental/VideoDataOutputInterface
+include/phonon4qt5/KDE/Phonon/Experimental/VideoFrame
+include/phonon4qt5/KDE/Phonon/Experimental/VideoFrame2
+include/phonon4qt5/KDE/Phonon/Experimental/Visualization
+include/phonon4qt5/KDE/Phonon/Global
+include/phonon4qt5/KDE/Phonon/MediaController
+include/phonon4qt5/KDE/Phonon/MediaNode
+include/phonon4qt5/KDE/Phonon/MediaObject
+include/phonon4qt5/KDE/Phonon/MediaObjectInterface
+include/phonon4qt5/KDE/Phonon/MediaSource
+include/phonon4qt5/KDE/Phonon/ObjectDescription
+include/phonon4qt5/KDE/Phonon/ObjectDescriptionModel
+include/phonon4qt5/KDE/Phonon/Path
+include/phonon4qt5/KDE/Phonon/PlatformPlugin
+include/phonon4qt5/KDE/Phonon/SeekSlider
+include/phonon4qt5/KDE/Phonon/StreamInterface
+include/phonon4qt5/KDE/Phonon/VideoPlayer
+include/phonon4qt5/KDE/Phonon/VideoWidget
+include/phonon4qt5/KDE/Phonon/VideoWidgetInterface
+include/phonon4qt5/KDE/Phonon/VolumeFaderEffect
+include/phonon4qt5/KDE/Phonon/VolumeFaderInterface
+include/phonon4qt5/KDE/Phonon/VolumeSlider
+include/phonon4qt5/phonon/AbstractAudioOutput
+include/phonon4qt5/phonon/AbstractMediaStream
+include/phonon4qt5/phonon/AbstractVideoOutput
+include/phonon4qt5/phonon/AddonInterface
+include/phonon4qt5/phonon/AudioCaptureDevice
+include/phonon4qt5/phonon/AudioCaptureDeviceModel
+include/phonon4qt5/phonon/AudioChannelDescription
+include/phonon4qt5/phonon/AudioChannelDescriptionModel
+include/phonon4qt5/phonon/AudioDataOutput
+include/phonon4qt5/phonon/AudioOutput
+include/phonon4qt5/phonon/AudioOutputDevice
+include/phonon4qt5/phonon/AudioOutputDeviceModel
+include/phonon4qt5/phonon/AudioOutputInterface
+include/phonon4qt5/phonon/AudioOutputInterface40
+include/phonon4qt5/phonon/AudioOutputInterface42
+include/phonon4qt5/phonon/AvCapture
+include/phonon4qt5/phonon/BackendCapabilities
+include/phonon4qt5/phonon/BackendInterface
+include/phonon4qt5/phonon/Effect
+include/phonon4qt5/phonon/EffectDescription
+include/phonon4qt5/phonon/EffectDescriptionModel
+include/phonon4qt5/phonon/EffectInterface
+include/phonon4qt5/phonon/EffectParameter
+include/phonon4qt5/phonon/EffectWidget
+include/phonon4qt5/phonon/Global
+include/phonon4qt5/phonon/GlobalDescriptionContainer
+include/phonon4qt5/phonon/MediaController
+include/phonon4qt5/phonon/MediaNode
+include/phonon4qt5/phonon/MediaObject
+include/phonon4qt5/phonon/MediaObjectInterface
+include/phonon4qt5/phonon/MediaSource
+include/phonon4qt5/phonon/Mrl
+include/phonon4qt5/phonon/ObjectDescription
+include/phonon4qt5/phonon/ObjectDescriptionData
+include/phonon4qt5/phonon/ObjectDescriptionModel
+include/phonon4qt5/phonon/ObjectDescriptionModelData
+include/phonon4qt5/phonon/Path
+include/phonon4qt5/phonon/PlatformPlugin
+include/phonon4qt5/phonon/SeekSlider
+include/phonon4qt5/phonon/StreamInterface
+include/phonon4qt5/phonon/SubtitleDescription
+include/phonon4qt5/phonon/SubtitleDescriptionModel
+include/phonon4qt5/phonon/VideoCaptureDevice
+include/phonon4qt5/phonon/VideoCaptureDeviceModel
+include/phonon4qt5/phonon/VideoPlayer
+include/phonon4qt5/phonon/VideoWidget
+include/phonon4qt5/phonon/VideoWidgetInterface
+include/phonon4qt5/phonon/VideoWidgetInterface44
+include/phonon4qt5/phonon/VideoWidgetInterfaceLatest
+include/phonon4qt5/phonon/VolumeFaderEffect
+include/phonon4qt5/phonon/VolumeFaderInterface
+include/phonon4qt5/phonon/VolumeSlider
+include/phonon4qt5/phonon/abstractaudiooutput.h
+include/phonon4qt5/phonon/abstractmediastream.h
+include/phonon4qt5/phonon/abstractvideooutput.h
+include/phonon4qt5/phonon/addoninterface.h
+include/phonon4qt5/phonon/audiodataoutput.h
+include/phonon4qt5/phonon/audiodataoutputinterface.h
+include/phonon4qt5/phonon/audiooutput.h
+include/phonon4qt5/phonon/audiooutputinterface.h
+include/phonon4qt5/phonon/backendcapabilities.h
+include/phonon4qt5/phonon/backendinterface.h
+include/phonon4qt5/phonon/effect.h
+include/phonon4qt5/phonon/effectinterface.h
+include/phonon4qt5/phonon/effectparameter.h
+include/phonon4qt5/phonon/effectwidget.h
+include/phonon4qt5/phonon/experimental/abstractaudiodataoutput.h
+include/phonon4qt5/phonon/experimental/abstractvideodataoutput.h
+include/phonon4qt5/phonon/experimental/audiodataoutput.h
+include/phonon4qt5/phonon/experimental/audiodataoutputinterface.h
+include/phonon4qt5/phonon/experimental/audioformat.h
+include/phonon4qt5/phonon/experimental/avcapture.h
+include/phonon4qt5/phonon/experimental/avcaptureinterface.h
+include/phonon4qt5/phonon/experimental/backendcapabilities.h
+include/phonon4qt5/phonon/experimental/backendinterface.h
+include/phonon4qt5/phonon/experimental/export.h
+include/phonon4qt5/phonon/experimental/globalconfig.h
+include/phonon4qt5/phonon/experimental/mediasource.h
+include/phonon4qt5/phonon/experimental/objectdescription.h
+include/phonon4qt5/phonon/experimental/packet.h
+include/phonon4qt5/phonon/experimental/packetpool.h
+include/phonon4qt5/phonon/experimental/phononnamespace.h
+include/phonon4qt5/phonon/experimental/snapshotinterface.h
+include/phonon4qt5/phonon/experimental/videodataoutput.h
+include/phonon4qt5/phonon/experimental/videodataoutput2.h
+include/phonon4qt5/phonon/experimental/videodataoutputinterface.h
+include/phonon4qt5/phonon/experimental/videoframe.h
+include/phonon4qt5/phonon/experimental/videoframe2.h
+include/phonon4qt5/phonon/experimental/videowidget.h
+include/phonon4qt5/phonon/experimental/visualization.h
+include/phonon4qt5/phonon/globalconfig.h
+include/phonon4qt5/phonon/globaldescriptioncontainer.h
+include/phonon4qt5/phonon/mediacontroller.h
+include/phonon4qt5/phonon/medianode.h
+include/phonon4qt5/phonon/mediaobject.h
+include/phonon4qt5/phonon/mediaobjectinterface.h
+include/phonon4qt5/phonon/mediasource.h
+include/phonon4qt5/phonon/mrl.h
+include/phonon4qt5/phonon/objectdescription.h
+include/phonon4qt5/phonon/objectdescriptionmodel.h
+include/phonon4qt5/phonon/path.h
+include/phonon4qt5/phonon/phonon_export.h
+include/phonon4qt5/phonon/phonondefs.h
+include/phonon4qt5/phonon/phononnamespace.h
+include/phonon4qt5/phonon/platformplugin.h
+include/phonon4qt5/phonon/pulsesupport.h
+include/phonon4qt5/phonon/seekslider.h
+include/phonon4qt5/phonon/streaminterface.h
+include/phonon4qt5/phonon/videoplayer.h
+include/phonon4qt5/phonon/videowidget.h
+include/phonon4qt5/phonon/videowidgetinterface.h
+include/phonon4qt5/phonon/volumefadereffect.h
+include/phonon4qt5/phonon/volumefaderinterface.h
+include/phonon4qt5/phonon/volumeslider.h
+lib/cmake/phonon4qt5/Phonon4Qt5Config.cmake
+lib/cmake/phonon4qt5/Phonon4Qt5ConfigVersion.cmake
+lib/cmake/phonon4qt5/PhononTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/phonon4qt5/PhononTargets.cmake
+lib/libphonon4qt5.so
+lib/libphonon4qt5.so.4
+lib/libphonon4qt5.so.%%SHLIB_VER%%
+lib/libphonon4qt5experimental.so
+lib/libphonon4qt5experimental.so.4
+lib/libphonon4qt5experimental.so.%%SHLIB_VER%%
+%%QT_MKSPECDIR%%/modules/qt_phonon4qt5.pri
+libdata/pkgconfig/phonon4qt5.pc
+share/dbus-1/interfaces/org.kde.Phonon4Qt5.AudioOutput.xml
+share/phonon4qt5/buildsystem/COPYING-CMAKE-SCRIPTS
+share/phonon4qt5/buildsystem/FindAutomoc4.cmake
+share/phonon4qt5/buildsystem/FindPackageHandleStandardArgs.cmake
+share/phonon4qt5/buildsystem/FindPhononInternal.cmake
+share/phonon4qt5/buildsystem/MacroEnsureVersion.cmake
+share/phonon4qt5/buildsystem/MacroLogFeature.cmake
+share/phonon4qt5/buildsystem/MacroOptionalFindPackage.cmake
+share/phonon4qt5/buildsystem/MacroPushRequiredVars.cmake
+share/phonon4qt5/buildsystem/PhononMacros.cmake
+share/phonon4qt5/buildsystem/cmake_uninstall.cmake.in