aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Meyer <cem@FreeBSD.org>2016-07-17 20:59:00 +0000
committerConrad Meyer <cem@FreeBSD.org>2016-07-17 20:59:00 +0000
commitc7a62b139758c7857b4cc6c22ed0f26dc37a4174 (patch)
tree10212382235a5a2d699476fac24f2f9dd6ad8d94
parentf02d0d4f308434afe40f8046eb27b947f62d90e1 (diff)
downloadports-c7a62b139758c7857b4cc6c22ed0f26dc37a4174.tar.gz
ports-c7a62b139758c7857b4cc6c22ed0f26dc37a4174.zip
Notes
-rw-r--r--devel/elfutils/Makefile16
-rw-r--r--devel/elfutils/files/patch-libdw_dwarf__getsrclines.c11
-rw-r--r--devel/elfutils/files/patch-src_Makefile.am10
-rw-r--r--devel/elfutils/files/patch-src_ldlex.c11
-rw-r--r--devel/elfutils/files/patch-src_ldlex.l11
-rw-r--r--devel/elfutils/files/patch-src_readelf.c10
6 files changed, 65 insertions, 4 deletions
diff --git a/devel/elfutils/Makefile b/devel/elfutils/Makefile
index 51c94855744f..84f1371fdc2f 100644
--- a/devel/elfutils/Makefile
+++ b/devel/elfutils/Makefile
@@ -3,7 +3,7 @@
PORTNAME= elfutils
PORTVERSION= 0.163
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= devel
MASTER_SITES= https://fedorahosted.org/releases/e/l/elfutils/$(PORTVERSION)/
@@ -27,9 +27,13 @@ NLS_CONFIGURE_ENABLE= nls
USES= gmake libtool tar:bzip2
USE_AUTOTOOLS= automake:env
-USE_GCC= 4.9+
+USE_GCC= 4.8+
GNU_CONFIGURE= yes
+CFLAGS+= -Wno-unused-parameter
+# Give i386 a prayer of building, and we can fix the warnings later:
+CFLAGS_i386+= -Wno-error
+
# Avoid conflict with binutils / elftoolchain programs with the same names:
CONFIGURE_ARGS+= --program-prefix=eu-
@@ -43,4 +47,10 @@ post-patch:
pre-configure:
@cd $(WRKSRC) && ${AUTOMAKE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000000
+IGNORE= requires FreeBSD 10.0 (strchrnul)
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/elfutils/files/patch-libdw_dwarf__getsrclines.c b/devel/elfutils/files/patch-libdw_dwarf__getsrclines.c
new file mode 100644
index 000000000000..8a767a5a8bfc
--- /dev/null
+++ b/devel/elfutils/files/patch-libdw_dwarf__getsrclines.c
@@ -0,0 +1,11 @@
+--- libdw/dwarf_getsrclines.c.orig 2015-06-10 19:44:33 UTC
++++ libdw/dwarf_getsrclines.c
+@@ -188,7 +188,7 @@ read_srclines (Dwarf *dbg,
+ /* Remember array with the standard opcode length (-1 to account for
+ the opcode with value zero not being mentioned). */
+ const uint8_t *standard_opcode_lengths = linep - 1;
+- if (unlikely (lineendp - linep < opcode_base - 1))
++ if (unlikely (lineendp - linep < (ptrdiff_t)opcode_base - 1))
+ goto invalid_data;
+ linep += opcode_base - 1;
+
diff --git a/devel/elfutils/files/patch-src_Makefile.am b/devel/elfutils/files/patch-src_Makefile.am
index 3d629265a0f1..b5e9657d51c9 100644
--- a/devel/elfutils/files/patch-src_Makefile.am
+++ b/devel/elfutils/files/patch-src_Makefile.am
@@ -14,7 +14,15 @@
libelf = ../libelf/libelf.so
endif
libebl = ../libebl/libebl.a
-@@ -103,27 +103,27 @@ ranlib_no_Wstack_usage = yes
+@@ -89,6 +89,7 @@ endif
+ # XXX While the file is not finished, don't warn about this
+ ldgeneric_no_Wunused = yes
+ ldgeneric_no_Wstack_usage = yes
++ldgeneric_no_Werror = yes
+
+ # Bad, bad stack usage...
+ readelf_no_Wstack_usage = yes
+@@ -103,27 +104,27 @@ ranlib_no_Wstack_usage = yes
ar_no_Wstack_usage = yes
unstrip_no_Wstack_usage = yes
diff --git a/devel/elfutils/files/patch-src_ldlex.c b/devel/elfutils/files/patch-src_ldlex.c
new file mode 100644
index 000000000000..6f5005e0715f
--- /dev/null
+++ b/devel/elfutils/files/patch-src_ldlex.c
@@ -0,0 +1,11 @@
+--- src/ldlex.c.orig 2014-08-26 08:58:02 UTC
++++ src/ldlex.c
+@@ -1629,7 +1629,7 @@ YY_RULE_SETUP
+ #line 149 "/home/mark/src/elfutils/src/ldlex.l"
+ { int cnt = 1 ;
+ ldlval.num = 0;
+- while (cnt < ldleng - 1)
++ while (cnt < (int)ldleng - 1)
+ ldlval.num |= attrib_convert (ldtext[cnt++]);
+ return kMODE; }
+ YY_BREAK
diff --git a/devel/elfutils/files/patch-src_ldlex.l b/devel/elfutils/files/patch-src_ldlex.l
new file mode 100644
index 000000000000..1655ea846a22
--- /dev/null
+++ b/devel/elfutils/files/patch-src_ldlex.l
@@ -0,0 +1,11 @@
+--- src/ldlex.l.orig 2014-02-05 00:21:44 UTC
++++ src/ldlex.l
+@@ -148,7 +148,7 @@ VERSION { return kVERSION; }
+
+ "["([RWX]){0,3}"]" { int cnt = 1 ;
+ ldlval.num = 0;
+- while (cnt < yyleng - 1)
++ while (cnt < (int)yyleng - 1)
+ ldlval.num |= attrib_convert (yytext[cnt++]);
+ return kMODE; }
+
diff --git a/devel/elfutils/files/patch-src_readelf.c b/devel/elfutils/files/patch-src_readelf.c
new file mode 100644
index 000000000000..216484935632
--- /dev/null
+++ b/devel/elfutils/files/patch-src_readelf.c
@@ -0,0 +1,10 @@
+--- src/readelf.c.orig 2015-06-19 11:17:42 UTC
++++ src/readelf.c
+@@ -7911,6 +7911,7 @@ print_debug_exception_table (Dwfl_Module
+ break;
+ default:
+ error (1, 0, gettext ("invalid TType encoding"));
++ abort();
+ }
+
+ if (max_ar_filter