aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-01-11 08:51:49 +0000
committerJohn Marino <marino@FreeBSD.org>2016-01-11 08:51:49 +0000
commitc7aba825f01953cbc384c709fc7d9473d81a4c95 (patch)
tree44f088a6d8476984d4a65e17221e8edfd8adc13f
parent50ce3a08a42a2e630046c7563b35be8b27759156 (diff)
downloadports-c7aba825f01953cbc384c709fc7d9473d81a4c95.tar.gz
ports-c7aba825f01953cbc384c709fc7d9473d81a4c95.zip
Notes
-rw-r--r--Mk/Uses/drupal.mk3
-rw-r--r--www/drupal6-advanced_help/Makefile1
-rw-r--r--www/drupal6-cck/Makefile1
-rw-r--r--www/drupal6-chaos/Makefile1
-rw-r--r--www/drupal6-ckeditor/Makefile2
-rw-r--r--www/drupal6-content_access/Makefile1
-rw-r--r--www/drupal6-geshifilter/Makefile1
-rw-r--r--www/drupal6-google_analytics/Makefile1
-rw-r--r--www/drupal6-image/Makefile1
-rw-r--r--www/drupal6-imce/Makefile1
-rw-r--r--www/drupal6-menu_block/Makefile1
-rw-r--r--www/drupal6-mimedetect/Makefile1
-rw-r--r--www/drupal6-nice_menus/Makefile1
-rw-r--r--www/drupal6-nodewords/Makefile1
-rw-r--r--www/drupal6-page_title/Makefile1
-rw-r--r--www/drupal6-panels/Makefile1
-rw-r--r--www/drupal6-path_redirect/Makefile1
-rw-r--r--www/drupal6-pathauto/Makefile1
-rw-r--r--www/drupal6-print/Makefile1
-rw-r--r--www/drupal6-seo_checklist/Makefile1
-rw-r--r--www/drupal6-services/Makefile1
-rw-r--r--www/drupal6-tagadelic/Makefile1
-rw-r--r--www/drupal6-token/Makefile1
-rw-r--r--www/drupal6-views/Makefile1
-rw-r--r--www/drupal6-webform/Makefile1
-rw-r--r--www/drupal6-wysiwyg/Makefile1
-rw-r--r--www/drupal6-zeropoint/Makefile1
-rw-r--r--www/drupal7-wysiwyg/Makefile2
28 files changed, 28 insertions, 4 deletions
diff --git a/Mk/Uses/drupal.mk b/Mk/Uses/drupal.mk
index 246fff224834..6fd915041722 100644
--- a/Mk/Uses/drupal.mk
+++ b/Mk/Uses/drupal.mk
@@ -47,9 +47,6 @@ DOCSDIR?= ${DRUPAL_DOCSDIR}
.if ${_DRUPAL_COMP}
_USES_POST+= drupal
PKGNAMEPREFIX= drupal${_DRUPAL_VERSION}-
-.if defined(DOC_FILES)
-OPTIONS_DEFINE= DOCS
-.endif
# drupal contributions must be licensed under the GPLv2 or GPLv3. This is
# documented at: http://drupal.org/licensing/faq/
diff --git a/www/drupal6-advanced_help/Makefile b/www/drupal6-advanced_help/Makefile
index da5396ae5a22..a0544478eae4 100644
--- a/www/drupal6-advanced_help/Makefile
+++ b/www/drupal6-advanced_help/Makefile
@@ -43,5 +43,6 @@ MODULE_FILES= help/advanced_help.help.ini help/ini-file.html \
translations/advanced_help.pot \
translations/fr.po
DOC_FILES= LICENSE.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal6-cck/Makefile b/www/drupal6-cck/Makefile
index f58d571a08d0..8807a265bedd 100644
--- a/www/drupal6-cck/Makefile
+++ b/www/drupal6-cck/Makefile
@@ -242,5 +242,6 @@ MODULE_FILES= help/add-existing-field.html \
translations/vi.po
DOC_FILES= CHANGELOG.txt DEVELOPER.txt README.txt UPGRADE.txt \
LICENSE.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal6-chaos/Makefile b/www/drupal6-chaos/Makefile
index 77f46e8a7865..f5f101a6a57e 100644
--- a/www/drupal6-chaos/Makefile
+++ b/www/drupal6-chaos/Makefile
@@ -366,5 +366,6 @@ DOC_DIRS= ctools_plugin_example
DOC_FILES= ctools_plugin_example/README.txt LICENSE.txt \
CHANGELOG.txt API.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal6-ckeditor/Makefile b/www/drupal6-ckeditor/Makefile
index db2d110ce7af..7aa25cc34812 100644
--- a/www/drupal6-ckeditor/Makefile
+++ b/www/drupal6-ckeditor/Makefile
@@ -313,6 +313,8 @@ DOC_FILES= ckeditor/LICENSE.html ckeditor/INSTALL.html \
TROUBLESHOOTING.txt README.txt \
LICENSE.txt CHANGELOG.txt
+OPTIONS_DEFINE= DOCS
+
post-extract:
@cd ${WRKSRC} && ${TAR} xf ${DISTDIR}/${DIST_SUBDIR}/ckeditor_3.3.tar.gz
diff --git a/www/drupal6-content_access/Makefile b/www/drupal6-content_access/Makefile
index a72422991641..752c51f065e1 100644
--- a/www/drupal6-content_access/Makefile
+++ b/www/drupal6-content_access/Makefile
@@ -27,5 +27,6 @@ MODULE_FILES= tests/content_access.test \
translations/sv.po
DOC_FILES= README.txt UPGRADE.txt LICENSE.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal6-geshifilter/Makefile b/www/drupal6-geshifilter/Makefile
index 8aabc9d8b7a7..e2ef701b2d8f 100644
--- a/www/drupal6-geshifilter/Makefile
+++ b/www/drupal6-geshifilter/Makefile
@@ -29,6 +29,7 @@ MODULE_FILES= geshi-extra/drupal5.php geshi-extra/drupal6.php \
DOC_DIRS= geshi-extra
DOC_FILES= LICENSE.txt README.txt geshi-extra/README
+OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e's|%%LOCALBASE%%|${LOCALBASE}|g' \
diff --git a/www/drupal6-google_analytics/Makefile b/www/drupal6-google_analytics/Makefile
index 2b62a8fbb3de..aab65975e445 100644
--- a/www/drupal6-google_analytics/Makefile
+++ b/www/drupal6-google_analytics/Makefile
@@ -14,5 +14,6 @@ MODULE_FILES= googleanalytics.admin.inc googleanalytics.install googleanalytics.
googleanalytics.info googleanalytics.js googleanalytics.test
DOC_FILES= LICENSE.txt README.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal6-image/Makefile b/www/drupal6-image/Makefile
index 8010be9db05f..40bac32a1fe2 100644
--- a/www/drupal6-image/Makefile
+++ b/www/drupal6-image/Makefile
@@ -146,5 +146,6 @@ MODULE_FILES= contrib/image_attach/tests/image_attach.test \
views/image_plugin_argument_validate_image_size.inc
DOC_FILES= LICENSE.txt CHANGELOG.txt INSTALL.txt README.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal6-imce/Makefile b/www/drupal6-imce/Makefile
index 7c30dfea2a1f..2e3100b1663a 100644
--- a/www/drupal6-imce/Makefile
+++ b/www/drupal6-imce/Makefile
@@ -52,5 +52,6 @@ MODULE_FILES= translations/uk.po \
css/collapsed.png
DOC_FILES= README.txt LICENSE.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal6-menu_block/Makefile b/www/drupal6-menu_block/Makefile
index 15d624a393dc..6f766fc1cbdc 100644
--- a/www/drupal6-menu_block/Makefile
+++ b/www/drupal6-menu_block/Makefile
@@ -19,5 +19,6 @@ MODULE_FILES= menu-block-wrapper.tpl.php menu_block.admin.inc menu_block.book.in
plugins/content_types/menu_tree/menu_tree.inc
MODULE_DIRS= plugins/content_types/menu_tree plugins/content_types plugins
DOC_FILES= CHANGELOG.txt README.txt LICENSE.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal6-mimedetect/Makefile b/www/drupal6-mimedetect/Makefile
index be2ccb3ded46..44c168223aeb 100644
--- a/www/drupal6-mimedetect/Makefile
+++ b/www/drupal6-mimedetect/Makefile
@@ -17,6 +17,7 @@ USES= drupal:6,module
MODULE_FILES= magic magic.mgc magic.mime \
mimedetect.info mimedetect.install mimedetect.module
DOC_FILES= LICENSE.txt README.txt
+OPTIONS_DEFINE= DOCS
NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/www/drupal6-nice_menus/Makefile b/www/drupal6-nice_menus/Makefile
index 508ed245242e..68dad41385f6 100644
--- a/www/drupal6-nice_menus/Makefile
+++ b/www/drupal6-nice_menus/Makefile
@@ -19,5 +19,6 @@ MODULE_FILES= arrow-right.png nice_menus.install nice_menus_default-rtl.css \
superfish/js/jquery.hoverIntent.minified.js \
superfish/js/superfish.js
DOC_FILES= CHANGELOG.txt README.txt UPGRADE.txt LICENSE.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal6-nodewords/Makefile b/www/drupal6-nodewords/Makefile
index fe7ffa733b17..09df2a5be6d1 100644
--- a/www/drupal6-nodewords/Makefile
+++ b/www/drupal6-nodewords/Makefile
@@ -24,5 +24,6 @@ MODULE_FILES= includes/forum.inc includes/image.inc includes/node.inc \
nodewords_og/nodewords_og.install \
nodewords_og/nodewords_og.module
DOC_FILES= README.txt CHANGELOG.txt API.txt LICENSE.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal6-page_title/Makefile b/www/drupal6-page_title/Makefile
index 5f4dee4c2552..07f94295383e 100644
--- a/www/drupal6-page_title/Makefile
+++ b/www/drupal6-page_title/Makefile
@@ -23,5 +23,6 @@ MODULE_FILES= page_title-admin-settings-form.tpl.php page_title.install page_tit
MODULE_DIRS= modules views/plugins/ views tests
DOC_FILES= CHANGELOG.txt README.txt LICENSE.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal6-panels/Makefile b/www/drupal6-panels/Makefile
index 5be9e76e7d7f..b8ff71bf6549 100644
--- a/www/drupal6-panels/Makefile
+++ b/www/drupal6-panels/Makefile
@@ -188,5 +188,6 @@ MODULE_FILES= translations/panels.pot \
DOC_FILES= README.txt LICENSE.txt \
KNOWN_ISSUES.txt INSTALL.txt \
D6UPDATE.txt CHANGELOG.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal6-path_redirect/Makefile b/www/drupal6-path_redirect/Makefile
index 4e2f932a8ed5..eecf0452ea05 100644
--- a/www/drupal6-path_redirect/Makefile
+++ b/www/drupal6-path_redirect/Makefile
@@ -20,5 +20,6 @@ MODULE_FILES= generate/path_redirect_generate.drush.inc \
MODULE_DIRS= generate
DOC_FILES= LICENSE.txt README.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal6-pathauto/Makefile b/www/drupal6-pathauto/Makefile
index 2743e0a67414..81834df599cb 100644
--- a/www/drupal6-pathauto/Makefile
+++ b/www/drupal6-pathauto/Makefile
@@ -15,5 +15,6 @@ MODULE_FILES= pathauto.admin.inc pathauto.inc pathauto.install pathauto.module \
pathauto.test pathauto.api.php pathauto.info pathauto.js \
pathauto.pathauto.inc pathauto.tokens.inc
DOC_FILES= INSTALL.txt API.txt README.txt LICENSE.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal6-print/Makefile b/www/drupal6-print/Makefile
index ee3a2fee8acd..244066beee2c 100644
--- a/www/drupal6-print/Makefile
+++ b/www/drupal6-print/Makefile
@@ -30,5 +30,6 @@ MODULE_FILES= icons/mail_icon.gif icons/pdf_icon.gif icons/print_icon.gif \
translations/tr.po translations/uk.po
DOC_FILES= CHANGELOG.txt CREDITS.txt INSTALL.txt \
LICENSE.txt MAINTAINERS.txt README.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal6-seo_checklist/Makefile b/www/drupal6-seo_checklist/Makefile
index 98a7d5f06b18..4a41b7f68ded 100644
--- a/www/drupal6-seo_checklist/Makefile
+++ b/www/drupal6-seo_checklist/Makefile
@@ -11,5 +11,6 @@ COMMENT= Drupal module to provide checklist of actions for SEO
USES= drupal:6,module
MODULE_FILES= seochecklist.info seochecklist.install seochecklist.module
DOC_FILES= LICENSE.txt README.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal6-services/Makefile b/www/drupal6-services/Makefile
index 09ef7e7e567f..07d76c0aeca1 100644
--- a/www/drupal6-services/Makefile
+++ b/www/drupal6-services/Makefile
@@ -59,5 +59,6 @@ MODULE_FILES= auth/services_keyauth/services_keyauth.admin.inc \
services.resource-translation.inc services_admin_browse.inc
DOC_FILES= LICENSE.txt README.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal6-tagadelic/Makefile b/www/drupal6-tagadelic/Makefile
index 881567ea103c..8926704f5ac6 100644
--- a/www/drupal6-tagadelic/Makefile
+++ b/www/drupal6-tagadelic/Makefile
@@ -21,5 +21,6 @@ MODULE_FILES= tagadelic.css tagadelic.info tagadelic.install \
translations/nl.po translations/pl.po \
translations/ru.po translations/tagadelic.pot
DOC_FILES= LICENSE.txt README.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal6-token/Makefile b/www/drupal6-token/Makefile
index 26ef865d823a..3fb23b4bc517 100644
--- a/www/drupal6-token/Makefile
+++ b/www/drupal6-token/Makefile
@@ -21,5 +21,6 @@ MODULE_FILES= translations/token.pot translations/da.po translations/de.po \
MODULE_DIRS= translations
DOC_FILES= API.txt LICENSE.txt README.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal6-views/Makefile b/www/drupal6-views/Makefile
index 7fc3161021ae..bd68550da1f0 100644
--- a/www/drupal6-views/Makefile
+++ b/www/drupal6-views/Makefile
@@ -395,6 +395,7 @@ MODULE_FILES= css/views-admin.css \
DOC_FILES= LICENSE.txt README.txt CHANGELOG.txt \
documentation-standards.txt
+OPTIONS_DEFINE= DOCS
## Maintenance targets for creating lists of directories and files.
module-dirs: patch
diff --git a/www/drupal6-webform/Makefile b/www/drupal6-webform/Makefile
index ccb18abfd82d..a5234b05685d 100644
--- a/www/drupal6-webform/Makefile
+++ b/www/drupal6-webform/Makefile
@@ -74,5 +74,6 @@ MODULE_DIRS= components \
views
DOC_FILES= CHANGELOG.txt LICENSE.txt README.txt THEMING.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal6-wysiwyg/Makefile b/www/drupal6-wysiwyg/Makefile
index df7bb96a293a..1da8bd5002bb 100644
--- a/www/drupal6-wysiwyg/Makefile
+++ b/www/drupal6-wysiwyg/Makefile
@@ -65,6 +65,7 @@ MODULE_DIRS= editors/css editors/js editors plugins/break/images \
plugins/break/langs plugins/break plugins translations
DOC_FILES= CHANGELOG.txt README.txt LICENSE.txt
+OPTIONS_DEFINE= DOCS
post-install:
${LN} -s ${PREFIX}/${TINYMCEDIR} ${STAGEDIR}${PREFIX}/${DRUPAL_MODDIR}
diff --git a/www/drupal6-zeropoint/Makefile b/www/drupal6-zeropoint/Makefile
index 1992202aae5b..ecdd1b39c936 100644
--- a/www/drupal6-zeropoint/Makefile
+++ b/www/drupal6-zeropoint/Makefile
@@ -140,5 +140,6 @@ MODULE_FILES= _custom/custom-style.css _custom/headerimg/credits.txt \
search-theme-form.tpl.php template.php theme-settings.php \
views-view.tpl.php zeropoint.info
DOC_FILES= CHANGELOG.txt LICENSE.txt README.txt
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/www/drupal7-wysiwyg/Makefile b/www/drupal7-wysiwyg/Makefile
index 1fdab3e502f0..e86865cd2b0e 100644
--- a/www/drupal7-wysiwyg/Makefile
+++ b/www/drupal7-wysiwyg/Makefile
@@ -12,7 +12,7 @@ COMMENT= Allows implementation of WYSIWYG editors for editing Drupal content
USES= drupal:7,module
-OPTIONS_DEFINE= TINYMCE3 CKEDITOR YUI
+OPTIONS_DEFINE= TINYMCE3 CKEDITOR YUI DOCS
TINYMCE3_DESC= Install TinyMCE3 Editor
CKEDITOR_DESC= Install CKEditor