aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2019-03-04 08:47:02 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2019-03-04 08:47:02 +0000
commitc7b6348f25bdd37efad9174c1cad940c2213badf (patch)
tree0ad26ba3fffeab149035ca7bdea01d30421b7f46
parentfca3a6a777e64ffa6eb9a77246c105868da89a72 (diff)
downloadports-c7b6348f25bdd37efad9174c1cad940c2213badf.tar.gz
ports-c7b6348f25bdd37efad9174c1cad940c2213badf.zip
Notes
-rw-r--r--math/libtommath/Makefile27
1 files changed, 12 insertions, 15 deletions
diff --git a/math/libtommath/Makefile b/math/libtommath/Makefile
index a90eb76d0d3d..dfda7b71815f 100644
--- a/math/libtommath/Makefile
+++ b/math/libtommath/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libtommath
DISTVERSION= 1.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= https://github.com/libtom/libtommath/releases/download/v${DISTVERSION}/
DISTNAME= ltm-${DISTVERSION}
@@ -13,9 +13,12 @@ COMMENT= Comprehensive, modular, and portable mathematical routines
LICENSE= UNLICENSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= gmake tar:xz
+USES= gmake libtool:build tar:xz
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
+USE_LDCONFIG= yes
+
+MAKEFILE= makefile.shared
ALL_TARGET= default
CFLAGS+= -fPIC
PORTDOCS= *
@@ -23,19 +26,13 @@ PORTDOCS= *
PLIST_FILES= include/tommath.h \
include/tommath_class.h \
include/tommath_superclass.h \
- lib/libtommath.a
-
-OPTIONS_DEFINE= DOCS SHARED
+ lib/libtommath.a \
+ lib/libtommath.so \
+ lib/libtommath.so.${DISTVERSION:R:R} \
+ lib/libtommath.so.${DISTVERSION} \
+ libdata/pkgconfig/libtommath.pc
-SHARED_DESC= Build shared library
-SHARED_USES= libtool:build
-SHARED_USE= LDCONFIG=yes
-SHARED_PLIST_FILES= lib/libtommath.so \
- lib/libtommath.so.${DISTVERSION:R:R} \
- lib/libtommath.so.${DISTVERSION} \
- libdata/pkgconfig/libtommath.pc
-SHARED_VARS= MAKEFILE=makefile.shared
-SHARED_VARS_OFF= MAKEFILE=makefile
+OPTIONS_DEFINE= DOCS
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@@ -48,7 +45,7 @@ post-install-SHARED-on:
do-test:
(cd ${WRKSRC}; \
- ${SETENV} ${MAKE_ENV} ${MAKE_CMD} -f ${MAKEFILE} mtest/mtest test; \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} -f makefile mtest/mtest test; \
./mtest/mtest | ./test)
.include <bsd.port.mk>