aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-06-21 13:04:45 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-06-21 13:04:45 +0000
commitc7f6e44a89db5eb11e00bc8ff4bf39ef4bdae54b (patch)
tree9974f3efd63d9c94d9cde9fba9601cd3bfa5c97b
parent59c3c814afa2a0575c9350988a81e7ec251b26be (diff)
downloadports-c7f6e44a89db5eb11e00bc8ff4bf39ef4bdae54b.tar.gz
ports-c7f6e44a89db5eb11e00bc8ff4bf39ef4bdae54b.zip
Notes
-rw-r--r--www/links/Makefile33
1 files changed, 17 insertions, 16 deletions
diff --git a/www/links/Makefile b/www/links/Makefile
index 4fec8f27e9ec..42fa5cd1ca42 100644
--- a/www/links/Makefile
+++ b/www/links/Makefile
@@ -36,20 +36,6 @@ OPTIONS_DEFAULT= IPV6 UTF8 X11
PLIST_FILES= bin/links man/man1/links.1.gz
-.include <bsd.port.options.mk>
-
-#CIPHERSTRING must be a valid OpenSSL cipher string(see ciphers(1)):
-CIPHERSTRING?= HIGH:!SSLv2:!aNULL:!eNULL:@STRENGTH
-
-.if ${PORT_OPTIONS:MDIRECTFB} || ${PORT_OPTIONS:MSVGALIB} || ${PORT_OPTIONS:MX11}
-LIB_DEPENDS+= libpng.so:${PORTSDIR}/graphics/png \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libtiff.so:${PORTSDIR}/graphics/tiff
-CONFIGURE_ARGS+= --enable-graphics
-.else
-CONFIGURE_ARGS+= --disable-graphics --without-libjpeg --without-libtiff
-.endif
-
DIRECTFB_LIB_DEPENDS= libdirectfb.so:${PORTSDIR}/devel/directfb
DIRECTFB_CONFIGURE_WITH=directfb
@@ -63,11 +49,26 @@ THREADS_LDFLAGS=-pthread
TRANS_EXTRA_PATCHES= ${FILESDIR}/extra-terminal.c.diff
-UTF8_CONFIGURE_WITH= utf8
+UTF8_CONFIGURE_ENABLE= utf8
-X11_USE= xorg=x11,proto
+X11_USE= xorg=x11,xproto
X11_CONFIGURE_WITH= x
X11_PLIST_FILES= share/pixmaps/links.xpm
+
+.include <bsd.port.options.mk>
+
+#CIPHERSTRING must be a valid OpenSSL cipher string(see ciphers(1)):
+CIPHERSTRING?= HIGH:!SSLv2:!aNULL:!eNULL:@STRENGTH
+
+.if ${PORT_OPTIONS:MDIRECTFB} || ${PORT_OPTIONS:MSVGALIB} || ${PORT_OPTIONS:MX11}
+LIB_DEPENDS+= libpng.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libtiff.so:${PORTSDIR}/graphics/tiff
+CONFIGURE_ARGS+= --enable-graphics
+.else
+CONFIGURE_ARGS+= --disable-graphics --without-libjpeg --without-libtiff
+.endif
+
.if ${PORT_OPTIONS:MX11}
DESKTOP_ENTRIES="links" \
"Lynx-like text WWW browser" \