aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2004-03-05 23:22:20 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2004-03-05 23:22:20 +0000
commitc91b9f861e3792132e6befc490f2e8d80fcc9c9e (patch)
tree7ab77c2b7dbee4e9bf7c9aafe79a06108e5f1322
parent626d9e14d8880c81b558af843bf7572e4e4facd5 (diff)
downloadports-c91b9f861e3792132e6befc490f2e8d80fcc9c9e.tar.gz
ports-c91b9f861e3792132e6befc490f2e8d80fcc9c9e.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/happystats/Makefile41
-rw-r--r--net/happystats/distinfo2
-rw-r--r--net/happystats/files/patch-Makefile23
-rw-r--r--net/happystats/pkg-descr4
-rw-r--r--net/happystats/pkg-plist16
6 files changed, 87 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ed94079b8add..e01e92b147f8 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -181,6 +181,7 @@
SUBDIR += gutenfetch
SUBDIR += gyach
SUBDIR += hagelslag
+ SUBDIR += happystats
SUBDIR += haproxy
SUBDIR += hawk
SUBDIR += hf6to4
diff --git a/net/happystats/Makefile b/net/happystats/Makefile
new file mode 100644
index 000000000000..fcf1fe0f4ab0
--- /dev/null
+++ b/net/happystats/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: happystats
+# Date created: 2004-01-12
+# Whom: Xavier Beaudouin <kiwi@oav.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= happystats
+PORTVERSION= 0.5.0
+CATEGORIES= net
+MASTER_SITES= http://www.happystats.org/srcs/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= kiwi@oav.net
+COMMENT= Universal log converter into graph
+
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
+ xml2.5:${PORTSDIR}/textproc/libxml2 \
+ rrd.0:${PORTSDIR}/net/rrdtool \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+MAN1= happystats.1
+MANCOMPRESSED= yes
+DOCS= AUTHORS INSTALL TODO
+
+do-configure:
+ @cd ${WRKSRC} && ${MAKE} dep
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/happystats ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/happystats.1.gz ${MAN1PREFIX}/man/man1
+ @${MKDIR} ${PREFIX}/www/cgi-bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/happystats.cgi ${PREFIX}/www/cgi-bin
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/samples/* ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/happystats/distinfo b/net/happystats/distinfo
new file mode 100644
index 000000000000..e81289618629
--- /dev/null
+++ b/net/happystats/distinfo
@@ -0,0 +1,2 @@
+MD5 (happystats-0.5.0.tgz) = f2b015b6998e22266f363bbd0ff6c69f
+SIZE (happystats-0.5.0.tgz) = 38289
diff --git a/net/happystats/files/patch-Makefile b/net/happystats/files/patch-Makefile
new file mode 100644
index 000000000000..3a41d0c396a2
--- /dev/null
+++ b/net/happystats/files/patch-Makefile
@@ -0,0 +1,23 @@
+--- Makefile.orig Sat Mar 6 01:22:22 2004
++++ Makefile Sat Mar 6 01:24:19 2004
+@@ -1,15 +1,9 @@
+ # $Id: Makefile,v 1.4 2004/02/22 12:26:25 ofredj Exp $ #
+
+-PREFIX=/usr/local
+-CC=gcc
+-LD=/usr/bin/ld
+-#DEBUG=-ggdb
+-CARGS=-O2 -pipe -ansi -Wall -pedantic
+-COPTS= -ffast-math -ffloat-store -funroll-all-loops -funroll-loops
+-IFLAGS=-I/usr/local/include `xml2-config --cflags`
+-LDFLAGS=-L/usr/local/lib/ -lpcre -lrrd `xml2-config --libs`
+-CFLAGS=${CARGS} ${IFLAGS} ${COPTS}
++IFLAGS=`xml2-config --cflags`
++LDFLAGS+=`xml2-config --libs` -lpcre -lrrd -lgnugetopt
++CFLAGS+=${CPPFLAGS} ${IFLAGS}
+
+ SRCS= getopt.c date.c file.c common.c xmlparser.c pcre.c rrd.c main.c syslog.c ims.c exim.c clf.c alerts.c smtpclient.c
+ OBJS= getopt.o date.o file.o common.o xmlparser.o pcre.o rrd.o main.o syslog.o ims.o exim.o clf.o alerts.o smtpclient.o
+
+ CGISRCS= cgi_xmlparser.c cgi.c rrdgraph.c
+ CGIOBJS= file.o common.o cgi_xmlparser.o cgi.o rrdgraph.o
diff --git a/net/happystats/pkg-descr b/net/happystats/pkg-descr
new file mode 100644
index 000000000000..2b3fd505f31a
--- /dev/null
+++ b/net/happystats/pkg-descr
@@ -0,0 +1,4 @@
+Happystats is a universal tool to convert logs into graphs.
+Useful for mail stats for example.
+
+WWW: http://www.happystats.org/
diff --git a/net/happystats/pkg-plist b/net/happystats/pkg-plist
new file mode 100644
index 000000000000..e090dc0493aa
--- /dev/null
+++ b/net/happystats/pkg-plist
@@ -0,0 +1,16 @@
+
+@comment $FreeBSD$
+bin/happystats
+www/cgi-bin/happystats.cgi
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%EXAMPLESDIR%%/happystats.conf
+%%EXAMPLESDIR%%/happystats.courrier.xml
+%%EXAMPLESDIR%%/happystats.exim.natif.xml
+%%EXAMPLESDIR%%/happystats.exim.syslog.xml
+%%EXAMPLESDIR%%/happystats.ims.xml
+%%EXAMPLESDIR%%/happystats.postfix.xml
+%%EXAMPLESDIR%%/happystats.sendmail.xml
+@dirrm %%EXAMPLESDIR%%