aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-07-23 10:28:03 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-07-23 10:28:03 +0000
commitc958a485819003ec24c1ea1b01940ea7c953115e (patch)
tree544858c7e8531f55637ace19f7fe9ce4ac601ede
parenta0b1f9f804c55b43a404082d192042d7b0e7f832 (diff)
downloadports-c958a485819003ec24c1ea1b01940ea7c953115e.tar.gz
ports-c958a485819003ec24c1ea1b01940ea7c953115e.zip
Remove two libtool fixes from Mk/Uses/libtool.mk. They don't always work
when an older version of a package is installed. This is the case when an executable links with installed libraries and with uninstalled libraries that link with other uninstalled libraries. For each of the directly linked libraries the executable will have an rpath (/usr/local/lib for the installed libraries and a path under WRKDIR for each of the uninstalled libraries), but not for the indirect libraries. Both ld(1) and rtld(1) search the rpath of the executable first before any rpath of libraries, so the indirectly linked libraries will be found in /usr/local/lib if they are installed instead of in WRKDIR. With this commit executables will overlink with uninstalled indirect libraries again so their location is added to the rpath of the executable. This partially reverts r358784. PR: 191611 Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=362656
-rw-r--r--Mk/Uses/libtool.mk4
-rw-r--r--archivers/rpm4/Makefile4
-rw-r--r--databases/evolution-data-server/Makefile18
-rw-r--r--databases/gdbm/Makefile2
-rw-r--r--devel/anjuta/Makefile9
-rw-r--r--devel/gettext/files/patch-gettext-tools_src_Makefile.in42
-rw-r--r--devel/gitg0/Makefile4
-rw-r--r--devel/gnome-vfs/Makefile2
-rw-r--r--devel/libbonobo/files/patch-samples-echo-Makefile.in10
-rw-r--r--devel/libgii/Makefile4
-rw-r--r--devel/ois/Makefile3
-rw-r--r--graphics/devil/Makefile2
-rw-r--r--graphics/geomview/Makefile2
-rw-r--r--graphics/libggi/Makefile15
-rw-r--r--graphics/libgnomecanvas/files/patch-demos-Makefile.in10
-rw-r--r--graphics/swfdec/Makefile4
-rw-r--r--irc/xchat/Makefile2
-rw-r--r--mail/evolution/Makefile8
-rw-r--r--multimedia/mjpegtools/files/patch-mplex__Makefile.in11
-rw-r--r--net/gtk-vnc/Makefile4
-rw-r--r--net/libgweather/Makefile3
-rw-r--r--security/sssd/Makefile1
-rw-r--r--sysutils/tracker-client/Makefile4
-rw-r--r--www/gtkhtml3/Makefile2
-rw-r--r--x11-toolkits/gdl/Makefile4
-rw-r--r--x11-toolkits/libgdiplus/Makefile5
-rw-r--r--x11-toolkits/open-motif/Makefile62
-rw-r--r--x11-wm/mutter/Makefile2
-rw-r--r--x11/gnome-panel/Makefile2
29 files changed, 2 insertions, 243 deletions
diff --git a/Mk/Uses/libtool.mk b/Mk/Uses/libtool.mk
index 75ce5c6ff343..d99b2f07765d 100644
--- a/Mk/Uses/libtool.mk
+++ b/Mk/Uses/libtool.mk
@@ -35,10 +35,6 @@ patch-libtool:
@${FIND} ${WRKDIR} -type f -name ltmain.sh | \
${XARGS} ${REINPLACE_CMD} \
- -e '/link) libs=/s/ $$dependency_libs//' \
- -e '/elif.*linkmode.*prog.*linkmode.*lib/,/continue/ { \
- /elif/,/fi/ { /elif/ { h; d; }; H; d; }; \
- /continue/ { H; g; }; }' \
-e '/if.*linkmode.*prog.*mode.*!= relink/s/if.*;/if :;/'\
-e '/if.*linkmode.*prog.*mode.* = relink/s/||.*;/;/' \
-e 's/|-p|-pg|/|-B*|-p|-pg|/'
diff --git a/archivers/rpm4/Makefile b/archivers/rpm4/Makefile
index 23e75a064bd4..4f5e27345e04 100644
--- a/archivers/rpm4/Makefile
+++ b/archivers/rpm4/Makefile
@@ -57,9 +57,7 @@ CONFIGURE_ENV+= LUA_CFLAGS=-I${LUA_INCDIR} \
PLIST_SUB+= VERSION=${PORTVERSION}
post-patch:
- ${REINPLACE_CMD} \
- -e '/_LDADD =/s/=/= @LTLIBINTL@/' \
- -e 's:\.\./\.\./bin/::' ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e 's:\.\./\.\./bin/::' ${WRKSRC}/Makefile.in
${REINPLACE_CMD} -e 's/(hpux)/& || defined(__FreeBSD__)/' \
${WRKSRC}/misc/fts.?
${REINPLACE_CMD} -e 's/ __GLIBC__.*/& || defined(__FreeBSD__)/' \
diff --git a/databases/evolution-data-server/Makefile b/databases/evolution-data-server/Makefile
index 6025c16fdfc5..bae9f77ea691 100644
--- a/databases/evolution-data-server/Makefile
+++ b/databases/evolution-data-server/Makefile
@@ -68,23 +68,5 @@ post-patch:
s|-Wl,--no-undefined||g ; \
s|-Wmissing-include-dirs||g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} '/^e_addressbook_factory_LDADD =/ \
- s/=/= -lgio-2.0 -lgobject-2.0 -lgthread-2.0 -lglib-2.0 $$(INTLLIBS)/' \
- ${WRKSRC}/addressbook/libedata-book/Makefile.in
- @${REINPLACE_CMD} '/^test_interval_searches_LDADD =/s/=/= -lgthread-2.0/' \
- ${WRKSRC}/calendar/backends/file/Makefile.in
- @${REINPLACE_CMD} -e '/^test_e_sexp_LDADD =/s/=/= -lical/' \
- -e '/^test_intervaltree_LDADD =/s/=/= -lical/' \
- -e '/^e_calendar_factory_LDADD =/s|=|= ../libecal/libecal-1.2.la -lical|' \
- ${WRKSRC}/calendar/libedata-cal/Makefile.in
- @${REINPLACE_CMD} '/^camel_index_control_1_2_LDADD =/s/=/= -lgthread-2.0/' \
- ${WRKSRC}/camel/Makefile.in
- @${REINPLACE_CMD} '/^test_imapx_LDADD =/s/=/= -lgobject-2.0 -lgthread-2.0/' \
- ${WRKSRC}/camel/providers/imapx/Makefile.in
- @${REINPLACE_CMD} -e '/^test_contact_store_LDADD =/s|$$| ../addressbook/libebook/libebook-1.2.la|' \
- -e '/^test_name_selector_LDADD =/s|$$| ../camel/libcamel-1.2.la -lgthread-2.0|' \
- ${WRKSRC}/libedataserverui/Makefile.in
- @${REINPLACE_CMD} '/^soap_test_LDADD =/s/=/= -lgthread-2.0/' \
- ${WRKSRC}/servers/groupwise/Makefile.in
.include <bsd.port.mk>
diff --git a/databases/gdbm/Makefile b/databases/gdbm/Makefile
index 90ed753220f3..fc962f44218c 100644
--- a/databases/gdbm/Makefile
+++ b/databases/gdbm/Makefile
@@ -33,7 +33,5 @@ post-patch:
-e "s|BINOWN = bin|BINOWN = root|" -e "s|BINGRP = bin|BINGRP = wheel|" \
-e "s|libgdbm.la libgdbm_compat.la|libgdbm.la libgdbm_compat.la gdbm.info|" \
${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} '/_LDADD =/s/$$/ @LTLIBINTL@/' \
- ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>
diff --git a/devel/anjuta/Makefile b/devel/anjuta/Makefile
index d5c669a65a9d..0889890955bb 100644
--- a/devel/anjuta/Makefile
+++ b/devel/anjuta/Makefile
@@ -93,15 +93,6 @@ PLIST_SUB+= DEVHELP=""
post-patch:
@${RM} ${WRKSRC}/plugins/debug-manager/anjuta-debug-manager.schemas
- @${REINPLACE_CMD} '/^test_LDADD =/ \
- s/=/= -lgtk-x11-2.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0 -lxml2 $$(INTLLIBS)/' \
- ${WRKSRC}/plugins/gbf-am/Makefile.in
- @${REINPLACE_CMD} '/^gdbmi_test_LDADD =/s/$$/ -lgtk-x11-2.0 -lglib-2.0/' \
- ${WRKSRC}/plugins/gdb/Makefile.in
- @${REINPLACE_CMD} -e '/^anjuta_LDADD =/s/=/= $$(ANJUTA_LIBS)/' \
- -e '/^anjuta_shell_LDADD =/ \
- s/=/= -lgtk-x11-2.0 -lgobject-2.0 -lglib-2.0 $$(INTLLIBS)/' \
- ${WRKSRC}/src/Makefile.in
post-configure:
@${REINPLACE_CMD} -e 's|"make|"gmake|g' \
diff --git a/devel/gettext/files/patch-gettext-tools_src_Makefile.in b/devel/gettext/files/patch-gettext-tools_src_Makefile.in
deleted file mode 100644
index 7cfa89cbd6cd..000000000000
--- a/devel/gettext/files/patch-gettext-tools_src_Makefile.in
+++ /dev/null
@@ -1,42 +0,0 @@
---- gettext-tools/src/Makefile.in.orig
-+++ gettext-tools/src/Makefile.in
-@@ -1984,24 +1984,21 @@
- msgmerge_CXXFLAGS = $(AM_CXXFLAGS) $(OPENMP_CFLAGS)
-
- # Link dependencies.
--# INTL_MACOSX_LIBS is needed because the programs depend on libintl.la
--# but libtool doesn't put -Wl,-framework options into .la files.
--# For msginit, it is also needed because of localename.c.
--msgcmp_LDADD = libgettextsrc.la @INTL_MACOSX_LIBS@ @MSGMERGE_LIBM@ $(WOE32_LDADD)
--msgfmt_LDADD = libgettextsrc.la @INTL_MACOSX_LIBS@ $(WOE32_LDADD)
--msgmerge_LDADD = libgettextsrc.la @INTL_MACOSX_LIBS@ @MSGMERGE_LIBM@ $(WOE32_LDADD) $(OPENMP_CFLAGS)
--msgunfmt_LDADD = libgettextsrc.la @INTL_MACOSX_LIBS@ $(WOE32_LDADD)
--xgettext_LDADD = libgettextsrc.la @INTL_MACOSX_LIBS@ @LTLIBEXPAT@ @LTLIBICONV@ $(WOE32_LDADD)
--msgattrib_LDADD = libgettextsrc.la @INTL_MACOSX_LIBS@ $(WOE32_LDADD)
--msgcat_LDADD = libgettextsrc.la @INTL_MACOSX_LIBS@ $(WOE32_LDADD)
--msgcomm_LDADD = libgettextsrc.la @INTL_MACOSX_LIBS@ $(WOE32_LDADD)
--msgconv_LDADD = libgettextsrc.la @INTL_MACOSX_LIBS@ $(WOE32_LDADD)
--msgen_LDADD = libgettextsrc.la @INTL_MACOSX_LIBS@ $(WOE32_LDADD)
--msgexec_LDADD = libgettextsrc.la @INTL_MACOSX_LIBS@ $(WOE32_LDADD)
--msgfilter_LDADD = libgettextsrc.la @INTL_MACOSX_LIBS@ $(WOE32_LDADD)
--msggrep_LDADD = $(LIBGREP) libgettextsrc.la @INTL_MACOSX_LIBS@ $(WOE32_LDADD)
--msginit_LDADD = libgettextsrc.la @INTL_MACOSX_LIBS@ $(WOE32_LDADD)
--msguniq_LDADD = libgettextsrc.la @INTL_MACOSX_LIBS@ $(WOE32_LDADD)
-+msgcmp_LDADD = libgettextsrc.la ../gnulib-lib/libgettextlib.la @LTLIBINTL@ @MSGMERGE_LIBM@ $(WOE32_LDADD)
-+msgfmt_LDADD = libgettextsrc.la ../gnulib-lib/libgettextlib.la @LTLIBINTL@ $(WOE32_LDADD)
-+msgmerge_LDADD = libgettextsrc.la ../gnulib-lib/libgettextlib.la @LTLIBINTL@ @MSGMERGE_LIBM@ $(WOE32_LDADD) $(OPENMP_CFLAGS)
-+msgunfmt_LDADD = libgettextsrc.la ../gnulib-lib/libgettextlib.la @LTLIBINTL@ $(WOE32_LDADD)
-+xgettext_LDADD = libgettextsrc.la ../gnulib-lib/libgettextlib.la @LTLIBINTL@ @LTLIBEXPAT@ @LTLIBICONV@ $(WOE32_LDADD)
-+msgattrib_LDADD = libgettextsrc.la ../gnulib-lib/libgettextlib.la @LTLIBINTL@ $(WOE32_LDADD)
-+msgcat_LDADD = libgettextsrc.la ../gnulib-lib/libgettextlib.la @LTLIBINTL@ $(WOE32_LDADD)
-+msgcomm_LDADD = libgettextsrc.la ../gnulib-lib/libgettextlib.la @LTLIBINTL@ $(WOE32_LDADD)
-+msgconv_LDADD = libgettextsrc.la ../gnulib-lib/libgettextlib.la @LTLIBINTL@ $(WOE32_LDADD)
-+msgen_LDADD = libgettextsrc.la ../gnulib-lib/libgettextlib.la @LTLIBINTL@ $(WOE32_LDADD)
-+msgexec_LDADD = libgettextsrc.la ../gnulib-lib/libgettextlib.la @LTLIBINTL@ $(WOE32_LDADD)
-+msgfilter_LDADD = libgettextsrc.la ../gnulib-lib/libgettextlib.la @LTLIBINTL@ $(WOE32_LDADD)
-+msggrep_LDADD = $(LIBGREP) libgettextsrc.la ../gnulib-lib/libgettextlib.la @LTLIBINTL@ $(WOE32_LDADD)
-+msginit_LDADD = libgettextsrc.la ../gnulib-lib/libgettextlib.la @LTLIBINTL@ $(WOE32_LDADD)
-+msguniq_LDADD = libgettextsrc.la ../gnulib-lib/libgettextlib.la @LTLIBINTL@ $(WOE32_LDADD)
-
- # Specify when to relink the programs.
- msgcmp_DEPENDENCIES = libgettextsrc.la ../gnulib-lib/libgettextlib.la $(WOE32_LDADD)
diff --git a/devel/gitg0/Makefile b/devel/gitg0/Makefile
index 49a8cc6a0d82..dcced7b39d7c 100644
--- a/devel/gitg0/Makefile
+++ b/devel/gitg0/Makefile
@@ -35,8 +35,4 @@ NLS_CONFIGURE_ENABLE=nls
NLS_CPPFLAGS= -I${LOCALBASE}/include
NLS_LDFLAGS= -L${LOCALBASE}/lib
-post-patch:
- @${REINPLACE_CMD} '/shell_LDADD =/s/$$/ -lgio-2.0 -lgobject-2.0 -lglib-2.0/' \
- ${WRKSRC}/tests/Makefile.in ${WRKSRC}/tools/Makefile.in
-
.include <bsd.port.mk>
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index 7fa66954c524..a67634812777 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -88,8 +88,6 @@ post-patch:
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-DG_DISABLE_DEPRECATED||g' \
${WRKSRC}/*/Makefile.in
- @${REINPLACE_CMD} '/^gnomevfs_info_LDADD =/s/$$/ -lgobject-2.0/' \
- ${WRKSRC}/programs/Makefile.in
@${SED} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
< ${MASTERDIR}/pkg-install.in > ${PKGINSTALL}
@${SED} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
diff --git a/devel/libbonobo/files/patch-samples-echo-Makefile.in b/devel/libbonobo/files/patch-samples-echo-Makefile.in
deleted file mode 100644
index c30164fbca88..000000000000
--- a/devel/libbonobo/files/patch-samples-echo-Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- samples/echo/Makefile.in.orig
-+++ samples/echo/Makefile.in
-@@ -321,6 +321,7 @@
- bonobo_echo_2_LDADD = \
- libEcho.a \
- $(top_builddir)/bonobo/libbonobo-2.la \
-+ $(top_builddir)/bonobo-activation/libbonobo-activation.la \
- $(LIBBONOBO_LIBS) \
- $(INTLLIBS)
-
diff --git a/devel/libgii/Makefile b/devel/libgii/Makefile
index 757c58322cc4..435424e2b94c 100644
--- a/devel/libgii/Makefile
+++ b/devel/libgii/Makefile
@@ -54,10 +54,6 @@ CONFIGURE_ARGS+=--disable-vgl
PLIST_SUB+= VGL="@comment "
.endif
-post-patch:
- @${REINPLACE_CMD} '/^LDADD =/s,$$, $$(top_builddir)/gg/libgg.la,' \
- ${WRKSRC}/regress/gii/Makefile.in
-
post-install:
${MV} ${STAGEDIR}${PREFIX}/etc/ggi/libgii.conf ${STAGEDIR}${PREFIX}/etc/ggi/libgii.conf.sample
${MV} ${STAGEDIR}${PREFIX}/etc/ggi/filter/mouse ${STAGEDIR}${PREFIX}/etc/ggi/filter/mouse.sample
diff --git a/devel/ois/Makefile b/devel/ois/Makefile
index 9c60bade0f0b..4bc80a815146 100644
--- a/devel/ois/Makefile
+++ b/devel/ois/Makefile
@@ -25,7 +25,4 @@ LDFLAGS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/${PORTNAME}
-post-patch:
- @${REINPLACE_CMD} '/_LDADD =/s/$$/ -lX11/' ${WRKSRC}/demos/Makefile.am
-
.include <bsd.port.mk>
diff --git a/graphics/devil/Makefile b/graphics/devil/Makefile
index 7615cfd57044..46a57921b84c 100644
--- a/graphics/devil/Makefile
+++ b/graphics/devil/Makefile
@@ -94,8 +94,6 @@ CONFIGURE_ARGS+=--disable-altivec --disable-sse --disable-sse2 --disable-sse3
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS/s|docs||g' ${WRKSRC}/Makefile.am
- @${REINPLACE_CMD} -e '/^ilur_LDADD =/s|$$| $$(il_library)|' \
- ${WRKSRC}/bin/Makefile.am
@${REINPLACE_CMD} -e '/^pkgdir=/s|$$(libdir)/|$$(prefix)/libdata/|g' \
${WRKSRC}/data/Makefile.am
@${REINPLACE_CMD} -e 's|<malloc\.h>|<stdlib.h>|g' \
diff --git a/graphics/geomview/Makefile b/graphics/geomview/Makefile
index 17cd5f7f770f..42e5a2640124 100644
--- a/graphics/geomview/Makefile
+++ b/graphics/geomview/Makefile
@@ -34,8 +34,6 @@ post-patch:
'/^install-data-am:/s|install-info-am|| ; \
/install-man/s|install-nobase_infoimgDATA||' \
${WRKSRC}/doc/Makefile.in
- @${REINPLACE_CMD} '/^gvx_LDADD =/s/=/= $$(OPENGLLIBS)/' \
- ${WRKSRC}/src/bin/geomview/x11/Makefile.in
post-build:
@(cd ${WRKSRC}/doc && makeinfo --no-split --no-validate \
diff --git a/graphics/libggi/Makefile b/graphics/libggi/Makefile
index 1a076ad333e6..e8294ada5f44 100644
--- a/graphics/libggi/Makefile
+++ b/graphics/libggi/Makefile
@@ -72,21 +72,6 @@ CONFIGURE_ARGS+=--disable-vgagl --disable-svga
PLIST_SUB+= WITH_SVGALIB="@comment "
.endif
-post-patch:
- @${REINPLACE_CMD} '/^exttest1_LDADD =/s/$$/ -lgg/' \
- ${WRKSRC}/extensions/test/Makefile.in
- @${REINPLACE_CMD} '/^showaccel_LDADD =/ { \
- p; s/showaccel/palette/; p; s/palette/cbconsist/; }' \
- ${WRKSRC}/programs/check/Makefile.in
- @${REINPLACE_CMD} '/^cube3d_LDADD =/s/$$/ -lgii/' \
- ${WRKSRC}/programs/demos/Makefile.in
- @${REINPLACE_CMD} '/^LDADD =/s/$$/ -lgii/' \
- ${WRKSRC}/programs/regress/Makefile.in
- @${REINPLACE_CMD} '/^inputdump_LDADD =/s/$$/ -lgii/' \
- ${WRKSRC}/programs/util/Makefile.in
- @${REINPLACE_CMD} '/^ggiteleserver_LDADD =/s/$$/ -lgg/' \
- ${WRKSRC}/programs/util/ggiteleserver/Makefile.in
-
post-install:
${TOUCH} ${STAGEDIR}${PREFIX}/lib/ggi/default/fbdev/.keep
${TOUCH} ${STAGEDIR}${PREFIX}/lib/ggi/default/kgi/.keep
diff --git a/graphics/libgnomecanvas/files/patch-demos-Makefile.in b/graphics/libgnomecanvas/files/patch-demos-Makefile.in
deleted file mode 100644
index 348748913ea3..000000000000
--- a/graphics/libgnomecanvas/files/patch-demos-Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- demos/Makefile.in.orig
-+++ demos/Makefile.in
-@@ -255,6 +255,7 @@
-
- LDADD = \
- $(top_builddir)/libgnomecanvas/libgnomecanvas-2.la \
-+ $(LIBGNOMECANVAS_LIBS) \
- $(INTLLIBS)
-
- canvas_demo_SOURCES = \
diff --git a/graphics/swfdec/Makefile b/graphics/swfdec/Makefile
index f7fca275c4a5..f1ed41279e34 100644
--- a/graphics/swfdec/Makefile
+++ b/graphics/swfdec/Makefile
@@ -43,8 +43,6 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's|-Wmissing-include-dirs||g' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} '/^swfdec_test_LDADD =/s/$$/ -lgmodule-2.0/' \
- ${WRKSRC}/test/Makefile.in
+ ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index 430b57488480..a1087c589a57 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -97,8 +97,6 @@ PLIST_SUB+= TCL="@comment "
post-patch:
@${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
${WRKSRC}/src/common/*.[ch]
- @${REINPLACE_CMD} '/xchat_LDADD =/s/$$/ -lgmodule-2.0/' \
- ${WRKSRC}/src/fe-gtk/Makefile.in
# Create plugins directory even when no plugins are installed
post-install:
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index 634b3b495f95..c5088a2f2b7a 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -109,14 +109,6 @@ post-patch:
-e 's|-DG_DISABLE_DEPRECATED||g' \
-e 's|-Wmissing-include-dirs||g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} '/^evolution_alarm_notify_LDADD =/s/=/= -lgthread-2.0/' \
- ${WRKSRC}/calendar/gui/alarm-notify/Makefile.in
- @${REINPLACE_CMD} '/^evolution_settings_LDADD =/s/=/= -lgthread-2.0/' \
- ${WRKSRC}/capplet/Makefile.in
- @${REINPLACE_CMD} '/^evolution_backup_LDADD =/s/=/= -lgthread-2.0/' \
- ${WRKSRC}/plugins/backup-restore/Makefile.in
- @${REINPLACE_CMD} '/^evolution_LDADD =/s/=/= -lgthread-2.0/' \
- ${WRKSRC}/shell/Makefile.in
@${REINPLACE_CMD} -e 's|/usr|${LOCALBASE}|g' \
${WRKSRC}/plugins/bogo-junk-plugin/bf-junk-filter.c
@${REINPLACE_CMD} -e 's|/usr/sbin|${LOCALBASE}/bin|g' \
diff --git a/multimedia/mjpegtools/files/patch-mplex__Makefile.in b/multimedia/mjpegtools/files/patch-mplex__Makefile.in
deleted file mode 100644
index 264d24adeb29..000000000000
--- a/multimedia/mjpegtools/files/patch-mplex__Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- mplex/Makefile.in.orig
-+++ mplex/Makefile.in
-@@ -360,7 +360,7 @@
- libmplex2_la_CXXFLAGS =
- mplex_SOURCES = main.cpp
- mplex_DEPENDENCIES = libmplex2.la
--mplex_LDADD = libmplex2.la @LIBGETOPT_LIB@ $(LIBM_LIBS)
-+mplex_LDADD = libmplex2.la $(top_builddir)/utils/libmjpegutils.la @LIBGETOPT_LIB@ $(LIBM_LIBS)
- all: all-am
-
- .SUFFIXES:
diff --git a/net/gtk-vnc/Makefile b/net/gtk-vnc/Makefile
index 291f76f265d5..d2adafb2220b 100644
--- a/net/gtk-vnc/Makefile
+++ b/net/gtk-vnc/Makefile
@@ -27,8 +27,4 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-gtkglext=yes
INSTALL_TARGET= install-strip
-post-patch:
- @${REINPLACE_CMD} '/LDADD/s/GTK_CFLAGS/GTK_LIBS/' \
- ${WRKSRC}/examples/Makefile.in
-
.include <bsd.port.mk>
diff --git a/net/libgweather/Makefile b/net/libgweather/Makefile
index a0171cf96cbc..6a0bbb9cc7f2 100644
--- a/net/libgweather/Makefile
+++ b/net/libgweather/Makefile
@@ -28,7 +28,4 @@ INSTALL_TARGET= install-strip
GCONF_SCHEMAS= gweather.schemas
-post-patch:
- @${REINPLACE_CMD} '/noinst_PROGRAMS/,+1 d' ${WRKSRC}/libgweather/Makefile.in
-
.include <bsd.port.mk>
diff --git a/security/sssd/Makefile b/security/sssd/Makefile
index 89ce471e6ead..8b3f4aec8f7c 100644
--- a/security/sssd/Makefile
+++ b/security/sssd/Makefile
@@ -97,7 +97,6 @@ post-patch:
-e 's|install-data-hook install-dist_initSCRIPTS|install-dist_initSCRIPTS|g' \
-e 's|install-data-hook|notinstall-data-hook|g' \
-e 's| -lpam_misc||g' \
- -e '/^ldap_child_LDADD =/s|=|= $$(LTLIBINTL)|' \
${WRKSRC}/Makefile.am
@${REINPLACE_CMD} -e 's|/etc/sssd/|${ETCDIR}/|g' \
-e 's|/etc/openldap/|${LOCALBASE}/etc/openldap/|g' \
diff --git a/sysutils/tracker-client/Makefile b/sysutils/tracker-client/Makefile
index 1d7644900976..860c29a0081a 100644
--- a/sysutils/tracker-client/Makefile
+++ b/sysutils/tracker-client/Makefile
@@ -81,10 +81,6 @@ CONFIGURE_ARGS+= --disable-libtrackergtk --disable-gui \
post-patch:
@${REINPLACE_CMD} -e 's|libpng|libpng15|' ${WRKSRC}/configure
- @${REINPLACE_CMD} '/tracker_extract_LDADD =/s/=/= $$(DBUS_LIBS) $$(GIO_LIBS)/' \
- ${WRKSRC}/src/tracker-extract/Makefile.in
- @${REINPLACE_CMD} '/tracker_status_LDADD =/s/$$/ $$(DBUS_LIBS)/' \
- ${WRKSRC}/src/tracker-utils/Makefile.in
post-build:
.if defined(TRACKER_SLAVE) && ${TRACKER_SLAVE}=="libtrackergtk"
diff --git a/www/gtkhtml3/Makefile b/www/gtkhtml3/Makefile
index 521c26390d45..79f8c5b7d4af 100644
--- a/www/gtkhtml3/Makefile
+++ b/www/gtkhtml3/Makefile
@@ -41,8 +41,6 @@ post-patch:
s|-DGDK_DISABLE_DEPRECATED||g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|gtkhtml-editor-test[$$]|gtkhtml3-editor-test$$|' \
- -e '/^gtkhtml_editor_test_LDADD =/s/=/= @GTKHTML_LIBS@/' \
- -e 's/$$(GTHREAD_LIBS)/-lgthread-2.0/' \
${WRKSRC}/components/editor/Makefile.in
@${REINPLACE_CMD} -e 's|G_CONST_RETURN||g' \
${WRKSRC}/a11y/*.[ch]
diff --git a/x11-toolkits/gdl/Makefile b/x11-toolkits/gdl/Makefile
index c1b0b3462254..fe51f85de348 100644
--- a/x11-toolkits/gdl/Makefile
+++ b/x11-toolkits/gdl/Makefile
@@ -19,8 +19,4 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-post-patch:
- @${REINPLACE_CMD} '/^test_dock_LDADD =/s/$$/ $$(GDL_DEPENDENCIES_LIBS)/' \
- ${WRKSRC}/gdl/Makefile.in
-
.include <bsd.port.mk>
diff --git a/x11-toolkits/libgdiplus/Makefile b/x11-toolkits/libgdiplus/Makefile
index 0722ea319375..9a233c3f9e90 100644
--- a/x11-toolkits/libgdiplus/Makefile
+++ b/x11-toolkits/libgdiplus/Makefile
@@ -31,9 +31,4 @@ PLIST_FILES= lib/libgdiplus.a \
lib/libgdiplus.so.0.0.0 \
libdata/pkgconfig/libgdiplus.pc
-post-patch:
- @${REINPLACE_CMD} \
- '/^testgdi_LDADD =/s/$$/ $$(BASE_DEPENDENCIES_LIBS) -lX11/' \
- ${WRKSRC}/tests/Makefile.in
-
.include <bsd.port.mk>
diff --git a/x11-toolkits/open-motif/Makefile b/x11-toolkits/open-motif/Makefile
index 37425b0f10c0..e57e198cab25 100644
--- a/x11-toolkits/open-motif/Makefile
+++ b/x11-toolkits/open-motif/Makefile
@@ -50,68 +50,6 @@ post-patch:
${XARGS} ${REINPLACE_CMD} -e 's|special file|5| ; \
s|file formats|5|'
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/configure.ac
- @${REINPLACE_CMD} '/^mwm_LDADD =/s/$$/ -lXt -lXext -lX11/' \
- ${WRKSRC}/clients/mwm/Makefile.am
- @${REINPLACE_CMD} '/^uil_LDADD =/s/$$/ -lXt/' \
- ${WRKSRC}/clients/uil/Makefile.am
- @${REINPLACE_CMD} '/^LDADD =/s/\\*$$/ -lXt -lX11 &/' \
- ${WRKSRC}/clients/xmbind/Makefile.am \
- ${WRKSRC}/demos/doc/programGuide/ch05/Scale/Makefile.am \
- ${WRKSRC}/demos/doc/programGuide/ch06/combo_box/Makefile.am \
- ${WRKSRC}/demos/doc/programGuide/ch06/spin_box/Makefile.am \
- ${WRKSRC}/demos/doc/programGuide/ch08/Container/Makefile.am \
- ${WRKSRC}/demos/doc/programGuide/ch08/Notebook/Makefile.am \
- ${WRKSRC}/demos/doc/programGuide/ch16/Makefile.am \
- ${WRKSRC}/demos/doc/programGuide/ch17/simple_drag/Makefile.am \
- ${WRKSRC}/demos/doc/programGuide/ch17/simple_drop/Makefile.am \
- ${WRKSRC}/demos/programs/ColorSel/Makefile.am \
- ${WRKSRC}/demos/programs/Column/Makefile.am \
- ${WRKSRC}/demos/programs/Exm/simple_app/Makefile.am \
- ${WRKSRC}/demos/programs/Ext18List/Makefile.am \
- ${WRKSRC}/demos/programs/IconB/Makefile.am \
- ${WRKSRC}/demos/programs/TabStack/Makefile.am \
- ${WRKSRC}/demos/programs/Tree/Makefile.am \
- ${WRKSRC}/demos/programs/airport/Makefile.am \
- ${WRKSRC}/demos/programs/animate/Makefile.am \
- ${WRKSRC}/demos/programs/drag_and_drop/Makefile.am \
- ${WRKSRC}/demos/programs/draw/Makefile.am \
- ${WRKSRC}/demos/programs/filemanager/Makefile.am \
- ${WRKSRC}/demos/programs/fileview/Makefile.am \
- ${WRKSRC}/demos/programs/getsubres/Makefile.am \
- ${WRKSRC}/demos/programs/i18ninput/Makefile.am \
- ${WRKSRC}/demos/programs/panner/Makefile.am \
- ${WRKSRC}/demos/programs/periodic/Makefile.am \
- ${WRKSRC}/demos/programs/piano/Makefile.am \
- ${WRKSRC}/demos/programs/popups/Makefile.am \
- ${WRKSRC}/demos/programs/sampler2_0/Makefile.am \
- ${WRKSRC}/demos/programs/setdate/Makefile.am \
- ${WRKSRC}/demos/programs/workspace/Makefile.am \
- ${WRKSRC}/demos/unsupported/aicon/Makefile.am \
- ${WRKSRC}/demos/unsupported/dainput/Makefile.am \
- ${WRKSRC}/demos/unsupported/dogs/Makefile.am \
- ${WRKSRC}/demos/unsupported/motifshell/Makefile.am \
- ${WRKSRC}/demos/unsupported/xmapdef/Makefile.am \
- ${WRKSRC}/demos/unsupported/xmfonts/Makefile.am
- @${REINPLACE_CMD} '/^LDADD =/s/$$/ -lXt/' \
- ${WRKSRC}/demos/lib/Exm/wml/Makefile.am \
- ${WRKSRC}/demos/lib/Xmd/Makefile.am \
- ${WRKSRC}/demos/programs/ButtonBox/Makefile.am \
- ${WRKSRC}/demos/programs/Combo2/Makefile.am \
- ${WRKSRC}/demos/programs/FontSel/Makefile.am \
- ${WRKSRC}/demos/programs/Outline/Makefile.am \
- ${WRKSRC}/demos/programs/Paned/Makefile.am \
- ${WRKSRC}/demos/programs/hellomotif/Makefile.am \
- ${WRKSRC}/demos/programs/hellomotifi18n/Makefile.am \
- ${WRKSRC}/demos/programs/tooltips/Makefile.am \
- ${WRKSRC}/demos/unsupported/hellomotif/Makefile.am \
- ${WRKSRC}/demos/unsupported/xmforc/Makefile.am \
- ${WRKSRC}/demos/unsupported/xmform/Makefile.am
- @${REINPLACE_CMD} '/^LDADD =/s/\\*$$/ -lXt -lXext -lX11 &/' \
- ${WRKSRC}/demos/programs/Exm/app_in_c/Makefile.am \
- ${WRKSRC}/demos/programs/earth/Makefile.am \
- ${WRKSRC}/demos/programs/todo/Makefile.am
- @${REINPLACE_CMD} '/^wmldbcreate_LDADD =/s/$$/ -lXt/' \
- ${WRKSRC}/tools/wml/Makefile.am
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/x11-wm/mutter/Makefile b/x11-wm/mutter/Makefile
index b9d8c7b27902..40142d6c161d 100644
--- a/x11-wm/mutter/Makefile
+++ b/x11-wm/mutter/Makefile
@@ -32,7 +32,5 @@ GCONF_SCHEMAS= mutter.schemas
post-patch:
@${REINPLACE_CMD} -e 's|-Werror||g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} '/^mutter_LDADD =/s|$$| -lgmodule-2.0|' \
- ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>
diff --git a/x11/gnome-panel/Makefile b/x11/gnome-panel/Makefile
index eabc78bb5123..d2fb5e55be86 100644
--- a/x11/gnome-panel/Makefile
+++ b/x11/gnome-panel/Makefile
@@ -74,8 +74,6 @@ post-patch:
${WRKSRC}/help/fish/Makefile.in
@${REINPLACE_CMD} -e 's|python.* python2\.0|${PYTHON_VERSION}|g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} '/^panel_test_applets_LDADD =/s/=/= -lgmodule-2.0/' \
- ${WRKSRC}/gnome-panel/Makefile.in
.include <bsd.port.mk>