aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-02 17:03:02 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-02 17:03:02 +0000
commitc9c024ac0fa2622f53295f1b823d49d996ba0e33 (patch)
tree40b4f83e8b271c7266ba19e63b0ea4b3c8c6a437
parentf4c321326cbf0d0bc42557417727b9fdcfd21cdd (diff)
downloadports-c9c024ac0fa2622f53295f1b823d49d996ba0e33.tar.gz
ports-c9c024ac0fa2622f53295f1b823d49d996ba0e33.zip
Notes
-rw-r--r--print/Makefile1
-rw-r--r--print/mftrace/Makefile35
-rw-r--r--print/mftrace/distinfo1
-rw-r--r--print/mftrace/files/patch-GNUmakefile.in11
-rw-r--r--print/mftrace/pkg-comment1
-rw-r--r--print/mftrace/pkg-descr8
-rw-r--r--print/mftrace/pkg-plist3
-rw-r--r--print/pktrace/Makefile35
-rw-r--r--print/pktrace/distinfo1
-rw-r--r--print/pktrace/files/patch-GNUmakefile.in11
-rw-r--r--print/pktrace/pkg-comment1
-rw-r--r--print/pktrace/pkg-descr8
-rw-r--r--print/pktrace/pkg-plist3
13 files changed, 119 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 3c82dedd1ee2..bf0311d5ac32 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -143,6 +143,7 @@
SUBDIR += pkfonts360
SUBDIR += pkfonts400
SUBDIR += pkfonts600
+ SUBDIR += pktrace
SUBDIR += pnm2ppa
SUBDIR += poster
SUBDIR += preview-latex
diff --git a/print/mftrace/Makefile b/print/mftrace/Makefile
new file mode 100644
index 000000000000..4b92d96c85c4
--- /dev/null
+++ b/print/mftrace/Makefile
@@ -0,0 +1,35 @@
+# ex:ts=8
+# Ports collection makefile for: pktrace
+# Date created: Jun w, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= pktrace
+PORTVERSION= 1.0.4
+CATEGORIES= print
+MASTER_SITES= http://www.cs.uu.nl/~hanwen/pktrace/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+RUN_DEPENDS= mktextfm:${PORTSDIR}/print/teTeX \
+ autotrace:${PORTSDIR}/graphics/autotrace \
+ t1asm:${PORTSDIR}/print/t1utils \
+ pfaedit:${PORTSDIR}/print/pfaedit
+
+USE_PYTHON= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+
+MAN1= pktrace.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gf2pbm ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/pktrace ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/pktrace.1 ${MANPREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/tfm.py ${PYTHON_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/print/mftrace/distinfo b/print/mftrace/distinfo
new file mode 100644
index 000000000000..3ee91ccde048
--- /dev/null
+++ b/print/mftrace/distinfo
@@ -0,0 +1 @@
+MD5 (pktrace-1.0.4.tar.gz) = e78cd41f09abf9558133263397498f7b
diff --git a/print/mftrace/files/patch-GNUmakefile.in b/print/mftrace/files/patch-GNUmakefile.in
new file mode 100644
index 000000000000..bb1450b4db9d
--- /dev/null
+++ b/print/mftrace/files/patch-GNUmakefile.in
@@ -0,0 +1,11 @@
+--- GNUmakefile.in.orig Sun Jun 2 23:51:33 2002
++++ GNUmakefile.in Sun Jun 2 23:52:07 2002
+@@ -23,7 +23,7 @@
+ compile: pktrace gf2pbm
+
+ gf2pbm: gf2pbm.c
+- gcc -O2 -Wall -o $@ $<
++ ${CC} ${CFLAGS} -I${LOCALBASE}/include -o $@ $< -L${LOCALBASE}/lib -lgnugetopt
+
+ README.txt: README.texi
+ makeinfo --no-split --no-headers --output $@ $<
diff --git a/print/mftrace/pkg-comment b/print/mftrace/pkg-comment
new file mode 100644
index 000000000000..e74a20dd392b
--- /dev/null
+++ b/print/mftrace/pkg-comment
@@ -0,0 +1 @@
+Scalable PostScript (Type1) Fonts for MetaFont
diff --git a/print/mftrace/pkg-descr b/print/mftrace/pkg-descr
new file mode 100644
index 000000000000..fb1590554a57
--- /dev/null
+++ b/print/mftrace/pkg-descr
@@ -0,0 +1,8 @@
+pktrace is a small Python program that lets you trace a TeX bitmap font into
+a PFA or PFB font (A PostScript Type1 Scalable Font).
+
+Type1 fonts offer many advantages over bitmaps, as they allow PostScript
+files to render correctly on printers with many resolutions. Moreover,
+Ghostscript can generate much better PDF, if given scalable fonts.
+
+WWW: http://www.cs.uu.nl/~hanwen/pktrace/
diff --git a/print/mftrace/pkg-plist b/print/mftrace/pkg-plist
new file mode 100644
index 000000000000..e49b08dc1961
--- /dev/null
+++ b/print/mftrace/pkg-plist
@@ -0,0 +1,3 @@
+bin/gf2pbm
+bin/pktrace
+lib/%%PYTHON_VERSION%%/site-packages/tfm.py
diff --git a/print/pktrace/Makefile b/print/pktrace/Makefile
new file mode 100644
index 000000000000..4b92d96c85c4
--- /dev/null
+++ b/print/pktrace/Makefile
@@ -0,0 +1,35 @@
+# ex:ts=8
+# Ports collection makefile for: pktrace
+# Date created: Jun w, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= pktrace
+PORTVERSION= 1.0.4
+CATEGORIES= print
+MASTER_SITES= http://www.cs.uu.nl/~hanwen/pktrace/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+RUN_DEPENDS= mktextfm:${PORTSDIR}/print/teTeX \
+ autotrace:${PORTSDIR}/graphics/autotrace \
+ t1asm:${PORTSDIR}/print/t1utils \
+ pfaedit:${PORTSDIR}/print/pfaedit
+
+USE_PYTHON= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+
+MAN1= pktrace.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gf2pbm ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/pktrace ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/pktrace.1 ${MANPREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/tfm.py ${PYTHON_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/print/pktrace/distinfo b/print/pktrace/distinfo
new file mode 100644
index 000000000000..3ee91ccde048
--- /dev/null
+++ b/print/pktrace/distinfo
@@ -0,0 +1 @@
+MD5 (pktrace-1.0.4.tar.gz) = e78cd41f09abf9558133263397498f7b
diff --git a/print/pktrace/files/patch-GNUmakefile.in b/print/pktrace/files/patch-GNUmakefile.in
new file mode 100644
index 000000000000..bb1450b4db9d
--- /dev/null
+++ b/print/pktrace/files/patch-GNUmakefile.in
@@ -0,0 +1,11 @@
+--- GNUmakefile.in.orig Sun Jun 2 23:51:33 2002
++++ GNUmakefile.in Sun Jun 2 23:52:07 2002
+@@ -23,7 +23,7 @@
+ compile: pktrace gf2pbm
+
+ gf2pbm: gf2pbm.c
+- gcc -O2 -Wall -o $@ $<
++ ${CC} ${CFLAGS} -I${LOCALBASE}/include -o $@ $< -L${LOCALBASE}/lib -lgnugetopt
+
+ README.txt: README.texi
+ makeinfo --no-split --no-headers --output $@ $<
diff --git a/print/pktrace/pkg-comment b/print/pktrace/pkg-comment
new file mode 100644
index 000000000000..e74a20dd392b
--- /dev/null
+++ b/print/pktrace/pkg-comment
@@ -0,0 +1 @@
+Scalable PostScript (Type1) Fonts for MetaFont
diff --git a/print/pktrace/pkg-descr b/print/pktrace/pkg-descr
new file mode 100644
index 000000000000..fb1590554a57
--- /dev/null
+++ b/print/pktrace/pkg-descr
@@ -0,0 +1,8 @@
+pktrace is a small Python program that lets you trace a TeX bitmap font into
+a PFA or PFB font (A PostScript Type1 Scalable Font).
+
+Type1 fonts offer many advantages over bitmaps, as they allow PostScript
+files to render correctly on printers with many resolutions. Moreover,
+Ghostscript can generate much better PDF, if given scalable fonts.
+
+WWW: http://www.cs.uu.nl/~hanwen/pktrace/
diff --git a/print/pktrace/pkg-plist b/print/pktrace/pkg-plist
new file mode 100644
index 000000000000..e49b08dc1961
--- /dev/null
+++ b/print/pktrace/pkg-plist
@@ -0,0 +1,3 @@
+bin/gf2pbm
+bin/pktrace
+lib/%%PYTHON_VERSION%%/site-packages/tfm.py