aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2023-08-10 08:46:27 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2023-08-10 08:57:45 +0000
commitc9d11048b0b560b861989fd1b8e2097e5c33dcf0 (patch)
tree670d88ac1330a1520e694c0778dc8930c0446ba3
parentbec734ebf9c87c964411edaa2687ae65b7092f64 (diff)
downloadports-c9d11048b0b560b861989fd1b8e2097e5c33dcf0.tar.gz
ports-c9d11048b0b560b861989fd1b8e2097e5c33dcf0.zip
-rw-r--r--x11/antimicro/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/x11/antimicro/Makefile b/x11/antimicro/Makefile
index 9dbb18eec795..494c7f71fbad 100644
--- a/x11/antimicro/Makefile
+++ b/x11/antimicro/Makefile
@@ -9,18 +9,20 @@ WWW= https://github.com/AntiMicro/antimicro
LICENSE= GPLv3
+DEPRECATED= Replaced by x11/antimicrox upstream no longer maintained
+EXPIRATION_DATE= 2023-10-01
+
+USES= cmake compiler:c++11-lang desktop-file-utils pkgconfig \
+ qt:5 sdl shared-mime-info xorg
USE_GITHUB= yes
GH_ACCOUNT= antimicro #Ryochan7
+USE_QT= core gui linguisttools:build qmake:build buildtools:build widgets network
+USE_SDL= sdl2
+USE_XORG= x11 xi xtst
# Upstream assumes ${LOCALBASE}/lib is part of the default linker path. Pull
# request 268 fixes it for X11 libraries, but SDL2 is still using pkg-config
# output (without full paths).
LDFLAGS+= -L${LOCALBASE}/lib
-USES= cmake compiler:c++11-lang desktop-file-utils pkgconfig \
- qt:5 sdl shared-mime-info xorg
-USE_XORG= x11 xi xtst
-USE_QT= core gui linguisttools:build qmake:build buildtools:build widgets network
-USE_SDL= sdl2
-
.include <bsd.port.mk>