aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-09-14 05:01:26 +0000
committerJohn Marino <marino@FreeBSD.org>2016-09-14 05:01:26 +0000
commitc9e5cedaeedd28e67787e9aaaf9c6c6f420341ab (patch)
treeceafc20a3a71aead4a28b134d3e17672260aec7a
parentf57eeed763c9419763d6a50e3bb74544fe2bd622 (diff)
downloadports-c9e5cedaeedd28e67787e9aaaf9c6c6f420341ab.tar.gz
ports-c9e5cedaeedd28e67787e9aaaf9c6c6f420341ab.zip
Notes
-rw-r--r--misc/fortune-mod-futurama/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/misc/fortune-mod-futurama/Makefile b/misc/fortune-mod-futurama/Makefile
index ef26cfd4d026..7fc515e49acf 100644
--- a/misc/fortune-mod-futurama/Makefile
+++ b/misc/fortune-mod-futurama/Makefile
@@ -11,24 +11,20 @@ MASTER_SITES= http://www.netmeister.org/apps/ \
MAINTAINER= freebsd@skysmurf.nl
COMMENT= Compilation of quotes from the TV series "Futurama"
+BUILD_DEPENDS= fortune_strfile:misc/fortune_strfile
+
USES= tar:bzip2
SUB_FILES= pkg-message
+STRFILE= ${LOCALBASE}/bin/fortune_strfile
PLIST_FILES= share/games/fortune/futurama share/games/fortune/futurama.dat
-.if exists(/usr/games/strfile)
-STRFILE= /usr/games/strfile
-.elif exists(/usr/bin/strfile)
-STRFILE= /usr/bin/strfile
-.else
-IGNORE= needs strfile command. Please install games distribution of base system
-.endif
-
do-build:
- @${STRFILE} ${WRKSRC}/futurama
+ ${STRFILE} ${WRKSRC}/futurama
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/share/games/fortune
- ${INSTALL_DATA} ${WRKSRC}/futurama* ${STAGEDIR}${PREFIX}/share/games/fortune
+ ${INSTALL_DATA} ${WRKSRC}/futurama* \
+ ${STAGEDIR}${PREFIX}/share/games/fortune
.include <bsd.port.mk>