aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-10-28 17:20:52 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-10-28 17:20:52 +0000
commitc9f5af52c8f2d69a75c3f814d6f7399cc4ae151b (patch)
tree2db88b34426dd0d61480fff1d202077e55b6c648
parent3c39c030cdbf6ba659a4ad1a19f536febf8e2974 (diff)
downloadports-c9f5af52c8f2d69a75c3f814d6f7399cc4ae151b.tar.gz
ports-c9f5af52c8f2d69a75c3f814d6f7399cc4ae151b.zip
Notes
-rw-r--r--audio/Makefile1
-rw-r--r--audio/p5-Audio-MPD/Makefile29
-rw-r--r--audio/p5-Audio-MPD/distinfo3
-rw-r--r--audio/p5-Audio-MPD/pkg-descr17
-rw-r--r--audio/p5-Audio-MPD/pkg-plist10
5 files changed, 60 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index d52fb0fbedbb..2f324fbd4a5c 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -480,6 +480,7 @@
SUBDIR += p5-Audio-Beep
SUBDIR += p5-Audio-CD
SUBDIR += p5-Audio-FLAC-Header
+ SUBDIR += p5-Audio-MPD
SUBDIR += p5-Audio-MPD-Common
SUBDIR += p5-Audio-Mixer
SUBDIR += p5-Audio-Musepack
diff --git a/audio/p5-Audio-MPD/Makefile b/audio/p5-Audio-MPD/Makefile
new file mode 100644
index 000000000000..119a48e53c1a
--- /dev/null
+++ b/audio/p5-Audio-MPD/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Audio-MPD
+# Date created: 28 Oct 2008
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Audio-MPD
+PORTVERSION= 0.19.4
+CATEGORIES= audio perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Class to talk to MPD (Music Player Daemon) servers
+
+BUILD_DEPENDS= p5-Audio-MPD-Common>=0:${PORTSDIR}/audio/p5-Audio-MPD-Common \
+ p5-Getopt-Euclid>=0:${PORTSDIR}/devel/p5-Getopt-Euclid \
+ p5-Proc-Daemon>=0:${PORTSDIR}/devel/p5-Proc-Daemon \
+ p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN1= mpd-dynamic.1
+MAN3= Audio::MPD.3 Audio::MPD::Collection.3 \
+ Audio::MPD::Playlist.3 Audio::MPD::Test.3
+
+.include <bsd.port.mk>
diff --git a/audio/p5-Audio-MPD/distinfo b/audio/p5-Audio-MPD/distinfo
new file mode 100644
index 000000000000..8741d0023d30
--- /dev/null
+++ b/audio/p5-Audio-MPD/distinfo
@@ -0,0 +1,3 @@
+MD5 (Audio-MPD-0.19.4.tar.gz) = 72292ffeb59e5c911963bd2e741c694b
+SHA256 (Audio-MPD-0.19.4.tar.gz) = 184617d3dcfd4b7eee8468b9523a0b0c1b0ca7ebf426f490a5a6915129f82837
+SIZE (Audio-MPD-0.19.4.tar.gz) = 45888
diff --git a/audio/p5-Audio-MPD/pkg-descr b/audio/p5-Audio-MPD/pkg-descr
new file mode 100644
index 000000000000..8785ba600eef
--- /dev/null
+++ b/audio/p5-Audio-MPD/pkg-descr
@@ -0,0 +1,17 @@
+Audio::MPD gives a clear object-oriented interface for talking to and
+controlling MPD (Music Player Daemon) servers. A connection to the MPD
+server is established as soon as a new Audio::MPD object is created.
+
+Note that the module will by default connect to mpd before sending any
+command, and will disconnect after the command has been issued. This scheme
+is far from optimal, but allows us not to care about timeout disconnections.
+
+/!\ Note that Audio::MPD is using high-level, blocking sockets. This means
+that if the mpd server is slow, or hangs for whatever reason, or even
+crash abruptly, the program will be hung forever in this sub. The
+POE::Component::Client::MPD module is way safer - you're advised to use it
+instead of Audio::MPD. Or you can try to set conntype to $REUSE (see
+Audio::MPD constructor for more details), but you would be then on your
+own to deal with disconnections.
+
+WWW: http://search.cpan.org/dist/Audio-MPD/
diff --git a/audio/p5-Audio-MPD/pkg-plist b/audio/p5-Audio-MPD/pkg-plist
new file mode 100644
index 000000000000..975164663ea0
--- /dev/null
+++ b/audio/p5-Audio-MPD/pkg-plist
@@ -0,0 +1,10 @@
+bin/mpd-dynamic
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/MPD/.packlist
+%%SITE_PERL%%/Audio/MPD/Collection.pm
+%%SITE_PERL%%/Audio/MPD/Playlist.pm
+%%SITE_PERL%%/Audio/MPD/Test.pm
+%%SITE_PERL%%/Audio/MPD.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/MPD
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio
+@dirrmtry %%SITE_PERL%%/Audio/MPD
+@dirrmtry %%SITE_PERL%%/Audio