aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-05-04 19:26:48 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-05-04 19:28:37 +0000
commitca0002209e949e0a2366401b10036d24cfc26f27 (patch)
tree081a121cf91900c98f4d90af2b73f7b67d8818c4
parent7e9e1b6c9e710d094c9f0d5707a673dbe07cb2af (diff)
downloadports-ca0002209e949e0a2366401b10036d24cfc26f27.tar.gz
ports-ca0002209e949e0a2366401b10036d24cfc26f27.zip
www/restinio: Convert post-extract to EXTRACT_AFTER_ARGS
PR: 278749
-rw-r--r--www/restinio/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/www/restinio/Makefile b/www/restinio/Makefile
index 7e38a4c54592..46ae99ba30d7 100644
--- a/www/restinio/Makefile
+++ b/www/restinio/Makefile
@@ -21,6 +21,18 @@ RUN_DEPENDS= libfmt>0:devel/libfmt \
USES= cmake:testing compiler:c++14-lang localbase:ldflags tar:bz2
+EXTRACT_AFTER_ARGS= --exclude dev/asio \
+ --exclude dev/asio_mxxru \
+ --exclude dev/catch2 \
+ --exclude dev/fmt \
+ --exclude dev/fmt_mxxru \
+ --exclude dev/nodejs/http_parser/http-parser.* \
+ --exclude dev/nodejs/http_parser_mxxru \
+ --exclude dev/rapidjson \
+ --exclude dev/rapidjson_mxxru \
+ --exclude dev/so_5 \
+ --exclude dev/timertt
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
WRKSRC_SUBDIR= dev
@@ -39,17 +51,4 @@ SAMPLES_CMAKE_BOOL= RESTINIO_SAMPLE RESTINIO_INSTALL_SAMPLES
SAMPLES_VARS_OFF= NO_ARCH=yes
SAMPLES_BUILD_DEPENDS= json-dto>0:devel/json-dto
-post-extract:
- ${RM} -rf ${WRKSRC}/asio
- ${RM} -rf ${WRKSRC}/asio_mxxru
- ${RM} -rf ${WRKSRC}/catch2
- ${RM} -rf ${WRKSRC}/fmt
- ${RM} -rf ${WRKSRC}/fmt_mxxru
- ${RM} -rf ${WRKSRC}/nodejs/http_parser/http-parser.*
- ${RM} -rf ${WRKSRC}/nodejs/http_parser_mxxru
- ${RM} -rf ${WRKSRC}/rapidjson
- ${RM} -rf ${WRKSRC}/rapidjson_mxxru
- ${RM} -rf ${WRKSRC}/so_5
- ${RM} -rf ${WRKSRC}/timertt
-
.include <bsd.port.mk>