aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-05-07 13:13:29 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-05-07 13:13:29 +0000
commitca634402783ffb655cb88fb7d5f3a01fca9a3ec3 (patch)
treec52fedeee9722cfa0a0041352fd6f76247cc6095
parentb41cd06b20f5ac2e6a5c0860425d9324e64e1ade (diff)
downloadports-ca634402783ffb655cb88fb7d5f3a01fca9a3ec3.tar.gz
ports-ca634402783ffb655cb88fb7d5f3a01fca9a3ec3.zip
Notes
-rw-r--r--net/ohphone/Makefile51
-rw-r--r--net/ohphone/distinfo6
-rw-r--r--net/ohphone/files/patch-main69
-rw-r--r--net/ohphone/pkg-plist9
4 files changed, 40 insertions, 95 deletions
diff --git a/net/ohphone/Makefile b/net/ohphone/Makefile
index 19369691a1c2..9dbd439357b7 100644
--- a/net/ohphone/Makefile
+++ b/net/ohphone/Makefile
@@ -6,38 +6,43 @@
#
PORTNAME= ohphone
-PORTVERSION= 1.4.1
-PORTREVISION= 2
+PORTVERSION= 1.4.5
CATEGORIES= net
-MASTER_SITES= http://www.openh323.org/bin/ \
- http://www.de.openh323.org/bin/ \
- http://www.ru.openh323.org/bin/
-DISTNAME= ${PORTNAME}_${PORTVERSION}
+MASTER_SITES= ftp://ftp.frm2.tum.de/pub/jpulz/FreeBSD/distfiles/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= Joerg.Pulz@frm2.tum.de
COMMENT= H323 Video Conferencing Program, compatible with NetMeeting
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/net/openh323-112:build
-
-BROKEN= Incomplete dependency list
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-NOCLEANDEPENDS= yes
+LIB_DEPENDS= h323_r.1:${PORTSDIR}/net/openh323
USE_BISON= yes
USE_XLIB= yes
USE_GMAKE= yes
-ALL_TARGET= optnoshared
-MAKE_ENV= PWLIBDIR=${WRKDIRPREFIX}${.CURDIR}/../../devel/pwlib152/work/pwlib \
- OPENH323DIR=${WRKDIRPREFIX}${.CURDIR}/../openh323-112/work/openh323
-THE_MACHTYPE= ${ARCH:S/i386/x86/}
-MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION} CPLUS=${CXX}
+ALL_TARGET= optshared
+MAKE_ENV= PWLIBDIR=${LOCALBASE}/share/pwlib \
+ OPENH323DIR=${LOCALBASE}/share/openh323 \
+ SYSLIBDIR=${LOCALBASE}/lib
+MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${ARCH:S/i386/x86/} \
+ OSRELEASE=${OSVERSION} CPLUS=${CXX}
+
MAN1= ohphone.1
-PLIST_FILES= bin/ohphone
+
+PLIST_SUB= PORTNAME=${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/openh323
+EXAMPLESDIR= ${PREFIX}/share/examples/openh323
+
+.include <bsd.port.pre.mk>
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/obj_${OPSYS}_${THE_MACHTYPE}_r/ohphone ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/obj_r/ohphone ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/ohphone.1 ${PREFIX}/man/man1
-
-.include <bsd.port.mk>
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/ReadMe.txt ${DOCSDIR}/${PORTNAME}
+.endif
+ ${MKDIR} ${EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/check_listen.awk ${EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/regtest ${EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/stresstest ${EXAMPLESDIR}/${PORTNAME}
+
+.include <bsd.port.post.mk>
diff --git a/net/ohphone/distinfo b/net/ohphone/distinfo
index 2ba519cfddb6..67ac77c7a5ec 100644
--- a/net/ohphone/distinfo
+++ b/net/ohphone/distinfo
@@ -1,3 +1,3 @@
-MD5 (ohphone_1.4.1.tar.gz) = f5b975db51589e2ed741367e20f75ed0
-SHA256 (ohphone_1.4.1.tar.gz) = 277987557f821b54126867a19312fe83444fe15fc035e83ddd6879ce87176355
-SIZE (ohphone_1.4.1.tar.gz) = 77085
+MD5 (ohphone-1.4.5.tar.gz) = 87328457be0a44d8805a4d4e10057092
+SHA256 (ohphone-1.4.5.tar.gz) = 62e3038341d940700d186f68fff9a4b38c891d7afc6562e5afa9c31789b96d3d
+SIZE (ohphone-1.4.5.tar.gz) = 75743
diff --git a/net/ohphone/files/patch-main b/net/ohphone/files/patch-main
deleted file mode 100644
index 4bb0c9d4db1f..000000000000
--- a/net/ohphone/files/patch-main
+++ /dev/null
@@ -1,69 +0,0 @@
-*** main.cxx.orig Mon Aug 4 05:07:54 2003
---- main.cxx Sat Aug 23 09:17:04 2003
-***************
-*** 501,507 ****
- #include <speexcodec.h>
- #include "h261codec.h"
- #include "h263codec.h"
-! #include "ffh263codec.h"
- #include "h323pdu.h"
- #include "g726codec.h"
- //#include "h323t120.h"
---- 501,507 ----
- #include <speexcodec.h>
- #include "h261codec.h"
- #include "h263codec.h"
-! //#include "ffh263codec.h"
- #include "h323pdu.h"
- #include "g726codec.h"
- //#include "h323t120.h"
-*************** BOOL MyH323EndPoint::Initialise(PConfigA
-*** 1519,1530 ****
- } \
- } \
-
-! #if H323_AVCODEC
-! ADD_VIDEO_CAPAB (H323_FFH263Capability);
-! #endif
-! #if H323_VICH263
-! ADD_VIDEO_CAPAB (H323_H263Capability);
-! #endif
-
- if (!videoReceiveDevice.IsEmpty()) {
- if (videoSize == 1) {
---- 1519,1530 ----
- } \
- } \
-
-! //#if H323_AVCODEC
-! // ADD_VIDEO_CAPAB (H323_FFH263Capability);
-! //#endif
-! //#if H323_VICH263
-! // ADD_VIDEO_CAPAB (H323_H263Capability);
-! //#endif
-
- if (!videoReceiveDevice.IsEmpty()) {
- if (videoSize == 1) {
-*************** void MyH323EndPoint::TestVideoGrabber(PC
-*** 3609,3618 ****
-
- if (cap->IsDescendant(H323_H261Capability::Class()))
- frame.SetPayloadType(RTP_DataFrame::H261);
-! #if H323_AVCODEC
-! else if (cap->IsDescendant(H323_FFH263Capability::Class()))
-! frame.SetPayloadType(RTP_DataFrame::DynamicBase);
-! #endif
- frameCount = 0;
- skipCount = 0;
- PINDEX bitsEncoded = 0;
---- 3609,3618 ----
-
- if (cap->IsDescendant(H323_H261Capability::Class()))
- frame.SetPayloadType(RTP_DataFrame::H261);
-! //#if H323_AVCODEC
-! // else if (cap->IsDescendant(H323_FFH263Capability::Class()))
-! // frame.SetPayloadType(RTP_DataFrame::DynamicBase);
-! //#endif
- frameCount = 0;
- skipCount = 0;
- PINDEX bitsEncoded = 0;
diff --git a/net/ohphone/pkg-plist b/net/ohphone/pkg-plist
new file mode 100644
index 000000000000..549e1fee9d71
--- /dev/null
+++ b/net/ohphone/pkg-plist
@@ -0,0 +1,9 @@
+bin/ohphone
+%%EXAMPLESDIR%%/%%PORTNAME%%/check_listen.awk
+%%EXAMPLESDIR%%/%%PORTNAME%%/regtest
+%%EXAMPLESDIR%%/%%PORTNAME%%/stresstest
+@dirrm %%EXAMPLESDIR%%/%%PORTNAME%%
+@dirrmtry %%EXAMPLESDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/%%PORTNAME%%/ReadMe.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/%%PORTNAME%%
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%